Bug 46130 - gpm initscript ignores nonstandard mouse device
Summary: gpm initscript ignores nonstandard mouse device
Status: CLOSED DUPLICATE of bug 41553
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gpm (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-27 01:35 UTC by Michael Chapman
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 01:35:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Chapman 2001-06-27 01:35:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5 i686; Nav)

Description of problem:
The gpm initscript (/etc/rc.d/init.d/gpm) ignores the setting of the DEVICE
variable in
/etc/sysconfig/gpm . If there is no /dev/mouse symlink or device node, this
script fails upon startup with:

gpm: oops() invoked from gpm.c(978)
/dev/mouse: No such file or directory

In the /etc/rc.d/init.d/gpm script, one of the if...then statements has the
wrong logic. To
fix, apply the following patch:

--- gpm.old     Wed Jun 27 11:22:22 2001
+++ gpm Wed Jun 27 11:22:30 2001
@@ -36,7 +36,7 @@
                MOUSETYPE=ms
        fi
 
-       if [ -n "$DEVICE" ]; then
+       if [ -z "$DEVICE" ]; then
            DEVICE="/dev/mouse"
        fi


How reproducible:
Always

Steps to Reproduce:
% su
Password:
# cd /dev
# mv mouse mouse1

... edit /etc/sysconfig/gpm so that it has the line
DEVICE="/dev/mouse1"

# /sbin/service gpm restart


Additional info:

I encountered this bug while configuring my system to use devfs. On most
systems, /dev/mouse mouse will be a symlink to the real mouse device (eg,
/dev/psaux), so this
bug will not be apparent.

Comment 1 Preston Brown 2001-07-19 16:02:15 UTC

*** This bug has been marked as a duplicate of 41553 ***


Note You need to log in before you can comment on or make changes to this bug.