Bug 41553 - gpm always uses /dev/mouse, ignoring DEVICE
gpm always uses /dev/mouse, ignoring DEVICE
Status: CLOSED DUPLICATE of bug 36995
Product: Red Hat Linux
Classification: Retired
Component: gpm (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
: 46130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 06:30 EDT by Keith Owens
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 07:52:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith Owens 2001-05-21 06:30:48 EDT
Description of Problem: /etc/rc.d/init.d/gpm always sets device /dev/mouse,
even when /etc/sysconfig/mouse sets DEVICE


How Reproducible: 100%


Steps to Reproduce:
1. Set DEVICE=/dev/ttyS0 in /etc/sysconfig/mouse
2. Point /dev/mouse somewhere other than ttyS0
3. Stop and start gpm, it still uses /dev/mouse

Actual Results: /dev/mouse is hardwired


Expected Results: Use DEVICE from /etc/sysconfig/mouse


Additional Information: Simple fix.  Change /etc/rc.d/init.d/gpm, line 39
from if [ -n "$DEVICE" ]; then to if [ -z "$DEVICE" ]; then
Comment 1 mfarhat 2001-05-29 07:52:26 EDT
confirmed.... and patch working...
Comment 2 Preston Brown 2001-06-25 13:19:18 EDT

*** This bug has been marked as a duplicate of 36995 ***
Comment 3 Preston Brown 2001-07-19 12:02:10 EDT
*** Bug 46130 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.