Bug 461517 - MonitoringConfig swaps password and db name
MonitoringConfig swaps password and db name
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
: 469347 (view as bug list)
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-09-08 15:20 EDT by Mike McCune
Modified: 2009-09-17 03:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2008-09-08 15:20:14 EDT
Once you get the Monitoring RPMs installed and try to configure monitoring you will notice on:

https://spacewalk.example.com/rhn/admin/config/MonitoringConfig.do

that the DB name shows up in the password field.  Saving this page doesn't seem to actually correct the problem and you get startup problems with Monitoring:

DBI connect('spacewalk','spacewalk',...) failed: ORA-12541: TNS:no listener (DBD ERROR: OCIServerAttach) at /usr/lib/perl5/site_perl/5.8.8/NOCpulse/NOCpulseini.pm line 60
2008-09-08 15:18:37 InstallSoftwareConfig:      !! ERROR:  connect failed: ORA-12541: TNS:no listener (DBD ERROR: OCIServerAttach)

Debug I added:
DBD: Oracle dbname: spacewalk username: spacewalk password: XE

Even after hard coding spacewalk/spacewalk@xe into the Perl code you then get:

2008-09-08 14:57:31 InstallSoftwareConfig: START HAD ERRORS 
2008-09-08 14:57:31 InstallSoftwareConfig: ============ STATUS ===============
2008-09-08 14:57:31 InstallSoftwareConfig: Last action: start
2008-09-08 14:57:31 InstallSoftwareConfig: WARNING: STARTED BUT *NOT* RUNNING
2008-09-08 14:57:31 InstallSoftwareConfig: ERRORS ENCOUNTERED DURING LAST ACTION:
2008-09-08 14:57:31 InstallSoftwareConfig:      !! Reference to nonexistent macro 'NPVAR'
Comment 1 Miroslav Suchý 2008-10-31 11:10:02 EDT
*** Bug 469347 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Suchý 2008-11-05 14:59:36 EST
Commited as 8655225da933934bff8cec5d8448d0bb09803fdb
and to master as f5911db27d211347454a058fe41022e1147e7f14

Funny thing is that this bug has been there for 2 years without notice.
Comment 3 Miroslav Suchý 2009-09-17 03:01:15 EDT
Spacewalk has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.