This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 461547 - gvfs has short memory
gvfs has short memory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 462059 (view as bug list)
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-09-08 20:52 EDT by Bastien Nocera
Modified: 2015-03-03 17:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 18:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-09-08 20:52:53 EDT
$ gvfs-mount smb://192.168.1.7/data2/
$ gvfs-mount -u smb://192.168.1.7/data2/
Error finding enclosing mount: The specified location is not mounted
$ gvfs-mount -l
Mount(0): data2 on 192.168.1.7 -> smb://192.168.1.7/data2/

Huh?
Comment 1 Bastien Nocera 2008-09-09 05:45:52 EDT
The user-visible effect will be to have nautilus complain about the mount being already mounted, instead of displaying the contents of the remote share.

This means SMB is unusable in nautilus as a result.
Comment 2 Alexander Larsson 2008-09-25 06:04:59 EDT
This should be fixed in gvfs 0.99.8 by:

2008-09-15  Tomas Bzatek  <tbzatek@redhat.com>

	* daemon/gvfsbackendsmb.c:
	Revert commit #1772.
	Set the information on the mount spec from the original URI
Comment 3 Bastien Nocera 2008-10-03 18:18:41 EDT
*** Bug 462059 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2008-10-03 18:20:15 EDT
This works fine now.

Note You need to log in before you can comment on or make changes to this bug.