Bug 462059 - Error when authenticating to a CIFS share
Error when authenticating to a CIFS share
Status: CLOSED DUPLICATE of bug 461547
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-09-12 05:36 EDT by Adam Huffman
Modified: 2015-03-03 17:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 18:18:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2008-09-12 05:36:01 EDT
Description of problem:

When I try to connect to a CIFS server to see the list of shares, the shares are listed.  When I try to open one of the shares, the authentication dialogue appears and I enter the credentials.  However, while an icon does appear on the desktop, I see this error message:

DBus error: org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered

and the files in the share are not accessible.

If I try to connect directly to a specific share on the CIFS server. again an icon appears on the desktop but I see this error message:

Could not display "smb://server/share". Unable to mount the location. 

Version-Release number of selected component (if applicable):

nautilus-2.23.92-1.fc10.x86_64
gvfs-0.99.7.1-2.fc10.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Try connecting to a CIFS share
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-09-16 21:07:26 EDT
Can you try again with gvfs 0.99.8, please ? 
It has a number of smb-related fixes.
Comment 2 Adam Huffman 2008-09-19 02:04:22 EDT
Have just updated to gvfs-0.99.8-4.  Now there is no D-Bus error and the share is mounted.  However, no files are visible within the share window.

I tried ls of the relevant directory created underneath ~/.gvfs, but that caused the mount to disappear:

[adam@vaio .gvfs]$ cd share\ on\ terastation/
[adam@vaio share on terastation]$ ls
ls: reading directory .: Software caused connection abort

Sep 19 07:02:48 vaio kernel: gvfs-fuse-daemo[3487]: segfault at 0 ip 00000000078a5c70 sp 00007fba0c0bed6
8 error 4 in libc-2.8.90.so[7823000+16c000]
Sep 19 07:02:48 vaio kernel: gvfsd-smb[6637]: segfault at 4 ip 00007fafc644316c sp 00007fffceacc220 erro
r 4 in libdbus-1.so.3.4.0[7fafc641f000+3c000]
Comment 3 Adam Huffman 2008-09-19 02:06:58 EDT
Have just updated to gvfs-0.99.8-4.  Now there is no D-Bus error and the share is mounted.  However, no files are visible within the share window.

I tried ls of the relevant directory created underneath ~/.gvfs, but that caused the mount to disappear:

[adam@vaio .gvfs]$ cd share\ on\ terastation/
[adam@vaio share on terastation]$ ls
ls: reading directory .: Software caused connection abort

Sep 19 07:02:48 vaio kernel: gvfs-fuse-daemo[3487]: segfault at 0 ip 00000000078a5c70 sp 00007fba0c0bed68 error 4 in libc-2.8.90.so[7823000+16c000]
Sep 19 07:02:48 vaio kernel: gvfsd-smb[6637]: segfault at 4 ip 00007fafc644316c sp 00007fffceacc220 error 4 in libdbus-1.so.3.4.0[7fafc641f000+3c000]
Comment 4 Tomáš Bžatek 2008-10-03 07:58:39 EDT
Adam, can you please post Samba version the server is running on?
Comment 5 Adam Huffman 2008-10-03 12:57:23 EDT
It's a Buffalo TeraStation Pro - I believe it's Samba 2.x.
Comment 6 Bastien Nocera 2008-10-03 18:18:41 EDT
the Fuse part of the bug is a different problem. The original problem (saying that the share was already mounted, and not displaying anything) was fixed in a later gvfs (and is a dupe of bug 461547).

*** This bug has been marked as a duplicate of bug 461547 ***
Comment 7 Adam Huffman 2008-10-03 19:13:29 EDT
In which version of gvfs is this fixed?  I'm currently running:

gvfs-gphoto2-1.0.1-4.fc10.x86_64
gvfs-1.0.1-4.fc10.x86_64
gvfs-smb-1.0.1-4.fc10.x86_64
gvfs-archive-1.0.1-4.fc10.x86_64
gvfs-debuginfo-0.99.4-1.fc10.x86_64
gvfs-fuse-1.0.1-4.fc10.x86_64
gvfs-obexftp-1.0.1-4.fc10.x86_64

and the problem is still there i.e. the share is mounted but no files are visible.
Comment 8 Bastien Nocera 2008-10-05 23:53:45 EDT
The original bug was about a dbus error, which is fixed...
If you can't see the actual files (or folders) on the share, please file a separate bug.
Comment 9 Tomáš Bžatek 2008-10-06 05:07:11 EDT
Adam, if that's Samba 2.x, your issue is actually bug 443047. The same issue was discussed in bug 450708 as well.

Note You need to log in before you can comment on or make changes to this bug.