Bug 461657 - FC10a yum madwifi issue. Atheros Wireless Card.
FC10a yum madwifi issue. Atheros Wireless Card.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 15:02 EDT by jchangstrom
Modified: 2014-01-21 18:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 15:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jchangstrom 2008-09-09 15:02:32 EDT
Description of problem:

I've upgraded from FC9 to FC10a (rawhide) on my laptop. It's a toshiba satalite A135-S4656.  When I originally installed FC9, I had troubles getting my wireless card to work.  After a little reading I found that by installed madwifi, this was easily corrected.  After my upgrade however, the wireless became unusable again.  I haven't done a whole lot of research on it yet.  The problem I'm having now is when I run yum update I get the following:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
kernel-uname-r is needed by (installed) kmod-madwifi-2.6.25.11-97.fc9.i686-0.9.4-38.lvn9.i686
kernel-uname-r is needed by (installed) kmod-madwifi-2.6.25.14-108.fc9.i686-0.9.4-39.lvn9.i686
Complete!
(1, [u'Please report this error in bugzilla'])

I'm assuming I'me getting this error because I had to disable the livna repos.  I've tried enabling the livna-devel repo but still no such luck.

I've tried yum clean all and then retrying but no go.

I have the following for a wireless card:

# lspci | grep -i wire*
04:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Please let me know if I can get you any other additional information to help you resolve this issue.
Comment 1 jchangstrom 2008-09-10 10:31:44 EDT
I have worked around the problem by doing the following:

yum erase madwifi
yum update
yum install madwifi
Comment 2 Christopher D. Stover 2008-10-22 15:04:27 EDT
You got this error because you had two versions of kmod-madwifi installed.  Reference https://bugzilla.redhat.com/show_bug.cgi?id=460548 for more info.  I'm closing this ticket as well since it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.