Bug 461751 - nForce ethernet interface on ASUS M3N78-EMH HDMI is not detected
nForce ethernet interface on ASUS M3N78-EMH HDMI is not detected
Status: CLOSED DUPLICATE of bug 479740
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: 5.4
Assigned To: Ivan Vecera
Red Hat Kernel QE team
http://bugs.centos.org/view.php?id=3097
: FutureFeature, HardwareEnablement
Depends On:
Blocks: 450783 483701 483784 485920
  Show dependency treegraph
 
Reported: 2008-09-10 08:37 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2009-06-20 01:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 11:41:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3097 None None None Never

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2008-09-10 08:37:32 EDT
Description of problem:
Neither the stock kernel-2.6.18-92.el5 nor -92.1.10.el5 detect the onboard nForce ethernet interface of ASUS M3N78-EMH HDMI.
$ lspci
...
00:0a.0 Ethernet Controller: nVidia Corporation Unknown device 0760 (rev a2)
...
$ lspci -n
...
00:0a.0 0200: 10de:0760 (rev a2)
...

Version-Release number of selected component (if applicable):
kernel-2.6.18-92.el5 (CentOS)

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-2.6.18-92.el5
  
Actual results:
Kernel does not detect any network devices. After loading forcedeth module manually (modprobe forcedeth), eth0 doesn't appear and nothing apart from its version string is logged:
$ modprobe forcedeth
$ dmesg | tail -n 2
SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.60
$ ifconfig eth0
eth0: error fetching interface information: Device not found

It's therefore impossible to do a network install of RHEL 5.2/CentOS 5.2 using the stock kernel.

Expected results:
The kernel should detect the network device:
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.60.
ACPI: PCI Interrupt Link [LMAC] enabled at IRQ 22
ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LMAC] -> GSI 22 (level, low) -> IRQ 217
PCI: Setting latency timer of device 0000:00:0a.0 to 64
forcedeth: using HIGHDMA
eth0: forcedeth.c: subsystem: 01043:82f2 bound to 0000:00:0a.0

Additional info:
As far as I can tell, support for this device was added in Linux 2.6.23:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.23.y.git;a=commitdiff;h=091e78e2d16cdf1953c2a38f7798a2cfac8cd805

Patching forcedeth with the above patch makes it detect the card. However, there have probably been more updates in upstream kernel that should be applied to the driver to make it more robust:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.23.y.git;a=history;f=drivers/net/forcedeth.c;hb=HEAD
Current kernel tree might be worth a look as well.

I was told by CentOS kernel maintainer to report the problem here (see URL).
Comment 1 Rainer Koenig 2008-10-16 07:40:46 EDT
*** Bug 466836 has been marked as a duplicate of this bug. ***
Comment 2 Rainer Koenig 2008-10-16 07:44:37 EDT
Adding myself to this bug as a blocker of my Feature Request bug for nVidia chipsets.

The same network device is used on FSC D2721-H mainboards.
Comment 5 RHEL Product and Program Management 2009-02-16 10:15:36 EST
Updating PM score.
Comment 7 Ivan Vecera 2009-03-13 12:02:44 EDT
I have prepared the kernel packages for testing, could you please try them?
They are available at:
http://people.redhat.com/ivecera/rhel-5-ivtest/
Comment 8 Konstantin Olchanski 2009-03-23 20:05:00 EDT
Thanks - with kernel-xen-2.6.18-135.el5.ivtest.1.x86_64.rpm, SATA and both ethernet interfaces are detected and appear to function. Any chance these updates will make it into the main red hat kernels?
K.O.
Comment 9 Konstantin Olchanski 2009-03-26 22:07:52 EDT
While SATA and ethernet are detected and SATA works correctly, we see strange things with system time: it runs several seconds per minute too fast and ntpd fails to synchronize with any time server.

To fix the system clock problem, I tried to load these "new" drivers (SATA ahci.ko and libata.ko and ethernet forcedeth.ko) into the normal Red Hat kernel (2.6.18-128 or something),

but the new drivers refuse to load because of mismatching kernel module signatures.

Is there a way around this?
How do I disable checking of kernel module signatures?

(The current situation is bizarre - unsigned kernel modules are accepted, but modules signed by somebody else are rejected).

K.O.
Comment 10 Ivan Vecera 2009-04-02 11:14:45 EDT
You can download driver sources from 2.6.18-135 from here:
http://people.redhat.com/ivecera/misc/sata-forcedeth.tar.bz2

To build against currently running kernel, type:
make modules

To build against different kernel type:
make modules KERNELDIR=/lib/modules/2.6.18-xxx/build

Appropriate kernel-devel package have to be installed.

Can I assume that this new forcedeth driver is solving your issue reported here?
Comment 11 Ivan Vecera 2009-04-22 11:41:43 EDT
I'm closing this issue, the update for this new PCI ID is included in the patch associated with bug 479740.

*** This bug has been marked as a duplicate of bug 479740 ***

Note You need to log in before you can comment on or make changes to this bug.