Bug 466836 - ASUS NVidia nForce 780a unsupported devices
ASUS NVidia nForce 780a unsupported devices
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 19:41 EDT by Konstantin Olchanski
Modified: 2013-02-25 11:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 11:13:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2008-10-13 19:41:39 EDT
Linux kernels supplied with Red Hat Enterprise Linux including the most recent beta version 2.6.18-119.el5 do not support these nForce 780a devices, making affected mobos useless for running Linux (my particular test case is an ASUS Crosshair-II mobo).

All reported problems are fixed in vanilla kernel linux-2.6.26.2, please consider updating the affected drivers to the latest version from vanilla kernel.

1) SATA does not work: if in AHCI mode, nVidia SATA ports are detected, then some kind of errors are printed, ultimately no disks are detected, the machine does not boot (only way to capture the exact error text is by taking a photo of the monitor while booting). if in "IDE" mode and kernel is given the "all-generic-ide" command line switch, then disks work.

2) nVidia GigE interface does not work (see bug 461751, https://bugzilla.redhat.com/show_bug.cgi?id=461751). "lspci" reports "00:0a.0 Ethernet controller: nVidia Corporation Unknown device 0760 (rev a2)"

3) Marvell GigE interface does not work in released kernels (no go up to 2.6.18-92.1.13), seems to work in latest beta kernel 2.6.18-119.el5).

Obviously a mobo without working disks and ethernet is not very useful.

Please consider updating the effected drivers (sara AHCI, forcedeth) from latest version in vanilla kernel.

A temporary work around for these problems is to build and run a custom vanilla kernel.

K.O.
Comment 1 Rainer Koenig 2008-10-16 07:40:46 EDT

*** This bug has been marked as a duplicate of bug 461751 ***
Comment 2 Konstantin Olchanski 2008-10-16 12:58:08 EDT
How can a report about non working SATA be a dupe of a report about non working network?
K.O.
Comment 3 Dominik 'Rathann' Mierzejewski 2009-02-16 13:32:46 EST
(In reply to comment #2)
> How can a report about non working SATA be a dupe of a report about non working
> network?
> K.O.

You shouldn't put three separate issues in one bugreport.
Comment 4 Jes Sorensen 2013-02-25 11:13:14 EST
If this is still an issue in recent RHEL, please open a new bugzilla against
that, and remember to only put one issue per bugzilla.

Note You need to log in before you can comment on or make changes to this bug.