Bug 461772 - If I upgrade xorg-drv-i810 I can't start graphically my system
If I upgrade xorg-drv-i810 I can't start graphically my system
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Graphic login is not allowed if xorg...
:
: 461764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 10:34 EDT by antonio montagnani
Modified: 2018-04-11 04:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 14:41:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf configuration file (799 bytes, application/x-extension-conf)
2008-09-10 15:26 EDT, antonio montagnani
no flags Details
log file (37.49 KB, text/plain)
2008-09-10 15:28 EDT, antonio montagnani
no flags Details
Xorg.1.log (33.08 KB, text/plain)
2008-09-10 15:28 EDT, antonio montagnani
no flags Details
Xorg.2.log (4.58 KB, text/plain)
2008-09-10 15:29 EDT, antonio montagnani
no flags Details
Xorg.3.log (4.58 KB, text/plain)
2008-09-10 15:30 EDT, antonio montagnani
no flags Details
Xorg.4.log (4.58 KB, text/plain)
2008-09-10 15:30 EDT, antonio montagnani
no flags Details
Xorg.5.log (4.58 KB, text/plain)
2008-09-10 15:31 EDT, antonio montagnani
no flags Details
Xorg.0.log after deleting xorg.conf (35.26 KB, text/plain)
2008-09-10 16:09 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2008-09-10 10:34:17 EDT
Description of problem:
If I upgrade xorg-drv-i810 I can't start graphically my system, text mode is
o.k...


Version-Release number of selected component (if applicable):
Newer release than xorg-x11-drv-i810-2.2.1-24.fc9

How reproducible:
always

Steps to Reproduce:
1.Upgrade xorg-x11-drv-i810
2.Reboot
3.
  
Actual results:

No graphical login and freeze
Expected results:
standard graphical login

Additional info:pub_4beba9fc-1cd1-4820-b948-b9ccadcaa15e SMOLT
Similar to bug 461764 for F9
Comment 1 antonio montagnani 2008-09-10 12:20:09 EDT
if I upgrade with xorg-x11-drv-i810.2.4.2-6.fc10 system starts and I can login but after a while it freezes while working (I lost my mouse and everything was frozen, only an hard reboot was possible!!!)
Comment 2 Matěj Cepl 2008-09-10 13:01:31 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 antonio montagnani 2008-09-10 15:22:52 EDT
(In reply to comment #2)
> Thanks for the bug report.  We have reviewed the information you have provided
> above, and there is some additional information we require that will be helpful
> in our diagnosis of this issue.
> 
> Please attach your X server config file (/etc/X11/xorg.conf) and X server log
> file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
> attachments using the bugzilla file attachment link below.
> 
> Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
> let X11 autodetect your display and video card? Attach to this bug
> /var/log/Xorg.0.log from this attempt as well, please.
> 
> We will review this issue again once you've had a chance to attach this
> information.
> 
> Thanks in advance.
Comment 4 antonio montagnani 2008-09-10 15:26:43 EDT
Created attachment 316345 [details]
xorg.conf configuration file

as requested
Comment 5 antonio montagnani 2008-09-10 15:28:14 EDT
Created attachment 316346 [details]
log file
Comment 6 antonio montagnani 2008-09-10 15:28:47 EDT
Created attachment 316347 [details]
Xorg.1.log
Comment 7 antonio montagnani 2008-09-10 15:29:28 EDT
Created attachment 316348 [details]
Xorg.2.log
Comment 8 antonio montagnani 2008-09-10 15:30:08 EDT
Created attachment 316349 [details]
Xorg.3.log
Comment 9 antonio montagnani 2008-09-10 15:30:45 EDT
Created attachment 316350 [details]
Xorg.4.log
Comment 10 antonio montagnani 2008-09-10 15:31:23 EDT
Created attachment 316351 [details]
Xorg.5.log
Comment 11 antonio montagnani 2008-09-10 15:44:59 EDT
I can't proceed with other request as I cannot log as root!!! I will file another bug...
Comment 12 antonio montagnani 2008-09-10 16:09:17 EDT
Created attachment 316352 [details]
Xorg.0.log after deleting xorg.conf

I installed updated xorg-x11-drv-i810-2.4.2-6.fc10 and deleted xorg.conf file...
Comment 13 Matěj Cepl 2008-09-10 16:15:34 EDT
(In reply to comment #11)
> I can't proceed with other request as I cannot log as root!!! I will file
> another bug...

??? Why cannot you login as root?
Comment 14 antonio montagnani 2008-09-10 16:26:30 EDT
further informations:
1) I cannot login as root as it seems that it has been disabled in today's changelog..so no bug is required.

2)I installed the new driver with no xorg.conf file and I could work for about 15 minutes, then it froze...I mean the computer froze and I had to issue an hard reboot!!!
Comment 15 antonio montagnani 2008-09-10 16:27:16 EDT
and finally I reverted to the old one ... :-) until problem will be solved
Comment 16 Matěj Cepl 2008-09-10 16:49:00 EDT
OK, thanks
Comment 17 antonio montagnani 2008-09-11 10:17:41 EDT
after upgrading to xorg-x11-drv-i810-2.4.2-7.fc10, system is working fine, or at least I am not experiencing any freeze for more than one hour...

Any way I feel it somewhat slower than before, but it is just a feeling
Comment 18 antonio montagnani 2008-09-11 10:47:10 EDT
update to my test: X server crashes when I log out and it freezes PC!!!!
Comment 19 antonio montagnani 2008-09-11 10:49:55 EDT
and even when I shut-down :-(
Comment 20 antonio montagnani 2008-09-11 11:00:37 EDT
and after rebooting, I experienced same freezing during operation
Comment 21 Matěj Cepl 2008-09-12 09:31:56 EDT
*** Bug 461764 has been marked as a duplicate of this bug. ***
Comment 22 Matěj Cepl 2008-09-12 10:20:51 EDT
Bug 461764 is for Fedora 9, so when this bug is going to be closed packages for F9 should be updated as well.
Comment 23 antonio montagnani 2008-09-13 03:37:43 EDT
after upgrading to xorg-x11-drv-i810-2.4.2-8.fc10 system reboots fine but after a while it locks (two three minutes of operation are allowed) .

And during operations, before freezing, I get some interruptions (i.e. mouse stops for a while, music has some interruptions and so on..) 
I reverted to xorg-x11-drv-i810-2.2.1-24.fc9 and everything is o.k.
Please note that the only missing update is just this package, remaining packages are fully updated
Comment 24 antonio montagnani 2008-10-01 01:34:48 EDT
for help to readers, I am using intel driver on a Intel GM965/GL960 integrated graphic chip
Comment 25 antonio montagnani 2008-10-05 06:18:32 EDT
after upgrading to 
xorg-x11-drv-i810-2.4.2-9.fc10
gdm-2.24.0-8.fc10
kernel-2.6.27-0.382.rc8.git4.fc10

system seem to be fine.

I will report later if bug may be considered resolved

Note You need to log in before you can comment on or make changes to this bug.