Bug 461807 - NetworkManager: <WARN> nm_signal_handler(): Caught signal 6. Generating backtrace...
NetworkManager: <WARN> nm_signal_handler(): Caught signal 6. Generating bac...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 463253 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-09-10 14:37 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 15:16:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-09-10 14:37:56 EDT
After completing an install on x86_64, NM dies while rebooting the system.

 * anaconda-11.4.1.33-1.x86_64.rpm
 * NetworkManager-0.7.0-0.11.svn4022.1.fc10.x86_64.rpm
 * kernel-2.6.27-0.317.rc5.git10.fc10.x86_64.rpm

18:03:38 Starting graphical installation...

sh-3.2# NetworkManager: <info>  eth0: canceled DHCP transaction, dhcp client pid 1638

NetworkManager: <WARN>  check_one_route(): (eth0) error -34 returned from rtnl_route_del(): Sucess


NetworkManager: <info>  (eth0): cleaning up...

NetworkManager: <info>  (eth0): taking down device.

NetworkManager: <WARN>  nm_signal_handler(): Caught signal 6.  Generating backtrace...

NetworkManager: ******************* START **********************************
NetworkManager: Frame 0: /usr/sbin/NetworkManager(nm_logging_backtrace+0x37) [0x428317]
NetworkManager: Frame 1: /usr/sbin/NetworkManager [0x424850]
NetworkManager: Frame 2: /lib64/libpthread.so.0 [0x6a350f0]
NetworkManager: Frame 3: /lib64/libc.so.6(gsignal+0x35) [0x7f0069aeb0a5]
NetworkManager: Frame 4: /lib64/libc.so.6(abort+0x183) [0x7f0069aecc13]
NetworkManager: Frame 5: /lib64/libglib-2.0.so.0(g_assertion_message+0x113) [0x293f723]
NetworkManager: Frame 6: /lib64/libglib-2.0.so.0 [0x293fbc2]
NetworkManager: Frame 7: /lib64/libdbus-glib-1.so.2 [0x14974fe]
NetworkManager: Frame 8: /lib64/libdbus-glib-1.so.2 [0x1498efc]
NetworkManager: Frame 9: /lib64/libgobject-2.0.so.0(g_object_unref+0xc2) [0x10fe732]
NetworkManager: Frame 10: /usr/sbin/NetworkManager(nm_utils_call_dispatcher+0x286) [0x426696]
NetworkManager: Frame 11: /usr/sbin/NetworkManager(nm_device_state_changed+0x2a2) [0x412202]
NetworkManager: Frame 12: /usr/sbin/NetworkManager [0x4284b2]
NetworkManager: Frame 13: /usr/sbin/NetworkManager [0x42bdbe]
NetworkManager: Frame 14: /lib64/libgobject-2.0.so.0(g_object_unref+0xc2) [0x10fe732]
NetworkManager: Frame 15: /usr/sbin/NetworkManager(main+0x4ef) [0x424d8f]
NetworkManager: Frame 16: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f0069ad6566]
NetworkManager: Frame 17: /usr/sbin/NetworkManager [0x40f2f9]
NetworkManager: ******************* END **********************************
Comment 1 Dan Williams 2008-09-10 15:37:11 EDT
Could I convince you to install debuginfo if you haven't already?  First though, can you do this for me?

eu-addr2line --executable=/usr/sbin/NetworkManager --functions --symbols 0x426696

Need to try and figure out which exact g_object_unref() it's dying in.  This can be done at any time even when the system is up and running, provided you haven't touched /usr/sbin/NetworkManager since this backtrace happened.
Comment 2 James Laska 2008-10-02 11:03:26 EDT
Using NetworkManager-0.7.0-0.11.svn4022.4.fc10.x86_64.rpm and rawhide-20081002 still seeing the following.

NetworkManager: <WARN>  nm_signal_handler(): Caught signal 15, shutting down normally.

NetworkManager: <info>  (eth1): now unmanaged

NetworkManager: <info>  (eth1): device state change: 8 -> 1

NetworkManager: <info>  (eth1): deactivating device.

NetworkManager: <WARN>  check_one_route(): (eth1) error -34 returned from rtnl_route_del(): Sucess


NetworkManager: <info>  (eth1): cleaning up...

NetworkManager: <info>  (eth1): taking down device.

NetworkManager: <WARN>  nm_signal_handler(): Caught signal 6.  Generating backtrace...

NetworkManager: ******************* START **********************************
NetworkManager: Frame 0: /usr/sbin/NetworkManager(nm_logging_backtrace+0x37) [0x428317]
NetworkManager: Frame 1: /usr/sbin/NetworkManager [0x424850]
NetworkManager: Frame 2: /lib64/libpthread.so.0 [0x7f8a2b1a80f0]
NetworkManager: Frame 3: /lib64/libc.so.6(gsignal+0x35) [0x7f8a2ac510a5]
NetworkManager: Frame 4: /lib64/libc.so.6(abort+0x183) [0x7f8a2ac52c13]
NetworkManager: Frame 5: /lib64/libglib-2.0.so.0(g_assertion_message+0x113) [0x6a69723]
NetworkManager: Frame 6: /lib64/libglib-2.0.so.0 [0x6a69bc2]
NetworkManager: Frame 7: /lib64/libdbus-glib-1.so.2 [0x149d4fe]
NetworkManager: Frame 8: /lib64/libdbus-glib-1.so.2 [0x149eefc]
NetworkManager: Frame 9: /lib64/libgobject-2.0.so.0(g_object_unref+0xc2) [0x596f732]
NetworkManager: Frame 10: /usr/sbin/NetworkManager(nm_utils_call_dispatcher+0x286) [0x426696]
NetworkManager: Frame 11: /usr/sbin/NetworkManager(nm_device_state_changed+0x2a2) [0x412202]
NetworkManager: Frame 12: /usr/sbin/NetworkManager [0x4284b2]
NetworkManager: Frame 13: /usr/sbin/NetworkManager [0x42bdbe]
NetworkManager: Frame 14: /lib64/libgobject-2.0.so.0(g_object_unref+0xc2) [0x596f732]
NetworkManager: Frame 15: /usr/sbin/NetworkManager(main+0x4ef) [0x424d8f]
NetworkManager: Frame 16: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f8a2ac3c566]
NetworkManager: Frame 17: /usr/sbin/NetworkManager [0x40f2f9]
NetworkManager: ******************* END **********************************
sending termination signals...done


Using the above information on another already installed x86_64 system with the same level of NetworkManager installed:

# eu-addr2line --executable=/usr/sbin/NetworkManager --functions --symbols 0x426696
nm_utils_call_dispatcher
nm_utils_call_dispatcher+0x286
/usr/src/debug/NetworkManager-0.7.0/src/NetworkManagerUtils.c:508
Comment 3 James Laska 2008-10-02 11:34:00 EDT
Running the rest of the trace through eu-addr2line ...


# cat trace.txt | while read LINE; do echo $LINE; ADDR=$(echo "$LINE" | gawk '{print $5}'| tr -d ][); BIN=$(echo "$LINE" | gawk '{print $4}'); BIN=$(echo $BIN | sed 's|(.*||'); LIB="/usr/lib/debug$BIN.debug"; eu-addr2line -f -e $LIB $ADDR ; done

NetworkManager: Frame 0: /usr/sbin/NetworkManager(nm_logging_backtrace+0x37) [0x428317]
fallback_get_backtrace inlined at /usr/src/debug/NetworkManager-0.7.0/src/nm-logging.c:102 in nm_logging_backtrace
/usr/src/debug/NetworkManager-0.7.0/src/nm-logging.c:43
NetworkManager: Frame 1: /usr/sbin/NetworkManager [0x424850]
nm_signal_handler
/usr/src/debug/NetworkManager-0.7.0/src/NetworkManager.c:121
NetworkManager: Frame 2: /lib64/libpthread.so.0 [0x7f8a2b1a80f0]
??
??:0
NetworkManager: Frame 3: /lib64/libc.so.6(gsignal+0x35) [0x7f8a2ac510a5]
??
??:0
NetworkManager: Frame 4: /lib64/libc.so.6(abort+0x183) [0x7f8a2ac52c13]
??
??:0
NetworkManager: Frame 5: /lib64/libglib-2.0.so.0(g_assertion_message+0x113) [0x6a69723]
??
??:0
NetworkManager: Frame 6: /lib64/libglib-2.0.so.0 [0x6a69bc2]
??
??:0
NetworkManager: Frame 7: /lib64/libdbus-glib-1.so.2 [0x149d4fe]
??
??:0
NetworkManager: Frame 8: /lib64/libdbus-glib-1.so.2 [0x149eefc]
??
??:0
NetworkManager: Frame 9: /lib64/libgobject-2.0.so.0(g_object_unref+0xc2) [0x596f732]
??
??:0
NetworkManager: Frame 10: /usr/sbin/NetworkManager(nm_utils_call_dispatcher+0x286) [0x426696]
nm_utils_call_dispatcher
/usr/src/debug/NetworkManager-0.7.0/src/NetworkManagerUtils.c:508
NetworkManager: Frame 11: /usr/sbin/NetworkManager(nm_device_state_changed+0x2a2) [0x412202]
nm_device_state_changed
/usr/src/debug/NetworkManager-0.7.0/src/nm-device.c:2357
NetworkManager: Frame 12: /usr/sbin/NetworkManager [0x4284b2]
remove_one_device
/usr/src/debug/NetworkManager-0.7.0/src/nm-manager.c:398
NetworkManager: Frame 13: /usr/sbin/NetworkManager [0x42bdbe]
dispose
/usr/src/debug/NetworkManager-0.7.0/src/nm-manager.c:426
NetworkManager: Frame 14: /lib64/libgobject-2.0.so.0(g_object_unref+0xc2) [0x596f732]
??
??:0
NetworkManager: Frame 15: /usr/sbin/NetworkManager(main+0x4ef) [0x424d8f]
main
/usr/src/debug/NetworkManager-0.7.0/src/NetworkManager.c:352
NetworkManager: Frame 16: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f8a2ac3c566]
??
??:0
NetworkManager: Frame 17: /usr/sbin/NetworkManager [0x40f2f9]
_start
??:0
Comment 4 Dan Williams 2008-10-02 16:06:21 EDT
interesting.  thanks for the trace.  will look into this.
Comment 5 Dan Williams 2008-10-19 23:07:34 EDT
*** Bug 463253 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2008-11-07 13:07:57 EST
Dan, any update on this ?
Comment 7 Jesse Keating 2008-11-10 16:42:41 EST
Moving to target, crashes during shutdown aren't fatal.
Comment 8 Bug Zapper 2008-11-25 22:01:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Dan Williams 2009-02-14 15:16:10 EST
I haven't seen this in quite a while on my F10 boxes; please re-open if it's still an issue.  Both NM and dbus-glib updates may have fixed this bug.

Note You need to log in before you can comment on or make changes to this bug.