Bug 463253 - NetworkManager(nm_logging_backtrace+0x37)
NetworkManager(nm_logging_backtrace+0x37)
Status: CLOSED DUPLICATE of bug 461807
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-22 13:57 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-19 23:07:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NM-Fail1.png (18.70 KB, image/png)
2008-09-22 13:57 EDT, James Laska
no flags Details
NM-Fail2.png (17.46 KB, image/png)
2008-09-22 13:58 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-09-22 13:57:32 EDT
Created attachment 317394 [details]
NM-Fail1.png

Description of problem:

Anaconda fails with a traceback ... which results in a segfault from NetworkManager


Version-Release number of selected component (if applicable):

 * anaconda-11.4.1.36-1.x86_64
 * kernel-2.6.27-0.329.rc6.git2.fc10.x86_64
 * NetworkManager-0.7.0-0.11.svn4022.2.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Attempt to start installation in a KVM virt-manager guest
2. After download on the install images, anaconda crashes due to bug#462592
3. NetworkManager then segfaults
  
Actual results:

 See attached screenshots for dump from NetworkManager

Expected results:


Additional info:
Comment 1 James Laska 2008-09-22 13:58:05 EDT
Created attachment 317395 [details]
NM-Fail2.png
Comment 2 James Laska 2008-09-23 08:48:50 EDT
The same NM failure is shown on the console during normal completion of an install.

Xlib:  extension "RANDR" missing on display ":1.0".
12:32:34 Starting graphical installation...

sh-3.2# NetworkManager: <WARN>  nm_signal_handler(): Caught signal 15, shutting down normally.

NetworkManager: <info>  (eth0): now unmanaged

NetworkManager: <info>  (eth0): device state change: 8 -> 1

NetworkManager: <info>  (eth0): deactivating device.

NetworkManager: <info>  eth0: canceled DHCP transaction, dhcp client pid 1682

NetworkManager: <WARN>  check_one_route(): (eth0) error -34 returned from rtnl_route_del(): Sucess


NetworkManager: <info>  (eth0): cleaning up...

NetworkManager: <info>  (eth0): taking down device.

NetworkManager: <WARN>  nm_signal_handler(): Caught signal 6.  Generating backtrace...

NetworkManager: ******************* START **********************************
NetworkManager: Frame 0: /usr/sbin/NetworkManager(nm_logging_backtrace+0x45) [0x806ead5]
NetworkManager: Frame 1: /usr/sbin/NetworkManager [0x806aa85]
NetworkManager: Frame 2: [0x132400]
NetworkManager: Frame 3: /lib/libc.so.6(gsignal+0x46) [0x57f986]
NetworkManager: Frame 4: /lib/libc.so.6(abort+0x188) [0x5813f8]
NetworkManager: Frame 5: /lib/libglib-2.0.so.0(g_assertion_message+0x123) [0x2c16b3]
NetworkManager: Frame 6: /lib/libglib-2.0.so.0 [0x2c1b4d]
NetworkManager: Frame 7: /lib/libdbus-glib-1.so.2 [0x1d0fb6]
NetworkManager: Frame 8: /lib/libdbus-glib-1.so.2 [0x1d2a09]
NetworkManager: Frame 9: /lib/libgobject-2.0.so.0(g_object_unref+0xd8) [0x22d2a8]
NetworkManager: Frame 10: /usr/sbin/NetworkManager(nm_utils_call_dispatcher+0x2e3) [0x806cba3]
NetworkManager: Frame 11: /usr/sbin/NetworkManager(nm_device_state_changed+0x2df) [0x8056d9f]
NetworkManager: Frame 12: /usr/sbin/NetworkManager(nm_device_set_managed+0xf6) [0x8056ef6]
NetworkManager: Frame 13: /usr/sbin/NetworkManager [0x806ec98]
NetworkManager: Frame 14: /usr/sbin/NetworkManager [0x8072946]
NetworkManager: Frame 15: /lib/libgobject-2.0.so.0(g_object_unref+0xd8) [0x22d2a8]
NetworkManager: Frame 16: /usr/sbin/NetworkManager(main+0x4a5) [0x806af85]
NetworkManager: Frame 17: /lib/libc.so.6(__libc_start_main+0xe5) [0x56a6e5]
NetworkManager: Frame 18: /usr/sbin/NetworkManager [0x8053c51]
NetworkManager: ******************* END **********************************
sending termination signals...done
sending kill signals...done
disabling swap...
	/dev/mapper/VolGroup00-LogVol01
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0 LOOP_CLR_FD failed: 6
	/proc done
	/dev/pts done
	/sys done
	/selinux done
	/mnt/sysimage/boot done
	/mnt/sysimage/sys done
	/mnt/sysimage/proc done
	/mnt/sysimage/selinux done
	/mnt/sysimage/dev done
	/mnt/sysimage done
rebooting system
Restarting system.
Comment 3 Dan Williams 2008-10-19 23:07:34 EDT

*** This bug has been marked as a duplicate of bug 461807 ***

Note You need to log in before you can comment on or make changes to this bug.