Bug 461883 - yum-filter-data: Python syntax error
yum-filter-data: Python syntax error
Status: CLOSED DUPLICATE of bug 460963
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 03:09 EDT by Sebastian Vahl
Modified: 2014-01-21 01:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 08:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-09-11 03:09:46 EDT
Description of problem: After an update to recent yum and yum-utils, yum itself fails with a python syntax error if yum-filter-data plugin is enabled:

# yum check-update 
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 152, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 251, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/filter-data.py", line 111
    ('committers', 'committer')]
                               ^
SyntaxError: invalid syntax



Version-Release number of selected component (if applicable):
yum-filter-data-1.1.16-1.fc9.noarch
yum-3.2.19-3.fc9.noarch

How reproducible:
everytime

Steps to Reproduce:
1. yum install yum-filter-data
2. yum check-update
3.
  
Actual results:
error

Expected results:
no error due to a syntax error
Comment 1 seth vidal 2008-09-11 08:23:38 EDT

*** This bug has been marked as a duplicate of bug 460963 ***

Note You need to log in before you can comment on or make changes to this bug.