Bug 460963 - Packagekit doesn't when using latest yum-filter-data, due to invalid syntax
Packagekit doesn't when using latest yum-filter-data, due to invalid syntax
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 461883 461944 462036 462039 462063 464920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 19:42 EDT by acb
Modified: 2014-01-21 01:11 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 14:10:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acb 2008-09-02 19:42:50 EDT
Description of problem:

Pakcagekit doesn't work!!!!!!

"Internal system error"
Error Type: <type 'exceptions.SyntaxError'>
Error Value: invalid syntax (filter-data.py, line 111)
  File : /usr/share/PackageKit/helpers/yum/get-repo-list.py , line 17, in <module>
    backend = PackageKitYumBackend(sys.argv[2:])
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 242, in __init__
    self._setup_yum()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1556, in _setup_yum
    self.yumbase.doConfigSetup(errorlevel=0,debuglevel=0)     # Setup Yum Config
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 139, in doConfigSetup
    errorlevel=errorlevel)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 152, in __init__
    self._importplugins(types)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 195, in _importplugins
    self._loadplugin(modulefile, types)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 251, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2008-09-03 03:51:46 EDT
The problem is with the yum-filter-data code, not PackageKit. I guess this is in yum-utils -- apologies if I've got this wrong. If you disable the plugin, packagekit will work fine.
Comment 2 seth vidal 2008-09-03 09:18:13 EDT
What version of yum and yum-utils do you have installed?
Comment 3 acb 2008-09-03 16:02:00 EDT
how do i disable the plug in?
Comment 4 acb 2008-09-03 16:09:25 EDT
how do i disable the plug in?
Comment 5 seth vidal 2008-09-03 16:22:22 EDT
yum remove yum-filter-data

will do it.

or edit /etc/yum/pluginconf.d/filter-data.conf
Comment 6 James Antill 2008-09-03 16:51:03 EDT
 This is already fixed upstream, getting updates out is another problem...
Comment 7 acb 2008-09-03 16:56:26 EDT
thanks problem solved!
Comment 8 seth vidal 2008-09-11 08:23:38 EDT
*** Bug 461883 has been marked as a duplicate of this bug. ***
Comment 9 seth vidal 2008-09-11 11:46:38 EDT
*** Bug 461944 has been marked as a duplicate of this bug. ***
Comment 10 seth vidal 2008-09-12 08:03:59 EDT
*** Bug 462036 has been marked as a duplicate of this bug. ***
Comment 11 seth vidal 2008-09-12 08:04:07 EDT
*** Bug 462039 has been marked as a duplicate of this bug. ***
Comment 12 seth vidal 2008-09-12 08:07:32 EDT
*** Bug 462063 has been marked as a duplicate of this bug. ***
Comment 13 seth vidal 2008-10-01 09:31:53 EDT
*** Bug 464920 has been marked as a duplicate of this bug. ***
Comment 14 seth vidal 2008-12-10 14:10:26 EST
This is fixed and released - 1.1.17 and beyond.

Note You need to log in before you can comment on or make changes to this bug.