Bug 461944 - yum-filter-data package syntax error breaks all yum commands
yum-filter-data package syntax error breaks all yum commands
Status: CLOSED DUPLICATE of bug 460963
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 11:30 EDT by David Favor
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 11:46:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Favor 2008-09-11 11:30:39 EDT
Version-Release number of selected component (if applicable): fc9


How reproducible: Consistent

net1#yum --version
3.2.19
  Installed: yum-metadata-parser-1.1.2-8.fc9.i386 at 2008-08-26 23:07
  Built    : Fedora Project at 2008-02-14 13:27
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2008-02-14 22:00

  Installed: yum-3.2.19-3.fc9.noarch at 2008-09-11 03:19
  Built    : Fedora Project at 2008-09-03 15:04
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2008-09-03 22:00

  Installed: rpm-4.4.2.3-2.fc9.i386 at 2008-08-26 23:06
  Built    : Fedora Project at 2008-04-18 16:52
  Committed: Bill Nottingham <notting@redhat.com> at 2008-04-18 22:00

net1#yum -y install yum-filter-data
... ... ...
Resolving Dependencies
--> Running transaction check
---> Package yum-filter-data.noarch 0:1.1.16-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch        Version           Repository            Size 
================================================================================
Installing:
 yum-filter-data      noarch      1.1.16-1.fc9      updates-newkey         14 k

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)
... ... ...

net1#yum --version
3.2.19
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 152, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 251, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/filter-data.py", line 111
    ('committers', 'committer')]
                               ^
SyntaxError: invalid syntax
    
net1#rpm -e yum-filter-data

net1#yum --version
3.2.19
  Installed: yum-metadata-parser-1.1.2-8.fc9.i386 at 2008-08-26 23:07
  Built    : Fedora Project at 2008-02-14 13:27
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2008-02-14 22:00

  Installed: yum-3.2.19-3.fc9.noarch at 2008-09-11 03:19
  Built    : Fedora Project at 2008-09-03 15:04
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2008-09-03 22:00

  Installed: rpm-4.4.2.3-2.fc9.i386 at 2008-08-26 23:06
  Built    : Fedora Project at 2008-04-18 16:52
  Committed: Bill Nottingham <notting@redhat.com> at 2008-04-18 22:00
Comment 1 seth vidal 2008-09-11 11:46:38 EDT

*** This bug has been marked as a duplicate of bug 460963 ***

Note You need to log in before you can comment on or make changes to this bug.