Bug 462039 - Yum crash after update of yum-filter-data 1.1.16-1.fc9
Yum crash after update of yum-filter-data 1.1.16-1.fc9
Status: CLOSED DUPLICATE of bug 460963
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 02:30 EDT by vikram goyal
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 08:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vikram goyal 2008-09-12 02:30:35 EDT
Description of problem:
I updated yum.noarch 0:3.2.19-3.fc9 yum-fastestmirror.noarch 0:1.1.16-1.fc9 yum-fedorakmod.noarch 0:1.1.16-1.fc9 yum-kernel-mod
ule.noarch 0:1.1.16-1.fc9 yum-priorities.noarch 0:1.1.16-1.fc9 yum-refresh-updatesd.noarch 0:1.1.16-1.fc9 yum-utils.noarch 0:1
.1.16-1.fc9 yum-verify.noarch 0:1.1.16-1.fc9

After this I updated yum-aliases.noarch 0:1.1.16-1.fc9 yum-downloadonly.noarch 0:1.1.16-1.fc9 yum-filter-data.noarch 0:1.1.16-1.fc9 yum-ke
ys.noarch 0:1.1.16-1.fc9 yum-merge-conf.noarch 0:1.1.16-1.fc9 yum-protect-packages.noarch 0:1.1.16-1.fc9 yum-protectbase.noarc
h 0:1.1.16-1.fc9 yum-security.noarch 0:1.1.16-1.fc9 yum-tmprepo.noarch 0:1.1.16-1.fc9.

After the second updation when I started yum again I got the following output:

[root@f9host ~]# yum update
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 152, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 251, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/filter-data.py", line 111
    ('committers', 'committer')]
                               ^
SyntaxError: invalid syntax

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 vikram goyal 2008-09-12 02:57:31 EDT
removing yum-filter-data corrected the problem
Comment 2 seth vidal 2008-09-12 08:04:07 EDT

*** This bug has been marked as a duplicate of bug 460963 ***

Note You need to log in before you can comment on or make changes to this bug.