Bug 462063 - /usr/lib/yum-plugins having issues, post updates-newkey
/usr/lib/yum-plugins having issues, post updates-newkey
Status: CLOSED DUPLICATE of bug 460963
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 07:49 EDT by Scott Doty
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 08:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fpaste showing problem with skip-broken.py (5.99 KB, text/html)
2008-09-12 07:49 EDT, Scott Doty
no flags Details
kleinpaste showing installed yum packages, as well as the error in question. (2.40 KB, text/plain)
2008-09-12 07:52 EDT, Scott Doty
no flags Details

  None (edit)
Description Scott Doty 2008-09-12 07:49:20 EDT
Created attachment 316560 [details]
fpaste showing problem with skip-broken.py

Description of problem:
Yesterday, there was a bogus "/usr/lib/yum-plugins/skip-broken.py" on my system, which broke yum.  http://fpaste.org/paste/5963 -- attachement 1.

At the time, there was no "skip-broken" package installed, according to rpm.

This morning, a similar issued was caught on freenode's #fedora channel:

   http://karl.kleinpaste.org/.../yum.txt -- attachment 2 [details].

Version-Release number of selected component (if applicable):

   yum-3.2.19-3.fc9.noarch

How reproducible:

Unknown.  But once the condition happens, the only way to run yum is with the "--noplugins" switch.

Additional info:

In both cases, temporary workarounds were:

   yum --noplugins

and of course, something like:

   cd /usr/lib/yum-plugins ; mkdir Hide ; mv filter-data.py Hide/

Hope that's enough info...

 -Scott <scott@sonic.net>
Comment 1 Scott Doty 2008-09-12 07:52:41 EDT
Created attachment 316561 [details]
kleinpaste showing installed yum packages, as well as the error in question.

It looks like the gentleman with the kleinpaste error had the filter-data plugin installed -- however, this was causing an error.

This may actually be separate from the first observed problem, seen in the first attachment, since:  at that point, yum's skip-broken plugin was _definitely_ not installed, as reported by rpm.
Comment 2 seth vidal 2008-09-12 08:07:19 EDT
the first problem appears to be a file not belonging to a package conflicting with the installed version of yum.

the second problem is a dupe of bug 460963
Comment 3 seth vidal 2008-09-12 08:07:32 EDT

*** This bug has been marked as a duplicate of bug 460963 ***
Comment 4 Scott Doty 2008-09-12 17:44:45 EDT
Well, a fedora person in #fedora thought I should bring the problem to your attention -- the first problem was a system that was working fine, until applying your transitions over to updates-newkey.

And if you read the description in the topic, you'll see that this is a broader issue than just these piddling examples.

Have a good weekend. :)

 -Scott

Note You need to log in before you can comment on or make changes to this bug.