Bug 462156 - Kernel 2.6.26.3-14 hangs fairly early in boot
Kernel 2.6.26.3-14 hangs fairly early in boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 22:25 EDT by Stephen P. Schaefer
Modified: 2008-10-27 20:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Photo of the display/screen where the boot hangs (495.18 KB, image/jpeg)
2008-09-30 11:28 EDT, David Kovalsky
no flags Details
Screenshot of kernel hanging at boot (Intellistation M Pro) (1.66 MB, image/jpeg)
2008-10-02 15:23 EDT, Fredrik Duprez
no flags Details

  None (edit)
Description Stephen P. Schaefer 2008-09-12 22:25:50 EDT
Description of problem:

The last two messages I get on the console during boot are

isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found

(there appear to be no functioning devices beyond the console screen at this point, so the above is from written notes.  It is normal for no plug and play devices to be found).

Version-Release number of selected component (if applicable):
2.6.23.3-14

How reproducible:
Always (with this hardware)

Steps to Reproduce:
1. yum update
2. reboot
3.
  
Actual results:
Hang.

Expected results:
Working OS.

Additional info:

In my working kernel, 2.6.25.14-69, the isapnp lines are continued like so:

. . .
Sep 12 21:07:09 thyrsus-laptop2 kernel: isapnp: Scanning for PnP cards...
Sep 12 21:07:09 thyrsus-laptop2 kernel: isapnp: No Plug & Play device found
Sep 12 21:07:09 thyrsus-laptop2 kernel: Real Time Clock Driver v1.12ac
Sep 12 21:07:09 thyrsus-laptop2 kernel: Non-volatile memory driver v1.2
Sep 12 21:07:09 thyrsus-laptop2 kernel: Linux agpgart interface v0.103
Sep 12 21:07:09 thyrsus-laptop2 kernel: Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
Sep 12 21:07:09 thyrsus-laptop2 kernel: brd: module loaded
Sep 12 21:07:09 thyrsus-laptop2 kernel: input: Macintosh mouse button emulation as /class/input/input0
Sep 12 21:07:09 thyrsus-laptop2 kernel: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
Comment 1 Ivo 2008-09-13 12:18:09 EDT
I'm experiencing exactly the same problem on two different laptops.
Booting with acpi=off works, but a laptop is pretty broken without acpi.
The same laptop has worked with all previous fedora-9 and fedora-8 kernels.
Comment 2 Ivo 2008-09-13 13:03:34 EDT
Other boot options that make the machine boot are acpi=ht as well noapic
I've tried booting with noisapnp which hangs a little later after

Synaptics Touchpad, model:1, fw: 6.2, id: 0x1a0b1, caps: 0xa04713/0x200000
input: SynPS/2 Synaptics touchPad as /devices/platform/i8042/serio2/input/input6

The least intrusive boot option that makes the machine boot seems to be
clocksource=hpet
Comment 3 Stephen E Clark 2008-09-20 21:50:37 EDT
I have an Asus Laptop - Core 2 Duo and am experiencing the exact same problem - boot hangs right after 
isapnp: No Plug & Play device found
Comment 4 Stephen E Clark 2008-09-20 21:56:25 EDT
Using clocksource=hpet allowed my laptop to boot
Comment 5 Michael Tokarev 2008-09-25 14:10:11 EDT
I wonder, does it happen with CONFIG_PARAVIRT=y?  If so, does the system boot ok with CONFIG_PARAVIRT=n?
Comment 6 Michael Tokarev 2008-09-25 14:30:58 EDT
Well, probably unrelated, but who knows...  I've a mysterious problem with several Asus motherboards, their recent BIOSes and 2.6.26.5, but only with CONFIG_PARAVIRT enabled.  It hangs at a different place, right before choosing timer source.
Comment 7 Stephen E Clark 2008-09-25 16:24:45 EDT
I don't know - I built a vanilla kernel 2.6.26.5 with the config from fedora and it hung also. I then built a vanilla kernel 2.6.27-rc7 with the fedora config and it booted without having to add clocksource=hpet.
Comment 8 David Kovalsky 2008-09-29 17:49:25 EDT
I've also been bitten by the no-boot-thingy, Lenovo T60, Core2Duo. I'll add a screenshot tomorrow (hopefully) and gladly any other information you may find useful :-)
Comment 9 David Kovalsky 2008-09-30 11:27:00 EDT
So using clocksource=hpet does no difference. Adding a screenshot where the kernel actually hangs. Let me know what output do you need from me to better diagnose the problem.
Comment 10 David Kovalsky 2008-09-30 11:28:36 EDT
Created attachment 318093 [details]
Photo of the display/screen where the boot hangs
Comment 11 Fredrik Duprez 2008-10-02 15:21:30 EDT
I get a hang at boot with both 2.6.26 kernels on fedora 9. See attached screenshot.

Both 2.6.25 kernels (fedora 9) and fedora 10 beta kernel boot fine.

This is on an IBM Intellistation M Pro (P4-3.2)
Comment 12 Fredrik Duprez 2008-10-02 15:23:20 EDT
Created attachment 319284 [details]
Screenshot of kernel hanging at boot (Intellistation M Pro)
Comment 13 Chuck Ebbert 2008-10-03 22:41:03 EDT
(In reply to comment #9)
> So using clocksource=hpet does no difference. Adding a screenshot where the
> kernel actually hangs. Let me know what output do you need from me to better
> diagnose the problem.

Did you try 2.6.26.5-45? This kernel has a set of timer fixes that will be in 2.6.26.6. The next kernel, based on 2.6.26.6, will have more timer fixes.
Comment 14 Fredrik Duprez 2008-10-04 03:10:44 EDT
(In reply to comment #13)
> (In reply to comment #9)
> > So using clocksource=hpet does no difference. Adding a screenshot where the
> > kernel actually hangs. Let me know what output do you need from me to better
> > diagnose the problem.
> 
> Did you try 2.6.26.5-45? This kernel has a set of timer fixes that will be in
> 2.6.26.6. The next kernel, based on 2.6.26.6, will have more timer fixes.

My rig (screenshot attached) hangs at both 2.6.26 kernels released for fedora 9, including 2.6.26.5-45. The fedora 10 beta kernel boots.
Comment 15 Fredrik Duprez 2008-10-04 08:14:08 EDT
Comment on attachment 319284 [details]
Screenshot of kernel hanging at boot (Intellistation M Pro)

Screenshot is from trying to boot
kernel-2.6.26.5-45.fc9
Comment 16 Chuck Ebbert 2008-10-10 03:04:56 EDT
This should be fixed in 2.6.26.6
Comment 17 David Kovalsky 2008-10-10 03:43:15 EDT
Actually I'm able to boot with 2.6.26.5-28.fc8.

[dkovalsk@kovinek ~]$ uname -a
Linux kovinek 2.6.26.5-28.fc8 #1 SMP Sat Sep 20 09:32:58 EDT 2008 i686 i686 i386 GNU/Linux


Thanks for the fix!
Comment 18 Stephen P. Schaefer 2008-10-10 14:42:54 EDT
Unfortunately, my ASUSTek Z84J continues to require "clock=hpet" as a kernel argument in order to boot with 2.6.26.5-28.fc8 (Thank you, Ivo, for the suggestion).
Comment 19 Fedora Update System 2008-10-14 15:52:55 EDT
kernel-2.6.26.6-46.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-46.fc8
Comment 20 Fedora Update System 2008-10-14 16:01:05 EDT
kernel-2.6.26.6-71.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-71.fc9
Comment 21 Fedora Update System 2008-10-14 16:05:37 EDT
kernel-2.6.26.6-46.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-46.fc8
Comment 22 Fedora Update System 2008-10-17 20:19:54 EDT
kernel-2.6.26.6-49.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-49.fc8
Comment 23 Fedora Update System 2008-10-20 16:29:02 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8929
Comment 24 Fredrik Duprez 2008-10-21 15:01:10 EDT
Doesn't make any difference on my rig. It still hangs at the same spot.  The fedora 10 kernels all work (2.6.27.x)
Comment 25 Ivo 2008-10-21 16:35:31 EDT
2.6.26.6-79 solves the problem for me. 
Interestingly it chooses hpet as clocksource by default. 
As far as I recall 2.6.25.x kernel used to choose acpi_pm.
However, the new kernel boots without problems using either hpet or acpi_pm.
Comment 26 Fedora Update System 2008-10-23 12:37:49 EDT
kernel-2.6.26.6-49.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2008-10-23 12:38:30 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fredrik Duprez 2008-10-23 15:37:19 EDT
As stated in comment #24 it doesn't solve the problems on my rig. See the attached screenshot.
Comment 29 Stephen P. Schaefer 2008-10-23 16:32:20 EDT
How soon should I see the update?

[sps@thyrsus-laptop2 ~]$ sudo yum install kernel-2.6.26.6
Setting up Install Process
Parsing package install arguments
No package kernel-2.6.26.6 available.
Nothing to do
Comment 30 Chuck Ebbert 2008-10-23 22:01:31 EDT
(In reply to comment #29)
> How soon should I see the update?
> 
> [sps@thyrsus-laptop2 ~]$ sudo yum install kernel-2.6.26.6
> Setting up Install Process
> Parsing package install arguments
> No package kernel-2.6.26.6 available.

It's kernel-2.6.26.6-79.fc9 .

And erase the one that won't boot first, if you haven't done that already.
Comment 31 Stephen P. Schaefer 2008-10-24 13:51:51 EDT
Since my last comment, the update became visible to me:

[sps@thyrsus-laptop2 ~]$ sudo yum install kernel-2.6.26.6
Password:
livna                                                    | 2.1 kB     00:00     
primary.sqlite.bz2                                       | 499 kB     00:03     
http://mirror.cogentco.com/pub/linux/fedora/linux/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
fedora                                                   | 2.1 kB     00:00     
updates-newkey                                           | 2.3 kB     00:00     
updates                                                  | 2.6 kB     00:00     
Setting up Install Process
Parsing package install arguments
Package kernel-2.6.26.6-49.fc8.i686 already installed and latest version
Nothing to do

...and I'm happy to report that it boots without any extra clock= options.
Comment 32 Fredrik Duprez 2008-10-27 20:32:19 EDT
After being pushed to stable 2.6.26.6-79.fc9.i686 solves the problem for me.

The rig boots again.

Note You need to log in before you can comment on or make changes to this bug.