Bug 462186 - Installs in kvm stall at udevsettle
Installs in kvm stall at udevsettle
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 465529 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-13 12:48 EDT by Julian Sikorski
Modified: 2008-11-12 10:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 10:13:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file of the rawhide installation, ignore_loglevel (21.83 KB, text/plain)
2008-09-14 04:10 EDT, Julian Sikorski
no flags Details
Same log with ignore_loglevel initcall_debug (23.33 KB, text/plain)
2008-09-14 04:30 EDT, Julian Sikorski
no flags Details

  None (edit)
Description Julian Sikorski 2008-09-13 12:48:12 EDT
Description of problem:
When installing rawhide on a Fedora 9 kvm host, installer freezes during partitions creation. I was told that the thing happening at that time is udevsettle, hence the description. The following message is displayed at the freeze time: Activating new partitions. 

Version-Release number of selected component (if applicable):
kvm-65-7.fc9.x86_64 (host)
anaconda-11.4.1.34-1.x86_64 (guest)
udev-127-1.fc10.x86_64 (guest)

How reproducible:
always

Steps to Reproduce:
1. Set up a kvm host in F-9
2. Attempt to install rawhide. I used the following command: virt-install --hvm --os-type=linux --location=http://sunsite.icm.edu.pl/pub/Linux/fedora/linux/development/i386/os/ --name=rawhide-fullvirt --vcpus=1 --file=/var/lib/libvirt/images/rawhide-fullvirt.img --accelerate --ram=512 --file-size=15
3. Proceed as normal preserving default options
  
Actual results:
Installer freezes

Expected results:
Installer installs rawhide to the end

Additional info:
I tried rawhide trees from 20080719, 20080912 and 20080913, which all fail. Fedora 9 installs fine.
Comment 1 Julian Sikorski 2008-09-13 13:41:27 EDT
virt-install --hvm --os-type=linux --location=http://sunsite.icm.edu.pl/pub/Linux/fedora/linux/development/i386/os/ --name=rawhide-fullvirt --vcpus=1 --file=/var/lib/libvirt/images/rawhide-fullvirt.img --accelerate --ram=512 --file-size=15 --extra-args="console=ttyS0 console=tty0 ignore_loglevel initcall_debug" made it work. More info to follow tomorrow.
Comment 2 Julian Sikorski 2008-09-13 14:16:44 EDT
Of course the guest packages are i386.
Comment 3 Julian Sikorski 2008-09-14 03:48:32 EDT
Erm, that's what happens when you work on one thing for too long... It turns out that i386 guest installs on x86_64 host even without any parameters specified, it's x86_64 guest that stalls. I'll post some logs ASAP.
Comment 4 Julian Sikorski 2008-09-14 04:10:29 EDT
Created attachment 316683 [details]
Log file of the rawhide installation, ignore_loglevel

This is the stuff that gets output to the serial console with the following command:
virt-install --hvm --os-type=linux --location=http://sunsite.icm.edu.pl/pub/Linux/fedora/linux/development/x86_64/os/ --name=rawhide-x86_64 --vcpus=1 --file=/var/lib/libvirt/images/rawhide-x86_64.img --accelerate --ram=512 --file-size=15 --extra-args="console=ttyS0 console=tty0 ignore_loglevel"
At this point, anaconda is stalled.
Comment 5 Julian Sikorski 2008-09-14 04:30:42 EDT
Created attachment 316684 [details]
Same log with ignore_loglevel initcall_debug
Comment 6 Harald Hoyer 2008-09-16 03:15:40 EDT
I don't know how to debug anaconda..

udevsettle just waits for all udev events to be processed. What I would need is a list of processes running at that moment, or setting udev in debug mode. 

Does anaconda use "start_udev" ? I don't think so. 

Putting udev in debug mode would be:
/sbin/udevadm control --log_priority=debug
Comment 7 Andy Lindeberg 2008-10-08 17:40:20 EDT
*** Bug 465529 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2008-11-11 17:23:53 EST
There is no easy way to do this, no.  It requires rebuilding the loader and making new boot media.  Is this still an issue?
Comment 9 Julian Sikorski 2008-11-12 05:10:16 EST
I just tried and anaconda manages to pass the "Activating new partitions" screen, so it seems this problem is fixed (unless udevsettle is run at different point).
Comment 10 Harald Hoyer 2008-11-12 05:14:40 EST
udevsettle does not do bad things!
Comment 11 Julian Sikorski 2008-11-12 05:18:34 EST
I have no idea what was locking up anaconda, blaming udevsettle is a result of a chat with folks in #fedora-devel, who said that this is what is happening when "Activating new partitions" is displayed. Anyway, it seems to work now so I believe this report can be closed.

Note You need to log in before you can comment on or make changes to this bug.