Bug 462192 - Next/Back off bottom of the screen in firstboot
Next/Back off bottom of the screen in firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 463943 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-13 15:53 EDT by Laurence
Modified: 2008-10-12 14:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-12 14:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (269.88 KB, image/png)
2008-09-25 16:38 EDT, Laurence
no flags Details
/tmp/firstbootX.log (25.40 KB, text/plain)
2008-09-25 17:20 EDT, Laurence
no flags Details
photo of firstboot screen on T60p (screen 1600x1200) (1.54 MB, image/jpeg)
2008-09-26 07:37 EDT, Peter F. Patel-Schneider
no flags Details

  None (edit)
Description Laurence 2008-09-13 15:53:15 EDT
Description of problem:

Back/Next buttons off bottom of screen. GDM and normal X are fine, nothing chopped off the bottom of them. Am running rawhide from 12/9, with modesetting ati.

Version-Release number of selected component (if applicable):

How reproducible:

Every time

Steps to Reproduce:
1. When it loads on first boot
2. Or... touch /etc/reconfigSys, edit /etc/sysconfig/firstboot, chkconfig firstboot on
  
Actual results:

Next/Back buttons off bottom of screen

Expected results:

Able to see Next/Back buttons

Additional info:
Comment 1 John Poelstra 2008-09-19 15:53:52 EDT
adding to blocker... new F10 feature
Comment 2 Chris Lumens 2008-09-24 16:53:46 EDT
Does this machine run at some unusual resolution?  Can you attach a picture of the display?
Comment 3 Laurence 2008-09-24 18:16:24 EDT
Laptop screen, 1920x1200 native resolution. Any tips on getting a screenshot from firstboot?
Comment 4 Chris Lumens 2008-09-25 13:00:17 EDT
*** Bug 463943 has been marked as a duplicate of this bug. ***
Comment 5 Peter F. Patel-Schneider 2008-09-25 14:02:44 EDT
I'm getting the same behaviour on a Thinkpad T60p with a 1600x1200 resolution screen.  If you mean a real photo, I might be able to get one tonight.
Comment 6 Chris Lumens 2008-09-25 15:19:33 EDT
A real photo would be fine.
Comment 7 Laurence 2008-09-25 16:38:04 EDT
Created attachment 317725 [details]
Screenshot

Screenshot from firstboot
Comment 8 Laurence 2008-09-25 16:39:21 EDT
As you can see from the screenshot, it thinks my screen is square!

xdpyinfo agrees:

screen #0:
  dimensions:    1920x1920 pixels (508x508 millimeters)

For some reason gdm and gnome run fine, not off the bottom of the screen?!
Comment 9 Chris Lumens 2008-09-25 16:47:55 EDT
Yes, that would definitely be the problem.  I'm not doing anything special in firstboot to start up X anymore, so this shouldn't be my bug.  The /tmp/firstbootX.log file might be helpful in debugging what's going wrong here.
Comment 10 Laurence 2008-09-25 17:20:14 EDT
Created attachment 317729 [details]
/tmp/firstbootX.log
Comment 11 Peter F. Patel-Schneider 2008-09-26 07:37:25 EDT
Created attachment 317783 [details]
photo of firstboot screen on T60p (screen 1600x1200)

Here is a photo of one of the first boot screens on my T60p (screen size 1600x1200).  I have a couple other photos, but they all are missing the bottom buttons, just like this one.
Comment 12 Laurence 2008-09-30 18:37:26 EDT
However... looking at the logfile although initially it thinks the screen is 1920x1920, it then resizes it to 1920x1200 (correct).

GDM & GNOME seems to be fine with this... but firstboot not.
Comment 13 Peter F. Patel-Schneider 2008-10-11 08:10:40 EDT
Seems to be fixed in the Snap1 version, although the graphical experience is not always first rate.

I'm getting a ... Assuming cache write through message that interrupts the graphical sequence.
Comment 14 Laurence 2008-10-12 14:34:32 EDT
Fixed for me in snap1 too, closing...

Note You need to log in before you can comment on or make changes to this bug.