Bug 462203 - Assertion failure: !s->thread_info.rewind_re quested' failed at pulsecore/sink.c:632
Assertion failure: !s->thread_info.rewind_re quested' failed at pulsecore/sin...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 463108 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-13 23:14 EDT by Ralph Loader
Modified: 2008-10-06 13:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 13:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2008-09-13 23:14:31 EDT
pulseaudio dies with an assertion failure at login:

Sep 14 15:01:25 i kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_
stream: NID=0x6
Sep 14 15:01:34 i pulseaudio[2614]: sink.c: Assertion '!s->thread_info.rewind_re
quested' failed at pulsecore/sink.c:632, function pa_sink_render(). Aborting.
Sep 14 15:01:34 i gnome-session[2483]: DEBUG(+): GsmXsmpServer: ice_io_error_han
dler (0x93ccc48)


Seems to happen everytime.

Also I have a fair number of these in my logs, I think from failed attempts to play sounds:

Sep 14 15:01:34 i pulseaudio[2614]: sink.c: Assertion '!s->thread_info.rewind_re
quested' failed at pulsecore/sink.c:632, function pa_sink_render(). Aborting.


pulseaudio-0.9.12-5.fc10.i386
Linux i.geek.nz 2.6.27-0.323.rc6.fc10.i686

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
Comment 1 Lennart Poettering 2008-10-01 20:39:59 EDT
*** Bug 463108 has been marked as a duplicate of this bug. ***
Comment 2 Lennart Poettering 2008-10-01 21:09:15 EDT
Fixed upstream now in ra0f4ffd. Will upload a fixed version to Rawhide shortly.
Comment 3 Lennart Poettering 2008-10-06 13:34:38 EDT
Fixed in 0.9.13-1

Note You need to log in before you can comment on or make changes to this bug.