Bug 463108 - Pulseaudio + Flash10 + x86_64 = no mixing
Pulseaudio + Flash10 + x86_64 = no mixing
Status: CLOSED DUPLICATE of bug 462203
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 17:05 EDT by Saikat Guha
Modified: 2008-10-01 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 20:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saikat Guha 2008-09-21 17:05:32 EDT
Description of problem:

I know Flash is not supported as free software, however, the presence of libflashsupport suggests that there is some interest in getting flash to work on Fedora. To that end, I followed the instructions on http://macromedia.mplug.org/ to test Flash 10 (beta) on a x86_64 box. As suggested on that page, I removed libflashsupport. I got the following results.

A) If browser+flash is started when no other application is playing, sound in flash works fine, however, I cannot use any pulse audio application.

Mplayer reports error 
AO: [pulse] pa_stream_write() failed: Connection terminated,?% 5 0
AO: [pulse] pa_stream_get_latency() failed: Connection terminated

Even after the browser and flash processes are killed, I get the error until I delete everything inside ~/.pulse/

B) If flash is started while another application is running, I get no sound in flash, but I can use other pulse audio apps just fine.


What debug information should I provide to diagnose the problem?
Comment 1 Lennart Poettering 2008-09-23 19:54:12 EDT
Please run "pulseaudio -vvvv" in a terminal. Then do your testing and paste the output of that call here. (you might need to kill the running PA instance first by issuing "pulseaudio -k")
Comment 2 Saikat Guha 2008-09-23 20:36:41 EDT
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root priviliges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
D: main.c: Started as real root: no, suid root: yes
I: main.c: PolicyKit refuses acquire-high-priority privilege.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
D: main.c: Can realtime: no, can high-priority: no
I: main.c: This is PulseAudio 0.9.12
D: main.c: Compilation host: x86_64-redhat-linux-gnu
D: main.c: Compilation CFLAGS: -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -W -Wextra -pedantic -pipe -Wno-long-long -Wvla -Wno-overlength-strings -Wconversion -Wundef -Wformat -Wlogical-op -Wpacked -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Wno-unused-parameter -ffast-math
D: main.c: Running on host: Linux x86_64 2.6.25-14.fc9.x86_64 #1 SMP Thu May 1 06:06:21 EDT 2008
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Optimized build: yes
I: main.c: Machine ID is a2b71a90c29146cc307fcb2a48ccd032.
I: main.c: Using runtime directory /home/saikat/.pulse/a2b71a90c29146cc307fcb2a48ccd032:runtime.
I: main.c: Using state directory /home/saikat/.pulse.
I: main.c: Running in system mode: no
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib64/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 tsched=1'
D: alsa-util.c: Trying front:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device front:0: Device or resource busy
D: alsa-util.c: Trying surround40:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround40:0: Device or resource busy
D: alsa-util.c: Trying surround41:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround41:0: Device or resource busy
D: alsa-util.c: Trying surround50:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround50:0: Device or resource busy
D: alsa-util.c: Trying surround51:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround51:0: Device or resource busy
D: alsa-util.c: Trying surround71:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround71:0: Device or resource busy
D: alsa-util.c: Trying hw:0 as last resort...
D: alsa-util.c: Trying hw:0...
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_10de_59_sound_card_0_alsa_capture_0 tsched=1'
D: alsa-util.c: Trying front:0...
D: alsa-util.c: Maximum hw buffer size is 341 ms
W: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: module-alsa-source.c: Successfully enabled timer-based scheduling mode.
I: (alsa-lib)control.c: Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 0 "alsa_input.pci_10de_59_sound_card_0_alsa_capture_0" with sample spec s16le 2ch 48000Hz and channel map front-left,front-right
I: module-alsa-source.c: Using 1 fragments of size 65536 bytes, buffer time is 341.33ms
I: module-alsa-source.c: Time scheduling watermark is 18.38ms
D: module-alsa-source.c: hwbuf_unused_frames=0
D: module-alsa-source.c: setting avail_min=62005
I: module-alsa-source.c: Volume ranges from 0 to 15.
I: module-alsa-source.c: Volume ranges from 0.00 dB to 22.50 dB.
I: alsa-util.c: All 2 channels can be mapped to mixer channels.
I: module-alsa-source.c: Using hardware volume control. Hardware dB scale supported.
D: alsa-util.c: snd_pcm_dump():
D: alsa-util.c: Hardware PCM card 0 'NVidia CK804' device 0 subdevice 0
D: alsa-util.c: Its setup is:
D: alsa-util.c:   stream       : CAPTURE
D: alsa-util.c:   access       : MMAP_INTERLEAVED
D: alsa-util.c:   format       : S16_LE
D: alsa-util.c:   subformat    : STD
D: alsa-util.c:   channels     : 2
D: alsa-util.c:   rate         : 48000
D: alsa-util.c:   exact rate   : 48000 (48000/1)
D: alsa-util.c:   msbits       : 16
D: alsa-util.c:   buffer_size  : 16384
D: alsa-util.c:   period_size  : 16384
D: alsa-util.c:   period_time  : 341333
D: alsa-util.c:   tstamp_mode  : NONE
D: alsa-util.c:   period_step  : 1
D: alsa-util.c:   avail_min    : 62005
D: alsa-util.c:   period_event : 0
D: alsa-util.c:   start_threshold  : -1
D: alsa-util.c:   stop_threshold   : -1
D: alsa-util.c:   silence_threshold: 0
D: alsa-util.c:   silence_size : 0
D: alsa-util.c:   boundary     : 4611686018427387904
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
D: module-alsa-source.c: Read hardware volume: 0: 100% 1: 100%
I: module.c: Loaded "module-alsa-source" (index: #0; argument: "device_id=0 source_name=alsa_input.pci_10de_59_sound_card_0_alsa_capture_0 tsched=1").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 1 modules.
I: module.c: Loaded "module-hal-detect" (index: #1; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib64/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #2; argument: "").
I: module.c: Loaded "module-native-protocol-unix" (index: #3; argument: "").
I: module-stream-restore.c: Sucessfully opened database file '/home/saikat/.pulse/a2b71a90c29146cc307fcb2a48ccd032:stream-volumes.x86_64-redhat-linux-gnu.gdbm'.
I: module.c: Loaded "module-stream-restore" (index: #4; argument: "").
I: module-device-restore.c: Sucessfully opened database file '/home/saikat/.pulse/a2b71a90c29146cc307fcb2a48ccd032:device-volumes.x86_64-redhat-linux-gnu.gdbm'.
I: module.c: Loaded "module-device-restore" (index: #5; argument: "").
I: module-default-device-restore.c: Saved default sink 'auto_null' not existant, not restoring default sink setting.
I: module-default-device-restore.c: Restored default source 'alsa_input.pci_10de_59_sound_card_0_alsa_capture_0'.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-always-sink.c: Autoloading null-sink as no other sinks detected.
I: module-device-restore.c: Restoring volume for sink auto_null.
I: module-device-restore.c: Restoring mute state for sink auto_null.
I: sink.c: Created sink 0 "auto_null" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-device-restore.c: Restoring volume for source auto_null.monitor.
I: module-device-restore.c: Restoring mute state for source auto_null.monitor.
I: source.c: Created source 1 "auto_null.monitor" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
D: module-null-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-null-sink" (index: #8; argument: "sink_name=auto_null").
I: module.c: Loaded "module-always-sink" (index: #9; argument: "").
D: module-suspend-on-idle.c: Sink auto_null becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_10de_59_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source auto_null.monitor becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #10; argument: "").
I: client.c: Created 0 "ConsoleKit Session /org/freedesktop/ConsoleKit/Session2"
D: module-console-kit.c: Added new session /org/freedesktop/ConsoleKit/Session2
I: module.c: Loaded "module-console-kit" (index: #11; argument: "").
I: module.c: Loaded "module-position-event-sounds" (index: #12; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib64/pulse-0.9/modules/module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #13; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
D: module-console-kit.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Sink auto_null idle for too long, suspending ...
I: module-suspend-on-idle.c: Source auto_null.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Source alsa_input.pci_10de_59_sound_card_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: client.c: Created 1 "Native client (UNIX socket client)"
D: protocol-native.c: Protocol version: remote 14, local 14
I: protocol-native.c: Got credentials: uid=500 gid=500 success=1
D: protocol-native.c: SHM possible: yes
D: protocol-native.c: Negotiated SHM: yes
I: module-stream-restore.c: Restoring device for stream sink-input-by-application-name:MPlayer.
D: module-stream-restore.c: Not restoring volume for sink input sink-input-by-application-name:MPlayer, because already set.
D: module-stream-restore.c: Not restoring mute state for sink input sink-input-by-application-name:MPlayer, because already set.
D: module-suspend-on-idle.c: Sink auto_null becomes idle.
D: module-suspend-on-idle.c: Sink auto_null becomes busy.
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
D: memblockq.c: memblockq requested: maxlength=33554432, tlength=0, base=4, prebuf=0, minreq=1 maxrewind=0
D: memblockq.c: memblockq sanitized: maxlength=33554432, tlength=33554432, base=4, prebuf=0, minreq=4 maxrewind=0
I: sink-input.c: Created input 0 "audio stream" on auto_null with sample spec s16le 2ch 48000Hz and channel map front-left,front-right
I: protocol-native.c: Requested tlength=250.00 ms, minreq=20.00 ms
D: protocol-native.c: Traditional mode enabled, modifying sink usec only for compat with minreq.
D: memblockq.c: memblockq requested: maxlength=4194304, tlength=48000, base=4, prebuf=48000, minreq=3840 maxrewind=0
D: memblockq.c: memblockq sanitized: maxlength=4194304, tlength=48000, base=4, prebuf=48000, minreq=3840 maxrewind=0
I: protocol-native.c: Final latency 460.00 ms = 210.00 ms + 2*20.00 ms + 210.00 ms
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-null-sink.c: Requested to rewind 352800 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 352800 bytes on render memblockq.
D: module-null-sink.c: Rewound 352800 bytes.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-null-sink.c: Requested to rewind 352800 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 13408 bytes on render memblockq.
D: module-null-sink.c: Rewound 13408 bytes.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-null-sink.c: Requested to rewind 352800 bytes.
E: sink.c: Assertion '!s->thread_info.rewind_requested' failed at pulsecore/sink.c:632, function pa_sink_render(). Aborting.
Comment 3 Lennart Poettering 2008-09-24 08:44:45 EDT
Hmm, this dump shows that access to your audio device is blocked because some other applications uses it. Please figure out which one that is, and terminate it. Then start PA again.

Because no audio device is initialize PA will initialize a null sink, which however then causes a failure, which is already described in bug 462203.
Comment 4 Saikat Guha 2008-09-24 09:48:59 EDT
I assume that application is Flash wrapped inside NSPluginWrapper. However, Flash 10 is supposed to work with PulseAudio without the need of libflashplayersupport (at least on i386 I'd assume). I am wondering if they (Adobe) cannot handle x86_64, and libflashplayersupport needs to be updated to support Flash 10 and x86_64.
Comment 5 Lennart Poettering 2008-10-01 20:39:59 EDT
Anyway, this is mostly a duplicate of bug 462203 and the other issue is not a bug in PA. Closing.

*** This bug has been marked as a duplicate of bug 462203 ***

Note You need to log in before you can comment on or make changes to this bug.