This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 462210 - Macbook Pro stuck on kernel load
Macbook Pro stuck on kernel load
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 465320 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 02:30 EDT by Alexey Kuznetsov
Modified: 2008-11-05 13:22 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 10:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
-44 kernel build screen (286.54 KB, image/jpeg)
2008-09-20 01:16 EDT, Alexey Kuznetsov
no flags Details
stuck for -45 (439.49 KB, image/jpeg)
2008-10-08 03:37 EDT, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2008-09-14 02:30:58 EDT
Last kernel 2.6.26.3-29.fc9.i686 prevent fedora boot
Comment 1 Alexey Kuznetsov 2008-09-16 06:49:31 EDT
-39, -41 kernel builds have same issue. i will try git kernel version with fedora -41 config...
Comment 2 Alexey Kuznetsov 2008-09-16 07:53:06 EDT
2.6.26.5 git version stuck also...

here is bug created in bugzilla.kernel.org about this issue.

http://bugzilla.kernel.org/show_bug.cgi?id=11575
Comment 3 Chuck Ebbert 2008-09-19 18:04:12 EDT
patch suggested in kernel.org bugzilla is in 2.6.26.5-44
Comment 4 Alexey Kuznetsov 2008-09-20 01:16:18 EDT
Created attachment 317274 [details]
-44 kernel build screen

still stuck on boot
Comment 5 Chuck Ebbert 2008-09-20 02:42:45 EDT
Upstream bug says disabling aspm fixed the bug. How did you do that?
Comment 6 Alexey Kuznetsov 2008-09-20 02:46:32 EDT
i take git kernerl version 2.6.26.5. by make xconfig i load /boot/config-2.6.26.5-44.fc9.i686, after it i disable ASPM module by removing checkbox.

then compile and install it on my machine.
Comment 7 Chuck Ebbert 2008-09-20 03:06:31 EDT
Three new patches from the upstream bug are in 2.6.26.5-45, building now.
Comment 8 Chuck Ebbert 2008-09-20 13:57:18 EDT
Alexey, can you test 2.6.26.5-45?
Comment 9 Alexey Kuznetsov 2008-09-20 16:16:52 EDT
Sorry for delay Chuck. -45 build boot finely.
Comment 10 Alexey Kuznetsov 2008-09-22 04:02:25 EDT
today morning i unable to boot -45 kernel, they stuck on:

...
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found



after i boot to fedora rescue, and remove selinux they magicaly pass trougth that message.... reverting selinux to enforced state do not help reproduce that bug...


probably not everyting solved, but now -45 boot finely
Comment 11 Fedora Update System 2008-09-24 20:17:11 EDT
kernel-2.6.26.5-45.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8283
Comment 12 Fedora Update System 2008-10-01 02:37:04 EDT
kernel-2.6.26.5-45.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Chuck Ebbert 2008-10-04 00:37:16 EDT
*** Bug 465320 has been marked as a duplicate of this bug. ***
Comment 14 Alexey Kuznetsov 2008-10-08 03:37:08 EDT
Created attachment 319732 [details]
stuck for -45

sometimes, rarely i got stucked on boot.
Comment 15 Alexey Kuznetsov 2008-10-08 03:41:59 EDT
similar problem, probably related to 2.6.26-45:

http://forums.fedoraforum.org/showthread.php?t=200713&highlight=rhgb
Comment 16 Chuck Ebbert 2008-10-10 02:03:28 EDT
(In reply to comment #15)
> similar problem, probably related to 2.6.26-45:
> 
> http://forums.fedoraforum.org/showthread.php?t=200713&highlight=rhgb

Probably fixed by commit 38c052f8cff1bd323ccfa968136a9556652ee420,
now in 2.6.26.6.

This is bug 466060 on F8 and bug 465525 on F9.
Comment 17 Raffaele Candeliere 2008-10-10 03:43:47 EDT
I confirm the bug in 2.6.26.5-45. This kernel has solved the problem of the boot process stuck with the message "PCI:BIOS ERROR: the memory at f0000000 is not ACPI reserved" of the 2.6.26.3-14 version, but sometimes it hangs on boot. It is completely random. It hangs every 1 out of two times, more or less
Comment 18 Alexey Kuznetsov 2008-10-10 07:55:45 EDT
is possible for fedora 9 to move to 2.6.27?
Comment 19 Alexey Kuznetsov 2008-10-17 06:17:27 EDT
i want to reopen this bug, because problems happens again. my notebook can stuck for 2-5 times before he can pass "Scanning for PnP..." message. You can see it in "stuck for -45" attachment.

Now i use 2.6.27.1 and problem never back again with last kernel. Also i do not seen problem with 2.6.27...
Comment 20 Chuck Ebbert 2008-10-23 22:42:25 EDT
Can you test 2.6.26.6-79.fc9?
Comment 21 Alexey Kuznetsov 2008-10-24 07:26:10 EDT
two times booted finely... that mean nothing, please take a while... at least one week
Comment 22 Alexey Kuznetsov 2008-10-26 12:26:48 EDT
seems good for me, no more hangs at boot. anyone else wana confirm?
Comment 23 Raffaele Candeliere 2008-11-05 13:22:26 EST
Yes. I confirm too. With 2.6.26.6-79.fc9 no more hangs on my alu iMac (at least till now...)

Note You need to log in before you can comment on or make changes to this bug.