This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 465320 - Kernel 2.6.26.3-14 hangs immediately after nash on an aluminium iMac
Kernel 2.6.26.3-14 hangs immediately after nash on an aluminium iMac
Status: CLOSED DUPLICATE of bug 462210
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 15:05 EDT by Raffaele Candeliere
Modified: 2008-10-04 05:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-04 00:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raffaele Candeliere 2008-10-02 15:05:24 EDT
Description of problem:
The kernel hangs immediately with the following message 
BIOS ERROR: MCFG memory af f000000000000000 is not ACPI reserved


Version-Release number of selected component (if applicable):
2.6.26.3-14

How reproducible:
install a 2.6.26.3-14 kernel on a 20" aluminimum iMac.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
The system doesn't boot

Expected results:


Additional info:
No log files, no dmesg. Nothing. It is impossible to take some information, since the boot process doesn't even reach a phase in which it can access the disk.
It stays indefinitely there with the "Red Hat Nash starting" and "kernel alive" rows below the formerly reported error.
The previous kernel, on the contrary, (2.6.24.?) doesn't show the problem.
It starts perfectly.

Thank you
Comment 1 Raffaele Candeliere 2008-10-03 10:39:56 EDT
Hallo again.
Yesterday, while posting the bug, i wasn't in front of my iMac so i've been a bit unprecise about the kernel versions.
The faulty kernel is 2.6.26.3-29 (instead of ...-14 as stated) while the working one is the 2.6.25.14-108 (instead of the 2.6.24-... as stated).

The screen, immediately after the grub phase, displays the following lines:

<Top of the screen>
<Some GRUB lines>

Decompressing Linux... Parsing ELF... Done
Booting the kernel
PCI:BIOS BUG: MCFG area at f000000 is not reserved in ACPI motherboard resources.

i8042.c: No controller found.
Red Hat nash version 6.0.52 starting


Kernel alive
<Bottom of the screen>

P.S. the line "i8042.c ..." used to appear also with the working kernel, therefore i suppose it has nothing to do with the hang.
Comment 2 Chuck Ebbert 2008-10-04 00:37:16 EDT
Should be fixed in 2.6.26.5-45

*** This bug has been marked as a duplicate of bug 462210 ***
Comment 3 Raffaele Candeliere 2008-10-04 05:04:59 EDT
Thank you very much

Note You need to log in before you can comment on or make changes to this bug.