Bug 462235 - Nautilus crash @ startup "Nautilus can't be used now, due to an unexpected error"
Nautilus crash @ startup "Nautilus can't be used now, due to an unexpected er...
Status: CLOSED DUPLICATE of bug 238227
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 13:14 EDT by Stephen Warren
Modified: 2015-03-03 17:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 16:41:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2008-09-14 13:14:23 EDT
Description of problem:

Immediately after login, nautilus crashes(?) and displays a dialog box with no title, and the following text:

  Nautilus can't be used now,
  due to an unexpected error.

Clicking the "Show more details" button displays this additional text:

  Nautilus can't be used now, due to an
  unexpected error from Bonobo when attempting
  to locate the factory. Killing bonobo-activation-
  server and restarting Nautilus may help fix the
  problem.

Clicking the OK button restarts Nautilus, thus making the desktop icons appear for the first time this login session. Also, an unexpected nautilus file browsing window appears displaying the user's home directory. This window was not open at last logout.

Version-Release number of selected component (if applicable):
nautilus-2.22.5.1-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Log in (or perhaps unlock after hibernate)
2. Wait
Comment 1 Stephen Warren 2008-09-14 13:20:33 EDT
Additional notes:
* This happens at initial login, not unlock after hibernate.
* It isn't "always", instead it's "often".
* I believe this is a regressions that appeared as part of the updates since the F9 security outage; i.e. the last week or so. I don't recall seeing this before then. That said, hibernate worked before then, so perhaps I wasn't logging in from scratch so much.
Comment 2 Adam Huffman 2008-11-07 03:27:41 EST
In the past couple of days I've seen this on two systems running Rawhide.  The only other message shown when starting nautilus from the terminal is:

** (nautilus:4020): WARNING **: Unable to add monitor: Not supported
Comment 3 Stephen Warren 2008-11-07 11:58:24 EST
Yes, this still continually happens to my wife on F9.
Comment 4 Mike Iglesias 2008-12-03 16:48:52 EST
I'm seeing this behaviour on a system I upgraded from F8 to F9 with the Unity respin 20081004 DVD.  As Stephen noted, it doesn't happen every time I log in, but it's pretty close to every time.
Comment 5 Davide Repetto 2008-12-08 16:20:46 EST
This bug happens even more often in F10. I'm noticing it on almost any machine I upgraded (about 15 up to now).
Comment 6 Davide Repetto 2008-12-08 16:21:16 EST
bug 462235 and this should be merged.
Comment 7 Davide Repetto 2008-12-08 16:21:49 EST
Sorry. I meant bug 238227
Comment 8 Stephen Warren 2008-12-08 16:41:25 EST
Marking duplicate of 238227.

*** This bug has been marked as a duplicate of bug 238227 ***

Note You need to log in before you can comment on or make changes to this bug.