Bug 462273 - X/Open Federated Naming service master map entry should be handled by autofs
X/Open Federated Naming service master map entry should be handled by autofs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs5 (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Ian Kent
:
Depends On: 448674
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 23:44 EDT by Ian Kent
Modified: 2009-05-18 16:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:31:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Kent 2008-09-14 23:44:36 EDT
+++ This bug was initially created as a clone of Bug #448674 +++

Description of problem:

The xfn map type is not recognized by the autofs master map
parser. When encountered a syntax error is reported instead
of it being ignored.

Since this entry is common in the default installed master
map of other OS automount configurations this should be
handled by autofs.

How reproducible:
always.

Steps to Reproduce:
1. add master map entry with map type "-xfn"
2. start autofs.
  
Actual results:
Syntax error is reported and master map is not correctly
read.

Expected results:
Master map entry is correctly read and "not supported"
message issued.

--- Additional comment from pm-rhel@redhat.com on 2008-06-02 15:56:50 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 1 RHEL Product and Program Management 2008-09-24 16:24:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 errata-xmlrpc 2009-05-18 16:31:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1010.html

Note You need to log in before you can comment on or make changes to this bug.