Bug 462349 - FEAT: cdrom test should be split into multiple tests by media-type
FEAT: cdrom test should be split into multiple tests by media-type
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks: 445164
  Show dependency treegraph
 
Reported: 2008-09-15 11:56 EDT by Greg Nichols
Modified: 2014-03-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
opticalDiskTest.py common functions for cd and dvd testing (20.92 KB, text/x-python)
2008-09-29 21:32 EDT, Greg Nichols
no flags Details
cdrom.py re-write to use new OpticalDiskTest class (3.37 KB, text/x-python)
2008-09-29 21:35 EDT, Greg Nichols
no flags Details
dvd.py - the new DVD test based on the OpticalDiskTest class (6.97 KB, text/x-python)
2008-09-29 21:37 EDT, Greg Nichols
no flags Details

  None (edit)
Description Greg Nichols 2008-09-15 11:56:35 EDT
Description of problem:

The cdrom test should be split into media-specific tests:

CD
DVD
Blu-Ray
Comment 1 Greg Nichols 2008-09-15 11:57:03 EDT
Also, error-reporting needs improvement.
Comment 2 YangKun 2008-09-17 01:21:42 EDT
should I close bug#445164(FEAT: CDROM test should test Blu-ray Discs in rhel5) as duplicate of this one ? Seems the blu-ray testing will be covered in this bug ?
Comment 3 Rob Landry 2008-09-18 11:38:34 EDT
probably not, instead this bug should block #445164, where this bug will provide the basic research steps etc. such that when the cdrom test is split it's not a from nothing start for what is requried to properly test bluray but instead just the effort to split the test out.
Comment 4 Greg Nichols 2008-09-29 21:32:09 EDT
Created attachment 318031 [details]
opticalDiskTest.py common functions for cd and dvd testing


This file defines a python class OpticalDiskTest that is a base class for the CDROMTest test class and the new DVDTest test class.
Comment 5 Greg Nichols 2008-09-29 21:35:19 EDT
Created attachment 318032 [details]
cdrom.py re-write to use new OpticalDiskTest class


The CDROMTest class is for testing CD media support in optical disk drives.  This test is scheduled for any storage.cdrom device that supports CD-RW, CD-R or CDROM media.
Comment 6 Greg Nichols 2008-09-29 21:37:39 EDT
Created attachment 318033 [details]
dvd.py - the new DVD test based on the OpticalDiskTest class


The DVD test is planned for any storage.cdrom that supports DVD-+RW, DVD-+R or DVDROM media.  It uses the optical disk test class (OpticalDiskTest).
Comment 7 Greg Nichols 2008-09-29 21:40:25 EDT
In summary, the proposed change is to separate the old cdrom test into two tests, cdrom and dvd.  Much of the old test code has been moved to a common base class OpticalDiskTest.   Either or both of these tests will be scheduled for an optical drive, depending on it's media type.

The test code has also been changed to improve error handling and reporting.
Comment 9 Yan Tian 2009-01-01 21:42:39 EST
Verified hts-5.3-12 included 2 tests: cdrom and dvd.
Comment 11 errata-xmlrpc 2009-01-27 17:57:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.