Bug 462358 - Modules to add, remove or correct in Transifex
Modules to add, remove or correct in Transifex
Status: CLOSED NEXTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dimitris Glezos
Diego Búrigo Zacarão
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 12:59 EDT by Piotr Drąg
Modified: 2009-07-03 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-21 13:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Piotr Drąg 2008-09-15 12:59:46 EDT
Here it is:

* opyum is dead (and its l10n support was always broken), so it should be deleted
* pirut is also dead
* redhat-config-soundcard is dead too
* ...and rhgb is.
* talk.fedoraproject.org could be added (part of fedora-web git module)
* "f9-branch" branch of pykickstart could be added
* "Branch-RHEL5" branch of s-c-network could be added
* "rhel5" branch of s-c-netboot could be added
* "0.7.74.x" branch of s-c-printer can be removed (no longer needed)
Comment 1 Dimitris Glezos 2008-09-15 13:15:30 EDT
All done.

(In reply to comment #0)
> Here it is:
> 
> * opyum is dead (and its l10n support was always broken), so it should be
> deleted
> * pirut is also dead
> * redhat-config-soundcard is dead too
> * ...and rhgb is.

>>> for mn in ['opyum', 'pirut', 'redhat-config-soundcard', 'rhgb']:
...     m = Module.selectBy(name=m)[0]
...     m.disabled=True

> * talk.fedoraproject.org could be added (part of fedora-web git module)

https://translate.fedoraproject.org/submit/module/talk-fedoraproject-org

> * "f9-branch" branch of pykickstart could be added

  >>> b=Branch.selectBy(name='f9-branch')[0]
  >>> Module.selectBy(name='pykickstart')[0].addBranch(b)

> * "Branch-RHEL5" branch of s-c-network could be added

Module.selectBy(name='system-config-network')[0].addBranch(Branch(name='Branch-RHEL5'))

> * "rhel5" branch of s-c-netboot could be added

Module.selectBy(name='system-config-netboot')[0].addBranch(Branch(name='rhel5'))

> * "0.7.74.x" branch of s-c-printer can be removed (no longer needed)

>>> Module.selectBy(name='system-config-printer')[0].removeBranch(Branch.selectBy(name='0.7.74.x')[0])

Closing bug report. Please re-open when new configuration changes are needed.
Comment 2 Dimitris Glezos 2008-09-15 13:16:03 EDT
Forgot to thank you for collecting this data! =)
Comment 3 Piotr Drąg 2008-10-31 10:09:22 EDT
 * 0.7.32.x branch of system-config-printer should be (re)added - for RHEL5 releases

 * smoon module should be removed, as it's broken and translations of smoon can be submitted using smolt module

 * I would add common/entities/po folder of fedora-docs-utils module, if it's possible (now we can't update existing translations of entities!)

 * error can be removed from description of pkinit-nss (it's fixed for a long time)

 * Transifex description is not up to date (and it is important one), I suggest using DL description:

"Transifex is web system for submitting translations in various version control systems. This module is Fedora's customization of Transifex. PO files are available at http://hg.fedorahosted.org/hg/transifex/file/tip/transifex/po"


BTW configuration system of current Transifex is extremely not user friendly. Is it makes sense to file RFE report at Tx's upstream? :)
Comment 4 Dimitris Glezos 2008-10-31 13:27:07 EDT
Piotr, thanks for the spot-on requests.

(In reply to comment #3)
>  * 0.7.32.x branch of system-config-printer should be (re)added - for RHEL5
> releases

Done.

>  * smoon module should be removed, as it's broken and translations of smoon can
> be submitted using smolt module

Done.

>  * I would add common/entities/po folder of fedora-docs-utils module, if it's
> possible (now we can't update existing translations of entities!)

Done. I added the whole module, in particular its 'common' directory.

https://translate.fedoraproject.org/submit/module/docs-common-entities/

>  * error can be removed from description of pkinit-nss (it's fixed for a long
> time)

Fixed.

>  * Transifex description is not up to date (and it is important one), I suggest
> using DL description:
> 
> "Transifex is web system for submitting translations in various version control systems. This module is Fedora's customization of Transifex. PO files are available at http://hg.fedorahosted.org/hg/transifex/file/tip/transifex/po"

Fixed.

> BTW configuration system of current Transifex is extremely not user friendly.
> Is it makes sense to file RFE report at Tx's upstream? :)

I believe you've seen the new configuration system, on beta.transifex.net. If you feel something should be fixed there, definitely file a ticket!
Comment 5 Piotr Drąg 2008-10-31 13:44:17 EDT
D'oh, my mind is not here today. Yes, I've seen it, and it's great. Just a bit polishing, and it will be perfect.
Comment 6 Piotr Drąg 2008-10-31 13:53:50 EDT
(In reply to comment #4)
> (In reply to comment #3)
> >  * I would add common/entities/po folder of fedora-docs-utils module, if it's
> > possible (now we can't update existing translations of entities!)
> 
> Done. I added the whole module, in particular its 'common' directory.
> 
> https://translate.fedoraproject.org/submit/module/docs-common-entities/
> 

"There was a technical error with the commit/push of your submission, most likely because of a misconfiguration of the system. Try refreshing the module's cache and retry submitting. The administrators will look into the log files and try to find out what went wrong."
Comment 7 Piotr Drąg 2008-11-27 09:21:21 EST
 * f10-branch of anaconda should be added

 * F10-branch of initscripts should be added

 * fedoraproject.org website on git repo "fedora-web.git" should be (re)added (fedora-web-test.git has been deleted and new content has been migrated with regular repo)

 * translation-quick-start-guide is missing (and it has been moved to git repo)
Comment 8 Piotr Drąg 2008-12-01 15:26:42 EST
fedoraproject.org has been re-added by Ricky.
Comment 9 Piotr Drąg 2008-12-11 21:11:53 EST
desktop-effects is ready to be added for a long time (bug #438602).
Comment 10 Piotr Drąg 2009-01-09 18:55:04 EST
Ping:

 * f10-branch of anaconda should be added

 * F10-branch of initscripts should be added

 * 1.1.x branch of system-config-printer should be added

 * desktop-effects could be added (bug #438602)
Comment 11 Piotr Drąg 2009-03-21 13:33:37 EDT
All of these are correct in new Transifex. (And I have edit access :))
Comment 12 Piotr Drąg 2009-07-03 16:08:01 EDT
Mass change of component from Transifex to Website, since all our websites are handled by Transifex now.

Note You need to log in before you can comment on or make changes to this bug.