This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 462413 - Software Updater - TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment
Software Updater - TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:Unboun...
Status: CLOSED DUPLICATE of bug 428323
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.1.z
i386 Linux
medium Severity urgent
: rc
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 20:50 EDT by sriram_chitrapu
Modified: 2008-09-18 11:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 11:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump on the RHEL v5 server. (1.88 KB, application/octet-stream)
2008-09-15 20:50 EDT, sriram_chitrapu
no flags Details

  None (edit)
Description sriram_chitrapu 2008-09-15 20:50:45 EDT
Created attachment 316797 [details]
crash dump on the RHEL v5 server.

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sriram_chitrapu 2008-09-15 20:56:29 EDT
Description of problem:
The "Software Updater" application is throwing the exception (see attachment for details) when launched.  

Version-Release number of selected component (if applicable):


How reproducible:
Either try: a) Applications->System Tools->Software Updater or b) yum check-update or yum update from the command line.

Steps to Reproduce:
1. Listed under "How Reproducible" section.

Actual results:


Expected results:
The "Software Updater" should contact the RHN server successfully and show the list of available updates for the RHEL system.


Additional info:
The activation and registration were successful.
Comment 2 Günther Sommer 2008-09-18 11:20:24 EDT
having the same, here the crash information

Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 561, in applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 273, in downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in getPackage
    cache=cache
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-client-5/getPackage/hal-0.5.8.1-35.el5.i386.rpm
start: None
url: None
text: (6/314): hal-0.5.8.1-35.el5.i386.rpm
self: rhel-x86_64-client-5
cache: True
reget: simple
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-client-5
relative: getPackage/hal-0.5.8.1-35.el5.i386.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', '7wzt1n10Is9LxWSJ8ifNkw=='), ('X-RHN-Auth-Server-Time', '1221749947.64'), ('X-RHN-Server-Id', 1013761084))
checkfunc: (<bound method PackageUpdater.verifyPkg of <__main__.PackageUpdater object at 0x174f9690>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0x1b7d0b48>, 1), {})
copy_local: 0
end: None
local: //var/cache/yum/rhel-x86_64-client-5/packages/hal-0.5.8.1-35.el5.i386.rpm
Comment 3 James Antill 2008-09-18 11:27:03 EDT
 This is already fixed in yum-rhn-plugin, not sure which version though.
Comment 4 John Matthews 2008-09-18 11:44:47 EDT
If I remember correctly, the fix for this went out in RHEL 5.2.

Typically this error message is hiding a network or configuration error.

*** This bug has been marked as a duplicate of bug 428323 ***

Note You need to log in before you can comment on or make changes to this bug.