This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 462444 - RFE: update perl(Test::Simple)
RFE: update perl(Test::Simple)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 462587 462590
  Show dependency treegraph
 
Reported: 2008-09-16 07:48 EDT by Ralf Corsepius
Modified: 2008-10-22 21:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 03:16:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-09-16 07:48:12 EDT
Description of problem:

Fedora's perl ships an old version of the Test::Simple perl.
The current upstream version of Test::Simple is 0.80.

Additional info:
Test::Builder (part of Test::Simple) >= 0.77 is a requirement of rt-3.8.x's testsuite.
Comment 1 Paul Howarth 2008-09-16 11:24:22 EDT
Hmm, I wonder if this is going to break Test::Output as per Bug #434865 ?
Comment 2 Marcela Mašláňová 2008-09-17 03:16:45 EDT
Hmm, I try to install Test::Output from CPAN and tests had passed.
Comment 3 Paul Howarth 2008-09-17 06:03:36 EDT
It builds OK in koji too:
http://koji.fedoraproject.org/koji/getfile?taskID=829893&name=build.log

Which leads to two questions:

1. Why does it fail to build on F-8 now, when the cause of the failure seems to be the update of Test::Simple there (Bug #434865)?

http://koji.fedoraproject.org/koji/getfile?taskID=829945&name=build.log

2. Why is the perl-Test-Simple package in Rawhide versioned 0.72-43.fc10 when in fact the module is 0.80? (Same question for F-8 too I suppose, with different numbers)
Comment 4 Ralf Corsepius 2008-09-17 07:16:40 EDT
(In reply to comment #3)

> 2. Why is the perl-Test-Simple package in Rawhide versioned 0.72-43.fc10 when
> in fact the module is 0.80?

Apparent bug in perl.spec - perl-Test-Simple's Version: needs to be bumped.
Comment 5 Paul Howarth 2008-09-17 07:35:42 EDT
(In reply to comment #4)
> (In reply to comment #3)
> 
> > 2. Why is the perl-Test-Simple package in Rawhide versioned 0.72-43.fc10 when
> > in fact the module is 0.80?
> 
> Apparent bug in perl.spec - perl-Test-Simple's Version: needs to be bumped.

It's not the only example either - the changelog suggests that Test::Harness is at version 3.12 but the package claims to 2.64.

I think the specs for all active releases need reviewing to fix these inconsistencies; F-8 and Rawhide certainly have issues so I wouldn't be surprised if F-9 did too.
Comment 6 Ralf Corsepius 2008-09-17 07:42:41 EDT
(In reply to comment #5)
> It's not the only example either.
Urgh, do you have a patch at hand? Otherwise I'll walk through the rawhide spec and fix these (I do have write permissions).
Comment 7 Marcela Mašláňová 2008-09-17 07:48:27 EDT
I fixed it in rawhide. It was only Test::Simple and Test::Harness. The updates are done by me usually. So I fix it in all branches after myself. I'm sorry :(
Comment 8 Ralf Corsepius 2008-09-17 07:55:16 EDT
While investigating the issues above, I just noticed this
(Likely I should file another BZ)

# rpm -q --provides -p perl-Archive-Extract-0.24-43.fc10.x86_64.rpm 
perl(Archive::Extract) = 0.24
perl(Archive::Tar) = 1.38
perl(Archive::Tar::Constant) = 0.02
perl(Archive::Tar::File) = 0.02
perl-Archive-Extract = 1:0.24-44.fc10
perl-Archive-Extract(x86-64) = 1:0.24-44.fc10

# rpm -q --provides -p perl-Archive-Tar-1.37-43.fc10.x86_64.rpm 
perl(Archive::Tar) = 1.38
perl(Archive::Tar::Constant) = 0.02
perl(Archive::Tar::File) = 0.02
perl-Archive-Tar = 0:1.37-44.fc10
perl-Archive-Tar(x86-64) = 0:1.37-44.fc10


I am inclined to think this broken twice:

a) perl(Archive::Tar) = 1.38 vs. perl-Archive-Tar-1.37
Is this correct?

b) Both
perl-Archive-Extract-0.24-44.fc10.x86_64.rpm
and
perl-Archive-Tar-1.37-44.fc10.x86_64.rpm
Provide: perl(Archive::Tar*)

This can't be right - Likely a bug in rpm's requ/prov scripts.
Comment 9 Marcela Mašláňová 2008-09-17 10:56:59 EDT
a) perl(Archive::Tar) = 1.38 package cpan version was 1.37_01. Now it's possible to solve it with update to 1.38.

b) There was typo in %files section and Tar.pm was packaged in both.

Everything will be fixed in perl-5.10.0-44.fc10.
Comment 10 Paul Howarth 2008-10-22 21:22:49 EDT
(In reply to comment #3)
> It builds OK in koji too:
> http://koji.fedoraproject.org/koji/getfile?taskID=829893&name=build.log
> 
> Which leads to two questions:
> 
> 1. Why does it fail to build on F-8 now, when the cause of the failure seems to
> be the update of Test::Simple there (Bug #434865)?
> 
> http://koji.fedoraproject.org/koji/getfile?taskID=829945&name=build.log

This problem (which also now affects F-9) can be fixed by updating Test::Tester to 0.107.

Test::Output 0.11 was released recently, and Steve will probably hit this problem if/when he comes to build it on F-8 and F-9.

Note You need to log in before you can comment on or make changes to this bug.