Bug 462448 - Plasma workspace crashes on login
Plasma workspace crashes on login
Status: CLOSED DUPLICATE of bug 461848
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 08:45 EDT by David Tonhofer
Modified: 2008-09-16 11:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 11:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crashhandler dumps, three text files (30.00 KB, application/octet-stream)
2008-09-16 08:45 EDT, David Tonhofer
no flags Details
Stacktrace with newly created ~/.kde and old plasma-appletsrc (6.36 KB, text/plain)
2008-09-16 09:38 EDT, David Tonhofer
no flags Details
Plasma-appletsrc making plasma crash (1.57 KB, text/plain)
2008-09-16 09:39 EDT, David Tonhofer
no flags Details

  None (edit)
Description David Tonhofer 2008-09-16 08:45:34 EDT
Created attachment 316843 [details]
Crashhandler dumps, three text files

Description of problem:
-----------------------
I log in through kdm, but do not get a desktop. Instead the KDE crash handler shows that the plasma workspace has crashes. Only Dolphin, still pointing to a now removed USB memory stick is started.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
kdebase-workspace-4.1.0-8.fc9.x86_64

How reproducible:
-----------------
This occurred from a given boot on, but then always. Only fixed by:

Workaround
----------
renaming ~/.kde to ~/KDE.kde
  
(Maybe additionally removing an icon from the desktop and closing dolphin which was started at login)

Additional info:
----------------
3 krash handler dumps attached, all from 3 different login attempts. diff shows only minor differences.
Comment 1 David Tonhofer 2008-09-16 09:30:02 EDT
It looks like an existing ~/.kde/share/config/plasma-appletsrc caused havoc. It may have been left from a time from before an upgrade of the kdebase packages. 

I tested this by removing ~/.kde (causing it to be re-created at login), then copying said file from the old, saved ~/.kde over to the new ~/.kde. 

Will attach the file in question and the stacktrace after one last test.
Comment 2 David Tonhofer 2008-09-16 09:38:11 EDT
Created attachment 316850 [details]
Stacktrace with newly created ~/.kde and old plasma-appletsrc
Comment 3 David Tonhofer 2008-09-16 09:39:06 EDT
Created attachment 316851 [details]
Plasma-appletsrc making plasma crash
Comment 4 Kevin Kofler 2008-09-16 11:29:42 EDT

*** This bug has been marked as a duplicate of bug 461848 ***

Note You need to log in before you can comment on or make changes to this bug.