This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 462515 - pulseaudio fails to start on XO
pulseaudio fails to start on XO
Status: CLOSED DUPLICATE of bug 462407
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-09-16 16:13 EDT by Jack Spaar
Modified: 2008-09-23 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 20:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error output from failed pulseaudio start (1.22 KB, application/octet-stream)
2008-09-16 16:13 EDT, Jack Spaar
no flags Details
pulseaudio -v output for successful launch after creating ~/.pulseaudio (6.62 KB, text/plain)
2008-09-16 16:15 EDT, Jack Spaar
no flags Details

  None (edit)
Description Jack Spaar 2008-09-16 16:13:49 EDT
Created attachment 316896 [details]
Error output from failed pulseaudio start

Description of problem:
After logging in to gnome session on XO using Fedora livecd built for XO, pulseaudio fails to start.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. Boot XO with fedora livecd build for XO per http://katzj.livejournal.com/438184.html
2. Log in to gnome session.
3.
  
Actual results:
Pulseaudio hasn't started cleanly.  There are several processes hanging around:
2297 ?        S      0:00 /usr/bin/pulseaudio --start --log-target=syslog
2319 ?        S      0:00 /bin/sh /usr/bin/start-pulseaudio-x11
2322 ?        S      0:00 /usr/bin/pulseaudio --start
2363 ?        S      0:00 /usr/bin/pulseaudio --start --log-target=syslog
2387 ?        S      0:00 /usr/bin/pulseaudio --start --log-target=syslog

$ pkill pulseaudio
$ pulseaudio -v >pa.out 2>&1
exits abnormally, log pa.out attached.


Expected results:


Additional info:
The fedora home directory contains no .pulseaudio subdir.
$ pkill pulseaudio
$ mkdir ~/pulseaudio
$ pulseaudio -v > pa.out 2>&1
$ aplay /usr/share/sounds/startup3.wav
Produces pa.out2, attached.
The aplay does complete, but no sound is heard.
Comment 1 Jack Spaar 2008-09-16 16:15:25 EDT
Created attachment 316898 [details]
pulseaudio -v output for successful launch after creating ~/.pulseaudio

Successful launch, but still no sound.
Comment 2 Jack Spaar 2008-09-16 16:16:43 EDT
Intended to block FedoraOnXO Tracker https://bugzilla.redhat.com/show_bug.cgi?id=461806
Comment 3 Lennart Poettering 2008-09-23 18:17:49 EDT
The issue with missing ~/.pulseaudio is a duplicate of #462407 which is already fixed.

The other issue seems to be an ALSA issue. We try to open the audio device in many different ways but all fail. front:0 doesn't work, surround51:0, ..., not even hw:0 works. 

Please check whether "aplay -D hw:0 -f cd < /dev/urandom" works. If this doesn't work, than then this is clearly some driver issue, and should be reassigned to alsa/kernel.

Also, alsa is sometimes lying about the error codes (i.e. claiming Invalid Argument here). Try to figure out with strace what is  going on.
Comment 4 Lennart Poettering 2008-09-23 19:54:39 EDT
Oh, it's ~/.pulse btw, not ~/.pulseaudio.
Comment 5 Jack Spaar 2008-09-23 20:37:00 EDT
Thx, marking as dupe for the missing ~/.pulse fixed in rawhide.

The no sound issue is surely kernel and not PA (dmesg extract below).  It'll make sense to re-test and file separately when Jeremy gets a more XO-friendly kernel on the livecd image, probably soon: 
<https://www.redhat.com/archives/fedora-olpc-list/2008-September/msg00091.html>


[    0.000000] Linux version 2.6.26-20080828.fc9.katzj (katzj@erebor.bos.redhat.com) (gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) ) #1 PREEMPT Thu Aug 28 11:14:44 EDT 2008
...
[    2.105784] Advanced Linux Sound Architecture Driver Version 1.0.1
6.
[    2.106212] PCI: Setting latency timer of device 0000:00:0f.3 to 6
4
[    2.109966] Failure reading codec reg 0x7e,Last value=0x7e805368
[    2.110527] Failure reading codec reg 0x7e,Last value=0x7e805368
[    2.121531] ALSA device list:
[    2.121549]   #0: CS5535 Audio cs5535audio at 0x1480, irq 5

*** This bug has been marked as a duplicate of bug 462407 ***

Note You need to log in before you can comment on or make changes to this bug.