Bug 462561 - cman package missing dependencies
cman package missing dependencies
Status: CLOSED DUPLICATE of bug 248714
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 00:12 EDT by Jeremy
Modified: 2009-04-16 18:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 15:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2008-09-17 00:12:25 EDT
Description of problem:
The /sbin/fence_ilo script requires the perl(Net::SSL) or perl(Net::SSLeay) to function correctly.  The cman package should have a requirement for these perl modules.

Version-Release number of selected component (if applicable):


How reproducible:
cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.2 (Tikanga)
rpm -q cman
cman-2.0.84-2.el5


Steps to Reproduce:
1. Install cman
2. Configure cluster to use ilo fencing
3. Attempt to Fence the node
  
Actual results:
fenced[11766]: agent "fence_ilo" reports: Net::SSL.pm o
r Net::SSLeay::Handle.pm not found. Please install the perl-Crypt-SSLeay package
 from RHN (http://rhn.redhat.com) or Net::SSLeay from CPAN (http://www.cpan.org)

Expected results:
All fencing perl dependencies to be processed at the time of a yum install cman

Additional info:
Note: the error message at least points the user in the right direction, but the dependency can be met by either the perl-Net-SSLeay or perl-Crypt-SSLeay package.
Comment 1 Chris Feist 2008-09-23 15:42:05 EDT

*** This bug has been marked as a duplicate of bug 248714 ***

Note You need to log in before you can comment on or make changes to this bug.