Bug 462592 - Anaconda crashes on text installation
Anaconda crashes on text installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
: 462786 (view as bug list)
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-09-17 08:27 EDT by A.J. Werkman
Modified: 2013-01-09 23:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 15:16:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
End screen after anaconda stops (456.78 KB, image/jpeg)
2008-09-17 08:27 EDT, A.J. Werkman
no flags Details
Screenshot after graphic install crash (518.06 KB, image/jpeg)
2008-09-17 11:42 EDT, A.J. Werkman
no flags Details
Screenshot 3 after crash (474.08 KB, image/jpeg)
2008-09-17 11:45 EDT, A.J. Werkman
no flags Details
Screenshot 4 after the crash (529.97 KB, image/jpeg)
2008-09-17 11:50 EDT, A.J. Werkman
no flags Details
Screenshot after the crash (1) (140.95 KB, image/jpeg)
2008-10-06 14:31 EDT, A.J. Werkman
no flags Details
Screenshot two after anaconda crash (150.60 KB, image/jpeg)
2008-10-06 14:35 EDT, A.J. Werkman
no flags Details
Anaconda bug after IPv4 static adress configuration in anaconda (60.81 KB, image/jpeg)
2008-10-06 14:39 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2008-09-17 08:27:00 EDT
Created attachment 316951 [details]
End screen after anaconda stops

Description of problem:
When I install Rawhide with anaconda 11.4.1.36 on a system, after retrieval of the installation image, anaconda closses down with "You may safely reboot your system".

Version-Release number of selected component (if applicable):
Anaconda 11.4.1.36 in rawhide

How reproducible:
Every time

Steps to Reproduce:
1. I grub boot the installation kernel from a second harddisk in the system
2. The kernel options ar "ro text"
3. I choos e language "English"
4. I choose keyboard "us"
5. I choose installation method "URL".
6. I select "eth0" as interface
7. I accept the default settings in the TCP/IP screen, being DHCP and automatic neighbour discovery for Ipv6.
8. Anaconda downloads the installation image and next shuts the system down. I enclose a screen picture.
  
Actual results:
Rawhide is not installed

Expected results:
Rawhide should be installed

Additional info:
Comment 1 Chris Lumens 2008-09-17 09:42:19 EDT
Unfortunately what you've taken a picture of doesn't really tell me anything.  Can you hit page up a couple times and see if there's something more interesting above, like perhaps the traceback that's causing this problem?
Comment 2 A.J. Werkman 2008-09-17 10:03:04 EDT
I will try tonight. I am however afraid that this will not work.

As you see on the screenshot, the last line says "hit any key to reboot". So I think any keyboard interaction will only start the actual reboot.

I have seen, that there is info scrolling over the screen, but this is gone in a split second. So I can't reproduce.

I have another boot strategy, where the system SIGFAULTs. I can try to reproduce that one and send you the SIGFAULT screenshot.

I'l come back to you.
Comment 3 A.J. Werkman 2008-09-17 11:42:19 EDT
Created attachment 316981 [details]
Screenshot after graphic install crash

Here I have a screenshot after a graphic install crash.

As I already expected, I can not scroll up using the page up key.
Comment 4 A.J. Werkman 2008-09-17 11:45:58 EDT
Created attachment 316983 [details]
Screenshot 3 after crash

This screenshot I took on the fly, while the error occured. Don't think it gives extra info. In fact This is all the info that is to be seen. I took this shot immediatly after the blue installation screen ran of the video screen.
Comment 5 A.J. Werkman 2008-09-17 11:50:04 EDT
Created attachment 316985 [details]
Screenshot 4 after the crash

I took this screenshot from the result, when I tried to install fedora with fixed IP addresses (both Ipv4 and Ipv6). It then immediatly crashes without giving the opportunity to give any IP information and without getting the installatyion image of course.

Unfortunatly this is the only info the system gives to me. At the moment I don't see any possibility to get more info out of the system.
Comment 6 Johan Eenfeldt 2008-09-18 07:02:24 EDT
Note: Fedora Test-10 Alpha works (anaconda version 11.4.1.24 ?)

I have the exact same problem as in attachment "Screenshot after graphic install crash" above. I can scroll up, but there is not much more interesting information:

Running anaconda 11.4.1.36, the Fedora system installer - please wait...
12:42:20 Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 857, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 321, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 65, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 207, in __init__
    if isys.isDeviceDHCP(dev):
  File "/usr/lib/anaconda/isys.py", line 930, in isDeviceDHCP
    ip4_setting = setting['ipv4']
KeyError: 'ipv4'
install exited abnormally [1/1]
...

After downloading install.img file the screen goes black for a second or so, then switches back to text with this error.

With a few tries it seems to be reproducible 80% or so of the times, sometimes I instead get:

Running anaconda 11.4.1.36, the Fedora system installer - please wait...
11:47:44 Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 857, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 321, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 65, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 211, in __init__
    config_path = props.Get(isys.NM_MANAGER_IFACE, 'Ip4Config')
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File: "/usr/lib/python2.5/site-packages/dbus/connection.py", line 622, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
install exited abnormally [1/1]
...
Comment 7 David Cantrell 2008-09-19 01:06:07 EDT
This should be fixed in the next build of anaconda.  I've made sure the text mode interface is working with the new NetworkManager backend for network management.

In anaconda now, you will only be prompted for a hostname.  The per-interface configuration is only in the loader portion of anaconda now.
Comment 8 A.J. Werkman 2008-09-20 10:15:14 EDT
Tried anaconda 11.4.1.37 just know. Unfortunatly the bug is unaltered still there.

Crash ends with "you may safely reboot your system". Cntrl-alt-delete is the only option. The screen resembles the first screenshot I attached to this bug.
Comment 9 Johan Eenfeldt 2008-09-20 11:02:01 EDT
Almost identical crash.

Running anaconda 11.4.1.37, the Fedora system installer - please wait...
16:57:12 Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 857, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules,
opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 335, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 66, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 252, in __init__
    if isys.isDeviceDHCP(dev):
  File "/usr/lib/anaconda/isys.py", line 930, in isDeviceDHCP
    ip4_setting = setting['ipv4']
KeyError: 'ipv4'
install exited abnormally [1/1]
...
Comment 10 Jens Petersen 2008-09-22 01:14:32 EDT
(In reply to comment #9)

I am seeing this backtrace too.
Comment 11 Andy Lindeberg 2008-09-22 10:35:08 EDT
*** Bug 462786 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2008-09-22 14:07:30 EDT
David, This patch fixes the issue, but I don't know if assuming DHCP when there's no ipv4 setting is the correct thing to do.  It looks like it, based on your existing "if not ipv4_setting" in the code already.  Thoughts?

diff --git a/isys/isys.py b/isys/isys.py
index 904488d..8a1bea6 100755
--- a/isys/isys.py
+++ b/isys/isys.py
@@ -927,7 +927,7 @@ def isDeviceDHCP(dev=None):
         connection_iface = dbus.Interface(connection, NM_CONNECTION_IFACE)
         settings = connection_iface.GetSettings()
 
-        ip4_setting = settings['ipv4']
+        ip4_setting = settings.get('ipv4')
         if not ip4_setting or not ip4_setting['method'] or ip4_setting['method'] == 'auto':
             return True
Comment 13 Jesse Keating 2008-09-23 18:34:12 EDT
This was committed and built into rawhide/beta.  Closing for now.
Comment 14 Johan Eenfeldt 2008-09-23 19:40:16 EDT
The current anaconda version (11.4.1.39) works for me.
Comment 15 A.J. Werkman 2008-09-24 14:42:13 EDT
This works with anaconda 11.4.1.39 for me too if I choose DHCP as way of selecting network parameters. If I choose static IPv4 and static IPv6 11.4.1.39 crashes again.
As I read from another bug, Network manager manages network configuration in anaconda. But network manager does not support IPv6 in F10. Wouldn't it be sensible then to block IPv6 at all in the TCP/IP selection screen during the first network configuration fase?
Comment 16 David Cantrell 2008-09-25 01:05:35 EDT
This should be working as of anaconda-11.4.1.40-1.
Comment 17 A.J. Werkman 2008-09-27 05:00:30 EDT
Anaconda-11.4.1.40-1 still crashes when selecting static IPv4 and IPv6 addressing scheme.
Comment 18 A.J. Werkman 2008-09-27 07:48:54 EDT
I did some more testing.

Clear is, that as soon as I request a static IPv6 address, anaconda crashes. As I saw a report that NetworkManager is not supporting IPv6 this is obvious if configuration is under the command of NetworkManager. So if network configuration in anaconda is completely done through NetworkManager, why don't you comment out the possibility of selecting IPv6 installation. Mutatis mutandis if IPv6 static addressing is used don't use NetworkManager for configuring the interfaces.

Furthermore I noticed, that although I request a static IPv4 address, anaconda still configures the interface through DHCP. This is in the installation process, but also in the eventually installed system environment.

Also after requesting a static IPv4 address, the installed system starts up NetworkManager. I would expect that anaconda would configure the system to not start NetworkManager, but the classic network startup script, because with a static interface configuration there is not much to do for Networkmanager.
Comment 19 A.J. Werkman 2008-10-06 14:31:38 EDT
Created attachment 319585 [details]
Screenshot after the crash (1)

Screenshot after anaconda-11.4.1.43 crashes(1) with network configuration = DHCP.
Comment 20 A.J. Werkman 2008-10-06 14:35:12 EDT
Created attachment 319587 [details]
Screenshot two after anaconda crash

Screenshot after anaconda-11.4.1.43 crashes(1) with network configuration = DHCP.
Comment 21 A.J. Werkman 2008-10-06 14:39:23 EDT
Created attachment 319590 [details]
Anaconda bug after IPv4 static adress configuration in anaconda

Screenshot after anaconda static IPv4 text installation. The screen refers to IPv6 parameters. This is not relevant. After retry we have a crash.
Comment 22 A.J. Werkman 2008-10-06 14:50:16 EDT
Today I tried to install rawhide again. I am not able to do a complete installation due to anaconda crashing on network manager issues.

Anaconda 11.4.1.43 crashes while doing a text install. I select DHCP to determine the network addressing scheme. After the selection screen "Use text mode" / "VNC" anaconda crashes. In comment #19 and #20 I uploaded screenshots that give the information that scrolls over the screen just before "You may safely reboot" message.

As David Cantrell mentioned in bug #453265 IPv6 is not supported in anaconda NetworkManager at the moment. So IPv6 selections are deleted from the configuration screens. But if I do a text installation with a static IPv4 addressing scheme I get the screen as uploaded in comment #21. There is a reference to a IPv6 address that is not supplied. This is obvious since you can not enter IPv6 addresses anymore. After this anaconda crashes.

Sorry gays, NetworkManager seems to be very rebelious in this matter.
Comment 23 Chris Lumens 2008-10-27 13:27:24 EDT
The two screenshots you attached are a known bug in NM.  It just segfaults sometimes when the dbus daemon is killed before NM on shutdown.  It sure doesn't look pretty, but it's got nothing to do with the problem this bug is about.
Comment 24 Jesse Keating 2008-10-27 15:16:21 EDT
Using a static ipv4 address during text install is fine now (module a little bug introduced yesterday with .write()).  I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.