Bug 462786 - Anaconda fails during Installation via URL
Anaconda fails during Installation via URL
Status: CLOSED DUPLICATE of bug 462592
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: 463103 (view as bug list)
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
Reported: 2008-09-18 17:21 EDT by David Jones
Modified: 2008-09-22 10:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-22 10:35:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Jones 2008-09-18 17:21:17 EDT
Description of problem:
2 problems while performing installation via URL

1 After changing to Fixed IPV4 address and entering IP details. Warning rec'd must enter correct IPV6 and CIDR details.

2 Downloads image from URL then Anaconda fails with:-
Error in Anaconda line 857
Error in instdata.py line 321
Error in instdata.py line 65
Error in network.py line 207
Error in isys.py line 930 in isDeviceDHCP
keyerror "IPV4"

Version-Release number of selected component (if applicable):

How reproducible:
2 occasions

Steps to Reproduce:
1. Install via URL
2. Static IPV4 leave IPV6 to automatic
3. Enter URL e.g
Actual results:
Error in Anaconda - safe to reboot your system

Expected results:
To continue Fedora 10 installation

Additional info:
Comment 1 David Jones 2008-09-18 17:53:57 EDT
Update to above more detail included

I missed a number of lines prior to these, 1st line did show Anaconda version.

File in /usr/lib/Anaconda line 857 in <module> anaconda.id=instClass.installDataClass(anaconda, extramodules, opts.display_mode, anaconda.backend
File /usr/lib/anaconda/instdata.py line 321, in_init_self.reset
File /usr/lib/anaconda/instdata.py line 65 in reset 
    self.network = network.Network()
File /usr/lib/anaconda/network.py line 207 in_init_
    if isys.isDeviceDHCP(dev)
File /usr/lib/anaconda/isys.py line 930 in isDeviceDHCP
    ip4_setting = settings['ipv4']
KeyError "IPV4"

Install exited abnormally [1/1]
Comment 2 Jens Petersen 2008-09-22 01:20:51 EDT
*** Bug 463103 has been marked as a duplicate of this bug. ***
Comment 3 Andy Lindeberg 2008-09-22 10:35:08 EDT

*** This bug has been marked as a duplicate of bug 462592 ***

Note You need to log in before you can comment on or make changes to this bug.