Bug 462631 - Missing error in "rpm -e foo.i386" when only foo.x86_64 is installed
Missing error in "rpm -e foo.i386" when only foo.x86_64 is installed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 13:18 EDT by Ville Skyttä
Modified: 2009-04-07 01:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 01:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2008-09-17 13:18:14 EDT
rpm-4.4.2.3-2.fc9.x86_64:

    # rpm -q foo
    package foo is not installed
    # rpm -e foo.i386
    error: package foo.i386 is not installed
    # echo $?
    1

The above is fine, but:

    # rpm -q firefox
    firefox-3.0.1-1.fc9.x86_64
    # rpm -e firefox.i386
    # echo $?
    0

I would have expected a "error: package firefox.i386 is not installed" error message and exit status 1.  rpm -q works as expected though:

    # rpm -q firefox.i386
    package firefox.i386 is not installed
Comment 1 Panu Matilainen 2008-09-18 03:31:37 EDT
This is essentially the same issue as bug 124016 but different place, fixed upstream now.
Comment 2 Ville Skyttä 2009-04-06 15:50:14 EDT
Works for me in F-10's rpm-4.6.0-1.fc10.x86_64, can be closed as far as I'm concerned.

Note You need to log in before you can comment on or make changes to this bug.