Bug 462677 - save mixer settings using alsactl utility
save mixer settings using alsactl utility
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Reopened
: 463718 463738 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker 462337
  Show dependency treegraph
 
Reported: 2008-09-18 04:43 EDT by Jaroslav Kysela
Modified: 2014-03-16 23:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: 8.83-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 02:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsactl patch for /etc/rc.d/init.d/halt (722 bytes, patch)
2008-09-18 04:43 EDT, Jaroslav Kysela
no flags Details | Diff

  None (edit)
Description Jaroslav Kysela 2008-09-18 04:43:39 EDT
Created attachment 317048 [details]
alsactl patch for /etc/rc.d/init.d/halt

Recent alsa-utils package removed /sbin/salsa helper. The alsactl utility has integrated all salsa functionality now.

Please, consider to apply this patch:

--- initscripts-8.82/rc.d/init.d/halt.orig      2008-09-18 09:42:06.000000000 +0200
+++ initscripts-8.82/rc.d/init.d/halt   2008-09-18 09:56:07.000000000 +0200
@@ -73,9 +73,10 @@ action $"Sending all processes the KILL 
 /sbin/halt -w
 
 # Save mixer settings, here for lack of a better place.
-grep -q "\(alsa\)" /proc/devices
-if [ $? = 0 -a -x /sbin/salsa ]; then
-   action $"Saving mixer settings" /sbin/salsa -s
+if [ -s /etc/alsa/alsactl.conf -a -x /sbin/alsactl ]; then
+  action $"Saving mixer settings" /sbin/alsactl -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf --ignore store
+elif [ -r /proc/asound/card[0123456789] -a  -x /sbin/salsa ]; then
+  action $"Saving mixer settings" /sbin/salsa -s
 fi
 
 # Save random seed
Comment 2 Jaroslav Kysela 2008-09-29 02:42:11 EDT
Unfortunately, we do not have an updated rawhide package available and bug reports are comming...
Comment 3 Jaroslav Kysela 2008-09-29 02:42:47 EDT
*** Bug 463718 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Kysela 2008-09-29 02:43:06 EDT
*** Bug 463738 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Kofler 2008-10-02 02:33:41 EDT
Fixed in 8.83-1 as per yesterday's rawhide report.

Note You need to log in before you can comment on or make changes to this bug.