Bug 462771 - Changes in synaptics.fdi don't have any effect
Changes in synaptics.fdi don't have any effect
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-18 15:31 EDT by Rohan Dhruva
Modified: 2008-10-20 01:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.15.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 20:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.log. (19.57 KB, text/plain)
2008-09-18 15:33 EDT, Rohan Dhruva
no flags Details
Xorg.log after comment #2 (20.20 KB, text/plain)
2008-09-19 10:19 EDT, Rohan Dhruva
no flags Details

  None (edit)
Description Rohan Dhruva 2008-09-18 15:31:01 EDT
Description of problem:
I am using a fully updated Fedora 9 system. I removed the synaptics package using rpm -e --nodeps. I then installed x11-drv-synaptics package 0.15.1 from here --
http://koji.fedoraproject.org/koji/buildinfo?buildID=62375

I have made many changes to my /etc/hal/fdi/policy/10-synaptics.fdi file to make the touchpad more "natural". However, the changes do not have any effect.

I am trying to solve the following 4 issues with the touchpad:
1) My 4-way scroller button (below the touchpad in between the two click
buttons) no longer works - clicking "down" now works as right click
2) The tapping is VERY sensitive
3) I can't scroll by gliding in the right of the touchpad
4) Clicking with two fingers should be equal to middle click, but that doesn't
work. Similarly, clicking with three fingers should be equal to right click


Version-Release number of selected component (if applicable):
0.15.1-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Make changes to the synaptics.fdi file
2. Restart HAL/Xorg, or restart the computer
  
Actual results:
None of the parameters in the synaptics.fdi file have any effect.

Expected results:
The above 4 problems should be solved.

Additional info:
I am attaching my Xorg.log as requested here - https://bugzilla.redhat.com/show_bug.cgi?id=439386#c117
My synaptics.fdi is - https://bugzilla.redhat.com/attachment.cgi?id=316847
Output of hal-device - https://bugzilla.redhat.com/attachment.cgi?id=316848
Comment 1 Rohan Dhruva 2008-09-18 15:33:35 EDT
Created attachment 317111 [details]
My xorg.log.
Comment 2 Peter Hutterer 2008-09-18 21:04:29 EDT
Interesting. The log shows that the synaptics driver isn't even loading, none of the hotplugged devices are.

(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(EE) config/hal: NewInputDeviceRequest failed

I'm a bit baffled though, since I can't see anything wrong in the hal output.

Please add the following section to your xorg.conf

Section "InputDevice"
  Identifier "Touchpad"
  Driver "synaptics"
EndSection

and in your ServerLayout, add InputDevice "Touchpad". This should give us a clue why the driver isn't loading.
Comment 3 Rohan Dhruva 2008-09-19 10:18:18 EDT
I made the required changes. It seems that synaptics "can't open the device." I am attaching my xorg.log after the change was made.
Comment 4 Rohan Dhruva 2008-09-19 10:19:23 EDT
Created attachment 317200 [details]
Xorg.log after comment #2
Comment 5 Peter Hutterer 2008-09-22 02:49:39 EDT
I think you might be hitting the stale option list pointer bug.

http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/commit/?id=566b4dcc0b0f45ad83012314b67836ba2018cf9e

This would explain why it can't find the device even after auto-dev has the device set. Can you please try the updated packages below and let me know if they fix the issue? Thanks.

http://koji.fedoraproject.org/scratch/whot/task_835604/
Comment 6 Rohan Dhruva 2008-09-22 10:15:05 EDT
Thank you very much - that solves all the problems for me. The touchpad is now working as expected.
Comment 7 Rohan Dhruva 2008-09-22 10:36:18 EDT
I noticed one more "issue" - I removed the "Touchpad" lines which you told me to add in comment #2 and then the problem again appears. After I removed those lines, Xorg.log showed no indication of even trying to add the synaptics driver. Is that expected behaviour?
Comment 8 Fedora Update System 2008-09-22 20:25:44 EDT
xorg-x11-drv-synaptics-0.15.1-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-0.15.1-2.fc9
Comment 9 Peter Hutterer 2008-09-22 20:49:48 EDT
From your log: (**) Option "AutoAddDevices" "off"

The addition of HAL devices is disabled. Please remove the respective option from your xorg.conf and it should work fine then.

Marking this bug as fixed with xorg-x11-drv-synaptics-0.15.1-2. Thanks for your help.
Comment 10 Rohan Dhruva 2008-09-24 22:01:53 EDT
I had added that line after reading http://who-t.blogspot.com/2008/07/input-configuration-in-nutshell.html section "What to do with the xorg.conf". I added "AutoAddDevices" "off" to prevent conflicts between HAL and X.org both grabbing the device.

I confess I did not fully understand that section - can you please tell me what changes do I make to xorg.conf and other files, in order to avoid conflicts?

Also, one more thing - the clicking in Fedora is not as "easy" as windows or other distros i.e. I need to press my finger down too hard. Can you please tell me which option in synaptics.fdi controls this behaviour?
Comment 11 Peter Hutterer 2008-09-24 22:42:40 EDT
(In reply to comment #10)
> I confess I did not fully understand that section - can you please tell me what
> changes do I make to xorg.conf and other files, in order to avoid conflicts?

AutoAddDevices disables HAL, so it ignores anything in the fdi files. AAD must be "on" (or just not specified) for HAL to work.
If you have synaptics in the xorg.conf, then the AAD doesn't matter.

Either configuration works, as synaptics prevents the same device from getting loaded through xorg.conf and HAL. However, in some cases a synaptics device in xorg.conf may not always come back after a resume. This seems to be a kernel issue that affected some stages of rawhide and maybe F9 (not sure), but is fixed now.

> Also, one more thing - the clicking in Fedora is not as "easy" as windows or
> other distros i.e. I need to press my finger down too hard. Can you please tell
> me which option in synaptics.fdi controls this behaviour?

Try MaxTapMove = 220, or adjusting FingerLow and FingerHigh.
Comment 12 Fedora Update System 2008-10-15 22:12:53 EDT
xorg-x11-drv-synaptics-0.15.1-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Bruce Bigby 2008-10-18 21:51:28 EDT
I recently updated my Fedora 9 laptop, and apparently, the updater pulled in version 0.15.1-2 of the xorg-x11-drv-synaptics package. My touchpad appeared to work fine prior to the update, except that I haven't discovered how to do a middle mouse click.  Well, now, after the update, my touch pad is working very unreliably.  Sometimes a single click won't register unless I rapidly tap the touch pad up to 4 or 5 times.  I downgraded to 0.15.0-3, and now things are working reliably again. Note: My xorg file doesn't have any special option in it.  In fact, there is no Synaptics section at all.  Has anyone else had this problem with the new update?
Comment 14 Jason Turning 2008-10-19 16:12:33 EDT
The upgrade to xorg-x11-drv-synaptics.0.15.2-1 totally damaged up my tap functionality as well. I struggled with trying to configure the tap for quite a while, even to the point where I booted into Vista to make sure it wasn't a hardware problem. The touchpad worked perfectly in Vista so I searched and found this bug report. Per the note above I found the 0.15.0-3 package and reverted. The tap functionality is now working correctly after changing back to my original settings in gsynaptics.
Comment 15 Peter Hutterer 2008-10-20 01:17:28 EDT
Bruce, Jason: your comments are addressed in Bug 467278.

Note You need to log in before you can comment on or make changes to this bug.