Bug 462849 - Mouse stop working after update to 1.5.0
Mouse stop working after update to 1.5.0
Status: CLOSED DUPLICATE of bug 456936
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 07:27 EDT by Mikkel Kruse Johnsen
Modified: 2008-09-21 06:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-20 21:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.conf file (811 bytes, application/octet-stream)
2008-09-20 06:03 EDT, Mikkel Kruse Johnsen
no flags Details
When running without xorg.conf (Autodetect) (35.67 KB, application/octet-stream)
2008-09-20 06:04 EDT, Mikkel Kruse Johnsen
no flags Details
Xorg.0.log (33.48 KB, application/octet-stream)
2008-09-20 06:04 EDT, Mikkel Kruse Johnsen
no flags Details
Xorg.0.log.old (34.86 KB, application/octet-stream)
2008-09-20 06:04 EDT, Mikkel Kruse Johnsen
no flags Details
Xorg.1.log (35.74 KB, application/octet-stream)
2008-09-20 06:05 EDT, Mikkel Kruse Johnsen
no flags Details
Xorg.1.log.old (35.73 KB, application/octet-stream)
2008-09-20 06:06 EDT, Mikkel Kruse Johnsen
no flags Details
Xorg.2.log (39.55 KB, application/octet-stream)
2008-09-20 06:07 EDT, Mikkel Kruse Johnsen
no flags Details

  None (edit)
Description Mikkel Kruse Johnsen 2008-09-19 07:27:45 EDT
Description of problem:

After updating to newest xorg mouse stopped working.

Version-Release number of selected component (if applicable):

Sep 18 10:58:49 Updated: xorg-x11-server-common-1.5.0-1.fc9.i386
Sep 18 10:58:54 Updated: xorg-x11-drv-evdev-2.0.4-1.fc9.i386
Sep 18 10:58:56 Updated: xorg-x11-server-Xorg-1.5.0-1.fc9.i386


Steps to Reproduce:
1. Install newest xorg
2. Restart X
  
Actual results:

Mouse not working

Expected results:

Mouse working

Additional info:

Mouse and Keyboard is on same wireless USB, the keyboard was working but not the mouse (worked under shell, not a battery problem).

"Logitech diNovo Cordless Desktop for Notebooks"

Resolved it by downgrading to:

xorg-x11-drv-evdev-2.0.2-1.fc9.i386.rpm
xorg-x11-server-common-1.4.99.905-2.20080702.fc9.i386.rpm
xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386.rpm
Comment 1 Matěj Cepl 2008-09-19 11:14:27 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Paul Finnigan 2008-09-19 15:52:14 EDT
Hi

I had a similar problem but I have taken a different take to get it working. I have added a mouse to my xorg.conf file. 

The xorg.conf now looks like this (with extra line/section commented):

# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
        # Added next line to get mouse working
        InputDevice    "USBMouse" "CorePointer"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "gb"
EndSection


# Added section to get mouse working
Section "InputDevice"
	Identifier "USBMouse"
	Driver "mouse"
	Option "Device" "/dev/input/mice"
EndSection


Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection


####################################################################

I hope this helps
Comment 3 Jean-François Martin 2008-09-19 21:13:41 EDT
I have the same problem with a Microsoft Wireless Optical Mouse 2000.
Should i report another bug report or add information here?
Comment 4 Volker Potworowski 2008-09-20 05:06:43 EDT
Same over here with a Cherry Evolution wireless Keyboard / Mouse combo.
Comment 5 Mikkel Kruse Johnsen 2008-09-20 06:03:21 EDT
Created attachment 317278 [details]
My xorg.conf file
Comment 6 Mikkel Kruse Johnsen 2008-09-20 06:04:09 EDT
Created attachment 317279 [details]
When running without xorg.conf (Autodetect)
Comment 7 Mikkel Kruse Johnsen 2008-09-20 06:04:34 EDT
Created attachment 317280 [details]
Xorg.0.log
Comment 8 Mikkel Kruse Johnsen 2008-09-20 06:04:59 EDT
Created attachment 317281 [details]
Xorg.0.log.old
Comment 9 Mikkel Kruse Johnsen 2008-09-20 06:05:33 EDT
Created attachment 317282 [details]
Xorg.1.log
Comment 10 Mikkel Kruse Johnsen 2008-09-20 06:06:39 EDT
Created attachment 317283 [details]
Xorg.1.log.old
Comment 11 Mikkel Kruse Johnsen 2008-09-20 06:07:01 EDT
Created attachment 317284 [details]
Xorg.2.log
Comment 12 Mikkel Kruse Johnsen 2008-09-20 06:08:28 EDT
Please tell me if you need more of the log files. But Xorg.2.log was last modified, may 13. So I guess it's not useful.
Comment 13 Christof Damian 2008-09-20 06:53:56 EDT
(In reply to comment #2)
> Hi
> 
> I had a similar problem but I have taken a different take to get it working. I
> have added a mouse to my xorg.conf file. 

I had the same problem with a Logitech DiNovo Edge. The change to the xorg.conf fixed it.

Cheers
Christof
Comment 14 David 2008-09-20 06:58:55 EDT
Logitech USB wireless mouse and keyboard same issue.

Roll back to:

rpm -Uvh --oldpackage xorg-x11-drv-evdev-1.99.1-0.5.fc9.i386.rpm
rpm -Uvh --oldpackage xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386.rpm
rpm -Uvh --oldpackage xorg-x11-server-common-1.4.99.901-29.20080415.fc9.i386.rpm

and its fine.

The latest build on koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=63479

Does NOT fix this :(
Comment 15 Peter Hutterer 2008-09-20 21:34:45 EDT

*** This bug has been marked as a duplicate of bug 456936 ***
Comment 16 Mikkel Kruse Johnsen 2008-09-21 06:07:19 EDT
Updating to:

xorg-x11-server/1.5.0/2.fc9/i386/xorg-x11-server-Xorg-1.5.0-2.fc9.i386.rpm
xorg-x11-server/1.5.0/2.fc9/i386/xorg-x11-server-common-1.5.0-2.fc9.i386.rpm

Worked.

http://koji.fedoraproject.org/koji/buildinfo?buildID=63479

Note You need to log in before you can comment on or make changes to this bug.