Bug 456936 - USB wireless mouse broken in 0:1.4.99.906-1.fc9
USB wireless mouse broken in 0:1.4.99.906-1.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 462815 462849 462888 463098 463391 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 14:30 EDT by Eric Paris
Modified: 2008-10-22 01:03 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 01:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386 (32.65 KB, text/plain)
2008-07-28 14:30 EDT, Eric Paris
no flags Details
log from xorg-x11-server-Xorg-1.4.99.906-1.fc9.i386 *BROKEN* (31.46 KB, text/plain)
2008-07-28 14:33 EDT, Eric Paris
no flags Details
log from xorg-x11-server-Xorg-1.4.99.906-1.fc9.i386 *BROKEN* with no xorg.conf (31.55 KB, text/plain)
2008-07-28 17:59 EDT, Eric Paris
no flags Details
log from xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386 with no xorg.conf (38.66 KB, text/plain)
2008-07-28 18:00 EDT, Eric Paris
no flags Details
hal-devices output (126.64 KB, text/plain)
2008-07-28 22:02 EDT, Eric Paris
no flags Details

  None (edit)
Description Eric Paris 2008-07-28 14:30:15 EDT
I have a logitech combo USB wireless mouse and keyboard.  With version

xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386
xorg-x11-server-common-1.4.99.905-2.20080702.fc9.i386

They both function correctly.  When I move to version

xorg-x11-server-Xorg-1.4.99.906-1.fc9.i386
xorg-x11-server-common-1.4.99.906-1.fc9.i386

My USB wireless mouse stops functioning.  The track pad mouse continues to work
just fine.  Reverting to the above listen versions caused the mouse to start
working again.  I will be attaching logs from both versions shortly.
Comment 1 Eric Paris 2008-07-28 14:30:15 EDT
Created attachment 312802 [details]
log from xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386
Comment 2 Eric Paris 2008-07-28 14:33:48 EDT
Created attachment 312804 [details]
log from xorg-x11-server-Xorg-1.4.99.906-1.fc9.i386 *BROKEN*
Comment 3 Matěj Cepl 2008-07-28 17:17:28 EDT
You have also switched (probably, unknowingly) from xorg-x11-drv-mouse to
xorg-x11-drv-evdev.
Comment 4 Matěj Cepl 2008-07-28 17:21:21 EDT
Of course, try to run Xorg without any /etc/X11/xorg.conf whatsoever. What happens?
Comment 5 Eric Paris 2008-07-28 17:59:40 EDT
Created attachment 312825 [details]
log from xorg-x11-server-Xorg-1.4.99.906-1.fc9.i386 *BROKEN* with no xorg.conf

The updated xorg-x11-server-Xorg and xorg-x11-server-common with no config file
resulted in a system with no keyboard (both the built in and USB wireless
keyboard failed) and the USB mouse did not work.  The touchpad mouse built into
the laptop still worked.

So, that made it MUCH worse.
Comment 6 Eric Paris 2008-07-28 18:00:32 EDT
Created attachment 312826 [details]
log from xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386 with no xorg.conf
Comment 7 Peter Hutterer 2008-07-28 21:28:24 EDT
Eric:
what you are seeing is a combination of multiple issues.

First: The X server hotplugs input devices now, and it doesn't rely on devices
specified in the xorg.conf. Instead it obtains them via HAL.

This means that it doesn't force default input sections anymore if you don't
have them specified in the xorg.conf. Previous versions would auto-add a pointer
+ keyboard section if none were specified. This was a fairly recent change
(that's why a downgrade works for you).

However, the evdev driver for keyboards caused a number of issues, and fedora
has a patch to ignore keyboards provided by HAL. You're using a logitech
wireless combo and we found that some of them (if not all) advertise the mouse
as a mouse _and_ a keyboard (a quick check of hal-device shows you the
info.capabilities). 
Because it looks like a keyboard, it's ignored when hotplugging - hence you
don't get your mouse to work.

The simplest solution is to add Option "AllowEmptyInput" "off" to your
ServerLayout. This forces the server to auto-add a mouse/keyboard section.

The correct solution is to add an InputDevice section for your mouse and your
keyboard, and reference them from your ServerLayout.

The even better solution is for us to get rid of the fedora anti-keyboard patch,
but we're not quite there - yet.
Comment 8 Eric Paris 2008-07-28 22:02:55 EDT
Created attachment 312834 [details]
hal-devices output

Just want to make sure we are on the right track.  My line which I believe is
the wireless mouse shows:

  info.capabilities = { 'input', 'input.keys', 'input.mouse', 'button' }
(string list)

and the keyboard shows:

  info.capabilities = { 'input', 'input.keyboard', 'input.keypad',
'input.keys', 'button' } (string list)

I also have this in my xorg.conf:

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver	    "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

So I guess that explains why my built in keyboard continued to work in the new
xorg-x11-server-Xorg.

/me has no idea what the right magic sauce is get the new stuff working, but I
guess I'll try to google myself and answer tomorrow.  All of this is black
magic to me   :)
Comment 9 Peter Hutterer 2008-07-28 22:13:12 EDT
yeah, you can see the mouse announces having keys. The (fedora) server
classifies this as keyboard and ignores it when hotplugging.

The Keyboard0 needs to be referenced from your ServerLayout.

For the usb mouse to work, add

Section "InputDevice"
  Identifier "mymouse"
  Driver "evdev"
  Option "Device" "/dev/input/by-id/<device name>-event-mouse"
EndSection

Or just add a section with Driver mouse and device /dev/input/mice.
Comment 10 Eric Paris 2008-07-29 09:01:23 EDT
So I decided to cheat and just add 

Section "InputDevice"
  Identifier "Mouse0"
  Driver "mouse"
EndSection

Which as you indicated gets me working with what's in updates-testing.  If its
useful to you for me to add the more complete evdev entry (I assume I need one
for the touchpad and one for the USB mouse even though the USB mouse disappears
regularly?) I will.

I assume we should leave this bug open until things "just work" as I'm guessing
I'm not the only person in the world with a logitech mouse that would stop
working if we pushed xorg-x11-server-Xorg to updates?

Thanks for the help!
Comment 11 Peter Hutterer 2008-08-10 21:37:55 EDT
(In reply to comment #10)
> (I assume I need one for the touchpad and one for the USB mouse even though the USB mouse disappears> regularly?)
You wouldn't have to add a section for the touchpad, the log indicates it's working just fine.


FWIW, rawhide xserver 906-5 should work fine now. The patch to ignore keyboards has been removed.
Comment 12 Luis Villa 2008-08-27 10:04:07 EDT
FWIW, my microsoft wireless combo keyboard/mouse stopped working some time around the same time. I haven't been able to track it down to the same specific change, though. So probably more widespread than just logitechs. (Am testing more now to see if it really is the same problem.)
Comment 13 Luis Villa 2008-08-27 10:19:17 EDT
Yeah, same downgrade fixed it. If someone needs me to debug more, let me know, otherwise I'll just be relying on the downgrade for now.
Comment 14 Peter Hutterer 2008-08-28 00:35:43 EDT
Luis:

I have one of them too, hal-device says that they have keys, hence they are affected by the same issue.

info.product = 'Microsft Microsoft Wireless Desktop Receiver 3.1A'  (string)
info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
Comment 15 Peter Hutterer 2008-09-14 20:46:31 EDT
xorg-x11-server-Xorg-1.5.0-1.fc9 should fix this bug. Can you please verify this?

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-8032
Comment 16 Eric Paris 2008-09-15 09:26:53 EDT
installed everything in updates-testing including

xorg-x11-server-Xorg-1.5.0-1.fc9.i386

removed all InputDevice sections from /etc/X11/xorg.conf and rebooted the computer

Neither the logitech wireless keyboard or the keyboard built into the laptop worked.  The logitech wireless mouse was also non-functional.  The built in trackpad mount on the laptop did work.

Seems nothing was better...
Comment 17 Peter Hutterer 2008-09-15 23:23:45 EDT
Eric, can you give me an updated logfile please?
Comment 18 Sergio Pascual 2008-09-19 02:45:56 EDT
After updating xorg-x11-server-\* yesterday, the mouse from my keyboard mouse wireless combo ceased to work. I could fix it adding 

Option  "AllowEmptyInput" "off"

to ServerLayout in xorg.conf

And what I'm wondering is why has this been pushed to updates if it breaks existing working configurations?
Comment 19 Peter Hutterer 2008-09-19 03:25:37 EDT
Sergio: The fix for that issue is in 1.5.0-2, a simple 1 line patch that reverts a default that has changed upstream since.

https://admin.fedoraproject.org/updates/xorg-x11-server-1.5.0-2.fc9

But I'm afraid I have bad news: F9 will (until further notice) keep the patch that disables evdev keyboards through HAL. This patch affects some mice as mentioned in Comment #7. Comment #9 details a workaround.
Comment 20 Peter Hutterer 2008-09-19 03:33:08 EDT
*** Bug 462815 has been marked as a duplicate of this bug. ***
Comment 21 Matthias Saou 2008-09-19 12:05:33 EDT
I also had the same problem with my Logitech wireless combo when I got the update to 1.5.0-1.fc9 very recently. This a *VERY* bad user experience... I'm computer literate  enough to fix the problem, but I know many end users aren't.

Switching to have Xorg detect input devices differently in the middle of the Fedora 9 cycle doesn't seem like a wise choice either. Especially pushing the change to the stable updates when this bug report already contains evidence of unfixed failures.

I can also confirm that 1.5.0-2.fc9 fixes the problem for me.
Comment 22 Kent Pirkle 2008-09-19 12:33:44 EDT
1.5.0-2.fc9 fixes my issue with the mouse not working through an Avocent KVM switch.
Comment 23 Matěj Cepl 2008-09-19 13:03:48 EDT
Eric? Does 1.5.0-2.fc9 works for you?
Comment 24 Eric Paris 2008-09-19 13:33:15 EDT
1.5.0-2 and I am now a proud X user with absolutely no xorg.conf what-so-ever.

Lets push 1.5.0-2 very quickly.......
Comment 25 Peter Hutterer 2008-09-20 21:34:45 EDT
*** Bug 462849 has been marked as a duplicate of this bug. ***
Comment 26 Luis Villa 2008-09-21 18:00:15 EDT
<i>Lets push 1.5.0-2 very quickly.......</i>

+1 here. Fixes my problem.
Comment 27 Peter Hutterer 2008-09-22 00:11:58 EDT
*** Bug 463098 has been marked as a duplicate of this bug. ***
Comment 28 Peter Hutterer 2008-09-22 00:44:37 EDT
*** Bug 462888 has been marked as a duplicate of this bug. ***
Comment 29 Tim Taiwanese Liim 2008-09-26 01:07:39 EDT
*** Bug 463391 has been marked as a duplicate of this bug. ***
Comment 30 Peter Hutterer 2008-10-22 01:03:39 EDT
I'm closing this bug as RAWHIDE.

As explained in comment #7, mice that expose keys are interpreted as keyboards by the X server and a patch we have in F9's server disables them. This can only be fixed by removing the no-keyboard patch, which has been done for F10.

However, you can get around this problem using a workaround described in comment #9.

Note You need to log in before you can comment on or make changes to this bug.