Bug 462876 - java console can't be opened in firefox
java console can't be opened in firefox
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
: 466202 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 09:27 EDT by Christian Krause
Modified: 2009-06-07 13:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.6.0.0-18.b16.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 10:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2008-09-19 09:27:01 EDT
Description of problem:
Opening the java console in firefox (using the webdeveloper extenseion) doesn't work. No reaction when I click on the menu entry.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-plugin-1.6.0.0-0.18.b09.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1. install webdeveloper extension in firefox
2. make sure, that really the openjdk plugin is used (via about:plugins)
3. try to open the java console with Tools->Web Developer->Tools->Java Console

  
Actual results:
nothing happens

Expected results:
java console should be opened

Additional info:
When I use Sun's JRE 1.6.0_06 (jdk1.6.0_06/jre/plugin/i386/ns7/libjavaplugin_oji.so) instead of OpenJDK, the Java Console is opened without any problems. That's why I assume it is a problem in OpenJDK.
Comment 1 Lillian Angel 2008-10-16 10:50:41 EDT
*** Bug 466202 has been marked as a duplicate of this bug. ***
Comment 2 Donald Cohen 2008-10-16 12:59:29 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=466202
was slightly different from this, I believe, in that the console didn't even show up in the tools menu.  (Sorry I can't verify this at the moment since the machine is not here.)
Comment 3 Omair Majid 2009-01-07 11:43:12 EST
It seems that the webdeveloper extension skips checking for java support and blindly shows the java console entry. Java console support is currently not implemented in IcedteaPlugin.
Comment 4 Donald Cohen 2009-01-31 00:36:41 EST
I notice that by simply running firefox from a shell you get all of the java console output in the shell window.  In terms of usefulness this seems an adequate work around.
Comment 5 Christian Krause 2009-02-05 15:47:13 EST
(In reply to comment #3)
> It seems that the webdeveloper extension skips checking for java support and
> blindly shows the java console entry. Java console support is currently not
> implemented in IcedteaPlugin.

Ok, I understand. Do you know whether it is planned to implement this? I've already checked icedtea's web page, but I couldn't find any related information.

(In reply to comment #4)
> I notice that by simply running firefox from a shell you get all of the java
> console output in the shell window.  In terms of usefulness this seems an
> adequate work around.

Thank you very much for the hint. This workaround works fine for me.

Since the problem is also still in F10, I've updated the Fedora version of this bug.
Comment 7 Donald Cohen 2009-05-29 12:54:17 EDT
So how can I get firefox to open a java console?
(Or when will I be able to?)
Comment 8 Fedora Update System 2009-05-30 10:16:01 EDT
java-1.6.0-openjdk-1.6.0.0-18.b16.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-18.b16.fc10
Comment 9 Fedora Update System 2009-05-30 10:16:59 EDT
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-22.b16.fc11
Comment 10 Fedora Update System 2009-06-02 10:22:44 EDT
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-06-02 10:30:21 EDT
java-1.6.0-openjdk-1.6.0.0-18.b16.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Christian Krause 2009-06-03 13:26:32 EDT
Thank you very much!

I've successfully tested the feature using the web developer extensions in Firefox: the menu entry "Tools/Web Developer/Tools/Java Console" opens correctly the java console and java error messages are correctly displayed.

I've verified this feature in F10 and upcoming F11.
Comment 13 Donald Cohen 2009-06-06 02:04:25 EDT
Where does one get these web developer extensions?
I'm now using firefox-3.5-0.20.beta4.fc11.x86_64
I tried the sun java console 6.0.02 addon and it claims to be installed
but I see nothing about it in tools.
Comment 14 Christian Krause 2009-06-07 09:53:30 EDT
(In reply to comment #13)
> Where does one get these web developer extensions?

- Tools / AddOns / Get AddOns / Browse All AddOns
- search for "web developer"
- https://addons.mozilla.org/en-US/firefox/addon/60

> I'm now using firefox-3.5-0.20.beta4.fc11.x86_64
> I tried the sun java console 6.0.02 addon and it claims to be installed
> but I see nothing about it in tools.  

The Java console is available after installing the mentioned extension in the menu:

Tools / Web Developer / Tools / Java Console
Comment 15 Donald Cohen 2009-06-07 12:12:11 EDT
(In reply to comment #14)
> - https://addons.mozilla.org/en-US/firefox/addon/60
That seems to have installed ok. 
> Tools / Web Developer / Tools / Java Console  
There seems to be a lot under that menu.
I see Java Console there but it doesn't seem to bring up a java console.
I'm looking for a new window.  Should I be looking for something else?
It says ctl-shift O is the keyboard shortcut for that, but when I try it
I see a window with title Library and it looks like its for editing bookmarks.
Comment 16 Christian Krause 2009-06-07 13:06:20 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > - https://addons.mozilla.org/en-US/firefox/addon/60
> That seems to have installed ok. 
> > Tools / Web Developer / Tools / Java Console  
> There seems to be a lot under that menu.
> I see Java Console there but it doesn't seem to bring up a java console.

This works for me.

> I'm looking for a new window.  Should I be looking for something else?

Yes, there should be a new window opened (title: "Java Console").

> It says ctl-shift O is the keyboard shortcut for that, but when I try it
> I see a window with title Library and it looks like its for editing bookmarks.  

Yes, indeed the keyboard shortcut doesn't work.

Here are the versions of my environment:

web developer 1.1.6
firefox-3.5-0.20.beta4.fc11.i586
java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586

Enter "about:plugins" in the URL field and check, whether your firefox uses the correct java. If there is more than one java plugin, delete all others besides java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586.
Comment 17 Donald Cohen 2009-06-07 13:37:43 EDT
(In reply to comment #16)
> Here are the versions of my environment:
> web developer 1.1.6
same

> firefox-3.5-0.20.beta4.fc11.i586
firefox-3.5-0.20.beta4.fc11.x86_64  (same version, different platform)

> java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586
yum log says:
Jun 05 20:38:49 Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-20.b14.fc11.x86_64
slightly older version, what's the 1: about?

> Enter "about:plugins" in the URL field and check, whether your firefox uses the
> correct java. If there is more than one java plugin, delete all others besides
> java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586.  

about:plugins says (among other things)
IcedTea Java Web Browser Plugin
    File name: IcedTeaPlugin.so
    The IcedTea Java Web Browser Plugin 1.4.1 (fedora-20.b14.fc11-x86_64) executes Java applets.
In the following table is lists mime types up to 1.6, i.e.,
application/x-java-applet;version=1.6

So it looks like the main difference is the openjdk version.
Off hand I don't see how to get a more recent one unless the yum repository has been updated in the last 2 days.
Comment 18 Christian Krause 2009-06-07 13:48:38 EDT
(In reply to comment #17)
> > java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586
> yum log says:
> Jun 05 20:38:49 Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-20.b14.fc11.x86_64
> slightly older version, what's the 1: about?

That's the problem. The bug got solved in the newest release:
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5746 (which corresponds with the package I have mentioned).

It stable release was pushed out a couple days ago, so probably it hasn't reached all mirrors yet (and right now the F11 mirrors don't work).

You have two options now:

1. Just wait a couple of days until F11 is out and the mirrors are fully synced.

2. Or you download all packages manually from here: http://koji.fedoraproject.org/koji/buildinfo?buildID=104084 and install them.

Note You need to log in before you can comment on or make changes to this bug.