Bug 462888 - Logitech wireless mouse stopped working after update to 2.6.26.3-29.fc9.i686
Logitech wireless mouse stopped working after update to 2.6.26.3-29.fc9.i686
Status: CLOSED DUPLICATE of bug 456936
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 10:19 EDT by Yunus Aswat
Modified: 2008-09-22 00:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 00:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (883 bytes, application/octet-stream)
2008-09-19 17:59 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.0.log (35.21 KB, application/octet-stream)
2008-09-19 18:01 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.1.log (10.83 KB, application/octet-stream)
2008-09-19 18:02 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.2.log (8.20 KB, application/octet-stream)
2008-09-19 18:03 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.3.log (8.20 KB, application/octet-stream)
2008-09-19 18:04 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.4.log (8.20 KB, application/octet-stream)
2008-09-19 18:07 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.5.log (8.20 KB, application/octet-stream)
2008-09-19 18:07 EDT, Yunus Aswat
no flags Details
/var/log/messages (1.08 MB, application/octet-stream)
2008-09-19 18:10 EDT, Yunus Aswat
no flags Details
/var/log/dmesg (22.54 KB, application/octet-stream)
2008-09-19 18:17 EDT, Yunus Aswat
no flags Details
/var/log/Xorg.0.log after running without /etc/X11/xorg.conf (35.21 KB, application/octet-stream)
2008-09-19 18:45 EDT, Yunus Aswat
no flags Details

  None (edit)
Description Yunus Aswat 2008-09-19 10:19:51 EDT
Description of problem:
I use a Logitech Cordless Desktop EX110 keyboard/mouse combo. This has a wireless keyboard and mouse. The keyboard works ok after the update but the mouse does not.

Version-Release number of selected component (if applicable):
Kernel updated to 2.6.26.3-29.fc9.i686

How reproducible:
Install latest updates, from 2.6.25.14-108.fc9.i686 to 2.6.26.3-29.fc9.i686. There were a number of updates applied, the details of which I do not know but the update to the kernel was as described above.

Steps to Reproduce:
1. Begin with a kernel 2.6.25.14-108.fc9.i686.
2. Apply updates that show up in the updater.
3. Restart machine into 2.6.26.3-29.fc9.i686.
  
Actual results:
The mouse does not respond at all.

Expected results:
The mouse pointer should work as normal.

Additional info:
Booting into kernel 2.6.25.14-108.fc9.i686 after the update makes no difference. I suspect the kernel has nothing to do with this as a number of updates were applied at the same time, but this is the only visible update I can relate to. If there is a way to determine what updates were applied on a particular date I can provide more information.

I have also done a diff on xorg.conf between the updated and old file and there are no obvious differences.
Comment 1 Yunus Aswat 2008-09-19 10:22:52 EDT
When doing a ll on the /dev/input directory, I have two devices:

mouse0
mouse1

mouse1 appears to give output when moving the mouse during a cat mouse1 command. I don't know what configuration file has changed that prevents the mouse from working.
Comment 2 Matěj Cepl 2008-09-19 13:38:44 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf), X server log file (/var/log/Xorg.*.log), /var/log/messages, and /var/log/dmesg to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Yunus Aswat 2008-09-19 17:59:57 EDT
Created attachment 317252 [details]
/etc/X11/xorg.conf

As requested.
Comment 4 Yunus Aswat 2008-09-19 18:01:30 EDT
Created attachment 317253 [details]
/var/log/Xorg.0.log
Comment 5 Yunus Aswat 2008-09-19 18:02:41 EDT
Created attachment 317254 [details]
/var/log/Xorg.1.log
Comment 6 Yunus Aswat 2008-09-19 18:03:50 EDT
Created attachment 317255 [details]
/var/log/Xorg.2.log
Comment 7 Yunus Aswat 2008-09-19 18:04:59 EDT
Created attachment 317256 [details]
/var/log/Xorg.3.log
Comment 8 Yunus Aswat 2008-09-19 18:07:00 EDT
Created attachment 317257 [details]
/var/log/Xorg.4.log
Comment 9 Yunus Aswat 2008-09-19 18:07:58 EDT
Created attachment 317258 [details]
/var/log/Xorg.5.log
Comment 10 Yunus Aswat 2008-09-19 18:10:44 EDT
Created attachment 317259 [details]
/var/log/messages
Comment 11 Yunus Aswat 2008-09-19 18:17:36 EDT
Created attachment 317261 [details]
/var/log/dmesg
Comment 12 Yunus Aswat 2008-09-19 18:22:13 EDT
I forgot to add in the initial bug report that the nvidia kernel module could not be loaded because it is not compatible with kernel 2.6.26.3-29.fc9.i686. Still I can't see this being the problem though I expect the logs attached to contain errors related to this.

I will try running without /etc/X11/xorg.conf and report back with the results.
Comment 13 Yunus Aswat 2008-09-19 18:45:12 EDT
Created attachment 317265 [details]
/var/log/Xorg.0.log after running without /etc/X11/xorg.conf
Comment 14 Yunus Aswat 2008-09-19 18:56:33 EDT
I have a Nvidia AGP graphics card 5900XT. /var/log/Xorg.0.log is attached after running without /etc/X11/xorg.conf. I did this by moving xorg.conf to xorg.cong.test and restarting the machine. It did boot into a graphical mode, but apart from ctrl+alt+del nothing else would work on the keyboard and I couldn't log in as a result. Restarting into run level 3 and moving xorg.conf back restored keyboard functionality.

Mouse still did not function throughout the test.
Comment 15 Peter Hutterer 2008-09-22 00:44:37 EDT

*** This bug has been marked as a duplicate of bug 456936 ***

Note You need to log in before you can comment on or make changes to this bug.