Bug 462892 - gfs: use dlm_posix_set_fsid() for compat with old gfs_controld
gfs: use dlm_posix_set_fsid() for compat with old gfs_controld
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On: 462354
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 10:58 EDT by David Teigland
Modified: 2010-01-11 22:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:18:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2008-09-19 10:58:59 EDT
Description of problem:

Bug 462354 allows gfs1&2 to work with old versions of gfs_controld.
It adds the function dlm_posix_set_fsid() which gfs1 needs to
call to set the fsid in the plock ops.

Once the patch for 462354 is included, and dlm_posix_set_fsid is
whitelisted, gfs1 can get this patch:

diff --git a/gfs-kernel/src/gfs/lock_dlm_mount.c b/gfs-kernel/src/gfs/lock_dlm_m
index 9546a13..909d6c2 100644
--- a/gfs-kernel/src/gfs/lock_dlm_mount.c
+++ b/gfs-kernel/src/gfs/lock_dlm_mount.c
@@ -154,6 +154,8 @@ static int gdlm_mount(char *table_name, char *host_data,
                goto out_kobj;
        }
 
+       dlm_posix_set_fsid(ls->dlm_lockspace, ls->id);
+
        lockstruct->ls_jid = ls->jid;
        lockstruct->ls_first = ls->first;
        lockstruct->ls_lockspace = ls;
 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kiersten (Kerri) Anderson 2008-09-23 11:39:02 EDT
This is dependent on the gfs compatibility patch for the dlm kernel.  Once that patch is in, then this will get commited.  Added exception flag to allow us to be backward compatible with earlier rhel 5 cman packages.
Comment 5 Kiersten (Kerri) Anderson 2008-10-21 09:58:19 EDT
Turns out we can do this after beta builds.
Comment 7 Nate Straz 2008-11-13 15:12:01 EST
Verified plocks work on a RHEL 5.3 node which has joined a RHEL 5.3 cluster
using tree RHEL5.3-Server-20081105.1.
Comment 9 errata-xmlrpc 2009-01-20 16:18:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0132.html

Note You need to log in before you can comment on or make changes to this bug.