Bug 462919 - kernel 2.6.26.3-19.fc9.x86_64 TT-budget C-1500 DVB card is not longer working
kernel 2.6.26.3-19.fc9.x86_64 TT-budget C-1500 DVB card is not longer working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Regression
: 462637 465252 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 14:05 EDT by Maxime Bellengé
Modified: 2008-10-23 21:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
here is the dmesg output after booting the new kernel (30.24 KB, text/plain)
2008-09-23 13:08 EDT, Maxime Bellengé
no flags Details
dmesg trace from the previous working kernel (32.35 KB, text/plain)
2008-09-25 16:34 EDT, Maxime Bellengé
no flags Details

  None (edit)
Description Maxime Bellengé 2008-09-19 14:05:59 EDT
Description of problem:
With the new kernel-2.6.26.3-29.fc9.x86_64, the TT C-1500 dvb card is no longer recognized. I have two dvb cards in the computer : (HVT-1100 DVB-T) which is working fine with 2.6.26.3 and TT C-1500 which is not found. No /dev/dvb/adapter* entry.

Version-Release number of selected component (if applicable):


How reproducible:

Just boot and see that no /dev/dvb/adapter* entry is present for C-1500


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2008-09-21 18:42:18 EDT
Can you attach the file /var/log/dmesg after booting the new kernel?
Comment 2 Maxime Bellengé 2008-09-23 13:08:39 EDT
Created attachment 317494 [details]
here is the dmesg output after booting  the new kernel

here is the dmesg output after booting  the new kernel
Comment 3 Chuck Ebbert 2008-09-25 08:44:44 EDT
I should have asked for the log from the old kernel too. Can you attach that as well?
Comment 4 Maxime Bellengé 2008-09-25 16:34:23 EDT
Created attachment 317724 [details]
dmesg trace from the previous working kernel
Comment 5 Lauri Nurmi 2008-10-01 17:01:34 EDT
I suspect the explanation of the reason for this bug can be found in bug 462637.

Also, this bug should have the Regression keyword set.
Comment 6 Lauri Nurmi 2008-10-01 17:17:14 EDT
Additional note:

A workaround for getting the DVB device recognized again is to delete
/lib/modules/`uname -r`/kernel/sound/pci/aw2/snd-aw2.ko and reboot.
Comment 7 Chuck Ebbert 2008-10-02 12:27:06 EDT
*** Bug 462637 has been marked as a duplicate of this bug. ***
Comment 8 Chuck Ebbert 2008-10-02 12:31:47 EDT
(In reply to comment #6)
> Additional note:
> 
> A workaround for getting the DVB device recognized again is to delete
> /lib/modules/`uname -r`/kernel/sound/pci/aw2/snd-aw2.ko and reboot.

The right workaround is to just blacklist snd-aw2 in /etc/modprobe.d/blacklist
Comment 9 Maxime Bellengé 2008-10-03 07:44:27 EDT
Thanks, blacklisting snd_aw2 make the dvb card work again !
Comment 10 Chuck Ebbert 2008-10-03 21:38:04 EDT
Disabled the snd-aw2 driver until a better solution can be found. It wasn't in the previous kernel, so nobody should miss it.
Comment 11 Chuck Ebbert 2008-10-04 00:34:54 EDT
*** Bug 465252 has been marked as a duplicate of this bug. ***
Comment 12 Kevin R. Page 2008-10-06 04:11:17 EDT
This affects other SAA7146 based DVB cards too, e.g. Hauppauge Nova-T. Blacklisting snd-aw2 works.
Comment 13 Fedora Update System 2008-10-14 15:53:18 EDT
kernel-2.6.26.6-46.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-46.fc8
Comment 14 Fedora Update System 2008-10-14 16:02:45 EDT
kernel-2.6.26.6-71.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-71.fc9
Comment 15 Fedora Update System 2008-10-20 16:29:26 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8929
Comment 16 Fedora Update System 2008-10-23 12:38:55 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.