Bug 465252 - kernel-2.6.26.5-28.fc8 breaks Terratec Cinergy 1200 DVB-C support
kernel-2.6.26.5-28.fc8 breaks Terratec Cinergy 1200 DVB-C support
Status: CLOSED DUPLICATE of bug 462919
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 09:03 EDT by Bernd Bartmann
Modified: 2008-10-04 00:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-04 00:34:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2008-10-02 09:03:49 EDT
Description of problem:
Up to kernel-2.6.25.14-69.fc8 my Terratec Cinergy 1200 DVB-C card was working fine  in VDR. After updating to kernel-2.6.26.5-28.fc8 the card is not found anymore, i.e. I see no messages for this card in /var/log/messages. Two other DVB-T cards still remain working.

Version-Release number of selected component (if applicable):
kernel-2.6.26.5-28.fc8

How reproducible:
Works always with kernel-2.6.25.14-69.fc8
Never works with kernel-2.6.26.5-28.fc8

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Markku Kolkka 2008-10-03 09:39:26 EDT
I have the same card and the same problem. With kernel 2.6.25.14-69.fc8 the device nodes in /dev/dvb/* aren't created even if lsmod shows that the driver modules for the card are loaded. From system log it appears that the new kernel thinks that the DVB-C card is a sound card:

Oct  3 07:51:35 nightshade kernel: Audiowerk 2 sound card (saa7146 chipset) dete
cted and managed
Oct  3 07:51:35 nightshade kernel: cannot find the slot for index 0 (range 0-0),
 error: -16
Oct  3 07:51:35 nightshade kernel: hda-intel: Error creating card!
Oct  3 07:51:35 nightshade kernel: HDA Intel: probe of 0000:00:1b.0 failed with
error -12
Oct  3 07:51:35 nightshade kernel: Linux video capture interface: v2.00
Oct  3 07:51:35 nightshade kernel: saa7146: register extension 'budget_av'.

Hardware profile: http://www.smolts.org/client/show/?uuid=pub_b6451a8c-fbe5-48d9-a445-cb84f73a46ad
Comment 2 Chuck Ebbert 2008-10-04 00:34:53 EDT
Blacklist the snd-aw2 driver by adding it to /etc/modprobe.d/blacklist

*** This bug has been marked as a duplicate of bug 462919 ***

Note You need to log in before you can comment on or make changes to this bug.