Bug 462963 - WPA2 Encryption Not Functioning
WPA2 Encryption Not Functioning
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10KernelBlocker
  Show dependency treegraph
 
Reported: 2008-09-19 18:06 EDT by eric@christensenplace.us
Modified: 2008-10-20 20:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 20:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A portion of the messages log. (27.77 KB, text/plain)
2008-09-30 22:42 EDT, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2008-09-19 18:06:21 EDT
Description of problem: I can not get my WiFi to completely connect when using the latest kernel.  It attempts to connect but prompts for the WPA2 key after a few seconds.

Version-Release number of selected component (if applicable): kernel-2.6.27-0.329.rc6.git2.fc10.i686


How reproducible: Very


Steps to Reproduce:
1. Boot using kernel-2.6.27-0.329.rc6.git2.fc10.i686.
2. Login and attempt to connect to a WiFi network requiring WPA2 encryption.
3. Fail
  
Actual results:
Not able to connect.

Expected results:
Should be able to connect.

Additional info: I'm able to connect using kernel-2.6.27-0.323.rc6.fc10.i686.
Comment 1 John W. Linville 2008-09-23 12:53:40 EDT
What hardware are you using?  What messages are output from dmesg or are in /var/log/messages?  Are you using NetworkManager?  Or running wpa_supplicant directly?
Comment 2 eric@christensenplace.us 2008-09-25 20:00:37 EDT
Having the same problem using 2.6.27-0.352.rc7.git1.fc10.i686.

I'm using RaLink EW-7108PCg wireless card.  

I am not seeing any entries from dmesg in /var/log/messages.

I am using NetworkManager.
Comment 3 John W. Linville 2008-09-26 10:22:31 EDT
Perhaps you should just attach /var/log/messages to this bug.
Comment 4 John W. Linville 2008-09-29 14:16:11 EDT
*** Bug 464294 has been marked as a duplicate of this bug. ***
Comment 5 eric@christensenplace.us 2008-09-30 22:42:57 EDT
Created attachment 318158 [details]
A portion of the messages log.

This is the log file containing all the information from startup until after the system has tried to connect to the WAP twice.
Comment 6 eric@christensenplace.us 2008-09-30 22:45:09 EDT
Just upgraded to latest kernel tonight (2.6.27-0.370.rc8.fc10.i686).  Still having the same problem. 2.6.27-0.323.rc6.fc10.i686 still works properly.
Comment 7 John W. Linville 2008-10-01 15:29:45 EDT
That is odd...only a few wireless-related patches came in between 2.6.27-rc6 and 2.6.27-rc8 upstream, and none of them look pertinent to wpa2 or any driver other than ath9k (or maybe b43/b43legacy).  I'm not sure what else is getting into rawhide in between the kernels cited in comment 6.

Jouni Malinen (1):
      ath9k: Assign seq# when mac80211 requests this

Linus Torvalds (1):
      Revert "b43/b43legacy: add RFKILL_STATE_HARD_BLOCKED support"

Luis R. Rodriguez (1):
      ath9k: disable MIB interrupts to fix interrupt storm

Senthil Balasubramanian (2):
      ath9k: connectivity is lost after Group rekeying is done
      ath9k: Fix IRQ nobody cared issue with ath9k

born.into.silence@gmail.com (1):
      wireless: zd1211rw: add device ID fix wifi dongle "trust nw-3100"
Comment 8 John W. Linville 2008-10-01 16:39:50 EDT
FWIW, I built a vanilla 2.6.27-rc8 kernel w/ the config from 2.6.27-0.352.rc7.git1.fc10.x86_64.  The vanilla kernel connected to my WPA2 AP w/o a problem, while the fc10 kernel failed.

I'm forced to suspect that something we are adding to Fedora is causing this problem.  I just don't know what that may be. :-(
Comment 9 John W. Linville 2008-10-01 17:51:26 EDT
Ditto w/ vanilla 2.6.27-rc8 w/ config from 2.6.27-0.377.rc8.git1.fc10.x86_64...
Comment 10 John W. Linville 2008-10-03 15:40:53 EDT
Please see bug 458972 comment 11...
Comment 11 eric@christensenplace.us 2008-10-08 21:25:55 EDT
Having the same problem with 2.6.27-0.398.rc9.fc10.i686.
Comment 12 eric@christensenplace.us 2008-10-14 21:37:53 EDT
It appears that it works now using the 2.6.27-3.fc10.i686 kernel.

Note You need to log in before you can comment on or make changes to this bug.