Bug 464294 - Cannot get stable connection with BCM4318 and WEP
Cannot get stable connection with BCM4318 and WEP
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 04:43 EDT by Matěj Cepl
Modified: 2008-10-08 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 18:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (2.22 MB, text/plain)
2008-09-27 04:43 EDT, Matěj Cepl
no flags Details
/var/log/dmesg (27.93 KB, text/plain)
2008-09-27 04:44 EDT, Matěj Cepl
no flags Details
stdout of dmesg (30.39 KB, text/plain)
2008-09-27 04:45 EDT, Matěj Cepl
no flags Details
/var/log/messages with WEP (3.77 MB, text/plain)
2008-09-27 07:23 EDT, Matěj Cepl
no flags Details
/var/log/dmesg (26.81 KB, text/plain)
2008-09-27 07:31 EDT, Matěj Cepl
no flags Details
stdout of dmesg (33.32 KB, text/plain)
2008-09-27 07:36 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-09-27 04:43:51 EDT
Created attachment 317853 [details]
/var/log/messages

Description of problem:
I have a notebook which wifi BCM4318 I tried to make work in bug 198071. After one update of F8 it actually begin to work with my wifi, but the power supply for the notebook broke, so I put the computer on the shelf and forgot about it (and I haven't closed the bug properly, I am sorry; I think it has been already fixed as INSUFFICIENT_DATA in meanwhile, so I didn't bother).

Now, I decided I want a notebook for my wife, so I let the power supply to be fixed, upgraded to the latest version of everything from F8-updates-newkey and tried again. Meanwhile, I have switched our home wifi network to WPA, and when I tried to connect to the network with NetworkManager it failed to connect and asked repeatedly for the password.

I am not sure which component in the network stack is to blame so I am starting from the bottom and putting Dan Williams on Cc: just to be sure, that I include all involved person. Feel free to reassign.

Version-Release number of selected component (if applicable):
[matej@chelcicky disk]$ rpm -qa kernel\* Network\* wpa\* 
NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc8
kernel-2.6.26.3-14.fc8
NetworkManager-0.7.0-0.6.9.svn3675.fc8
kernel-headers-2.6.26.5-27.fc8
kernel-2.6.23.15-137.fc8
NetworkManager-glib-0.7.0-0.6.9.svn3675.fc8
NetworkManager-gnome-0.7.0-0.6.9.svn3675.fc8
wpa_supplicant-0.5.10-5.fc8
kernel-2.6.26.5-27.fc8
[matej@chelcicky disk]$ uname -a
Linux chelcicky.ceplovi.cz 2.6.26.5-27.fc8 #1 SMP Fri Sep 19 20:09:06 EDT 2008 i686 i686 i386 GNU/Linux
[matej@chelcicky disk]$ 

How reproducible:
100%

Steps to Reproduce:
1.upgrade to the latest F8 and reboot
2.select WIFI network in the NetworkManager
3.fill in the correct password
  
Actual results:
NM tries to get connection, but fails to do so.

Expected results:
Network connection like I get with this notebook with iwl3945 and F9.
Comment 1 Matěj Cepl 2008-09-27 04:44:36 EDT
Created attachment 317854 [details]
/var/log/dmesg
Comment 2 Matěj Cepl 2008-09-27 04:45:44 EDT
Created attachment 317855 [details]
stdout of dmesg

Not sure whether the information is the same as in /var/log/dmesg -- diff seems to think it isn't.
Comment 3 Matěj Cepl 2008-09-27 07:23:21 EDT
Created attachment 317861 [details]
/var/log/messages with WEP

When I switched the wifi access point to WEP, NetworkManager was easily able to connect to the network (after asking me for the password, of course), but the connection didn't last longer than couple of minutes (actually I was trying to change the component of this bug to wpa_supplicant, but the network connection died before the component listbox got filled; good, that I haven't managed to change that component :)). When trying to connect to the network repeatedly, I always got connection on the first attempt, but unfortunately the connection never lasted for longer than a minute or so.
Comment 4 Matěj Cepl 2008-09-27 07:31:30 EDT
Created attachment 317862 [details]
/var/log/dmesg
Comment 5 Matěj Cepl 2008-09-27 07:36:49 EDT
Created attachment 317863 [details]
stdout of dmesg
Comment 6 Matěj Cepl 2008-09-27 17:46:19 EDT
Some more notes:

a) I dimly remember that when it worked with F8, it was actually bcm43legacy (or whatever was the name then), which when I tried now didn't generate even a wlan0 device.
b) after all this unsuccessful attempts I gave up and installed ndiswrapper, which works like a charm -- so that we can eliminate possibility of hardware issues from the consideration.
Comment 7 John W. Linville 2008-09-29 14:16:11 EDT

*** This bug has been marked as a duplicate of bug 462963 ***
Comment 8 Matěj Cepl 2008-09-29 18:08:15 EDT
OK, comment 7 deals with WPA, let's forget anything before comment 3 and stay with WEP.
Comment 9 Matěj Cepl 2008-10-08 18:32:29 EDT
This is what's called anticipatory breach by lawyers -- I have upgraded the copmuter to Fedora10Beta, so I cannot help here anymore.

Note You need to log in before you can comment on or make changes to this bug.