Bug 462993 - [ltsp?] kernel 2.6.26.x-y.fc9.x86_64: booting fails while trying to mount the root filesystem
[ltsp?] kernel 2.6.26.x-y.fc9.x86_64: booting fails while trying to mount the...
Status: CLOSED DUPLICATE of bug 462228
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 04:11 EDT by Axel Thimm
Modified: 2008-10-11 03:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-11 03:20:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-09-20 04:11:19 EDT
Description of problem:

Trying to boot into kernel 2.6.26.3-29.fc9.x86_64 fails with the below output.

Bringing up eth0
waiting for link... 0 seconds-
Sending request for IP information through rth0
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
Listening on LPF/eth0/00:1e:8c:fb:d8:cc
Sending on   LPF/eth0/00:1e:8c:fb:d8:cc
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 intervall 3
DHCPOFFER from 192.168.42.111
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.42.111
bound to 192.168.42.88 -- renewal in 8752 seconds.
Creating root device.
Could not find root-path dhcp option.
mkrootdev: could not determine nfs root target.
Mounting root filesystem.
mount: missing mount point
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev/failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Copying DHCP lease
cp: error opening /sysroot/dev/.dhclient-eth0.leases: No such file or directory
Mount failed for selinuxfs on /selinux: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Booting has failed

Version-Release number of selected component (if applicable):
kernel 2.6.26.3-29.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.yum update
2.reboot into new kernel
3.
  
Actual results:
See above. kernel does not boot.

Expected results:
kernel should properly boot

Additional info:
kernel-2.6.25.14-108 still boots OK.

The system in question is a plain Toshiba Satellite L40-16D with a RealTek 8149 network interface.

It is strange that the kernel suddenly does DHCP, pulling out the cable just induces some timeouts and finally the same failure results, and as there is a similar report w/o the DHCP part on bug 462201 comment 3 I think this is probably unrelated. Still since the output is weaved form the DHCP and the root fs mounting attempt I typed in the DHCP output as well.
Comment 1 Chuck Ebbert 2008-09-21 18:44:09 EDT
Is your root filesystem really on NFS? That's what it's trying to set up...
Comment 2 Axel Thimm 2008-09-21 23:21:36 EDT
No, it never was/is. Maybe the realtek driver in 2.6.26 is too eager to do nfsroots?
Comment 3 Axel Thimm 2008-10-03 02:51:23 EDT
The same happens with kernel-2.6.26.5-45.fc9.x86_64.
Comment 4 Chuck Ebbert 2008-10-09 22:25:16 EDT
This is apparently caused by having the ltsp-client installed. Do you have that installed?

If you erase ltsp-client and rebuild the initrd for the new kernel, everything should work.

If you don't know how to rebuild the initrd, just uninstall and reinstall the new kernel.
Comment 5 Axel Thimm 2008-10-09 23:56:24 EDT
Would

/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install  2.6.26.5-45.fc9.x86_64

be good enough (as outlined from rpm -q --scripts kernel-2.6.26.5-45.fc9.x86_64)?

I just noticed the /etc/kernel/*.d directories (while trying to understand how ltsp-client, which I indeed have installed, could influence the initrd). Is there some documentation on what these do? Thanks!
Comment 6 Axel Thimm 2008-10-10 07:44:14 EDT
I confirmed that removing the ltsp-client fixes this.

Is this a bug in ltsp-client (=> move component to ltsp), or is the error in front of my monitor (=> NOTABUG)?
Comment 7 John Ellson 2008-10-10 15:33:35 EDT
The ltsp-client issue has been fixed.  See BZ #462228
Comment 8 Axel Thimm 2008-10-11 03:20:26 EDT

*** This bug has been marked as a duplicate of bug 462228 ***

Note You need to log in before you can comment on or make changes to this bug.