Bug 463059 - Unapplied patch
Unapplied patch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: classpathx-jaf (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: F10FTBFS
  Show dependency treegraph
 
Reported: 2008-09-21 05:35 EDT by Ville Skyttä
Modified: 2009-01-12 10:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 10:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix Patch0:/%patch mismatch (1010 bytes, patch)
2008-09-21 05:35 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-09-21 05:35:48 EDT
Created attachment 317309 [details]
Fix Patch0:/%patch mismatch

This package was identified as one that was bit by a bug in Rawhide rpm:
https://www.redhat.com/archives/fedora-devel-list/2008-September/msg00375.html

The rpm bug has been fixed, so currently this is "only" a FTBFS bug for this package - no builds with the broken rpm have apparently been done or tagged for F-10.

Fix attached, I was not able to commit it myself due to CVS ACL restrictions.
Comment 1 Devrim GUNDUZ 2008-09-23 20:38:03 EDT
Applied to -devel, pushed for build.
Comment 2 Matt Domsch 2008-10-28 22:56:15 EDT
Note, this still fails to build in koji.

http://koji.fedoraproject.org/koji/getfile?taskID=899136&name=build.log

/usr/lib/jvm/java/bin/javac -g -classpath ./classes:./source -d ./classes source/javax/activation/MimeType.java
----------
1. ERROR in source/javax/activation/MimeType.java (at line 256)
	throw new MimeTypeParseException(message, token);
	      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The constructor MimeTypeParseException(String, String) is undefined
----------
2. ERROR in source/javax/activation/MimeType.java (at line 261)
	throw new MimeTypeParseException(message, token);
	      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The constructor MimeTypeParseException(String, String) is undefined
----------
2 problems (2 errors)
make: *** [classes/javax/activation/MimeType.class] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.w9qm7J (%build)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.w9qm7J (%build)
Child returncode was: 1
Comment 3 Bug Zapper 2008-11-25 22:10:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Stepan Kasal 2009-01-12 10:58:24 EST
The patch is now present in the CVS, both in the Fedora 10 and rawhide branch.

The package has not been rebuilt since that (see FTBFS bug #479701), but the latest sucessful build in koji predates bug #461347, so we can happily close this bug.

Note You need to log in before you can comment on or make changes to this bug.