Bug 463113 - Xorg freezes with black display on Lenovo X200, Cantiga chipset
Xorg freezes with black display on Lenovo X200, Cantiga chipset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 463294 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-21 17:27 EDT by Bryan O'Sullivan
Modified: 2009-10-22 08:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 14:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci.out (21.17 KB, text/plain)
2008-09-21 17:27 EDT, Bryan O'Sullivan
no flags Details
Xorg.0.log from running Xorg -probeonly (14.54 KB, text/plain)
2008-09-21 17:28 EDT, Bryan O'Sullivan
no flags Details
Xorg.0.log (55.18 KB, text/plain)
2008-10-03 12:32 EDT, Zack Cerza
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17507 None None None Never
FreeDesktop.org 17703 None None None Never
Launchpad 263114 None None None Never

  None (edit)
Description Bryan O'Sullivan 2008-09-21 17:27:16 EDT
Created attachment 317327 [details]
lspci.out

Description of problem:

If I try to start X on a new Lenovo X200 laptop, the display is frozen black and I cannot kill the X server or switch to a different virtual console.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.5.0-6.fc10.x86_64
xorg-x11-drv-i810-2.4.2-8.fc10.x86_64

How reproducible:

100%

Additional info:

lspci reports that 00:02.0 and 00:02.1 are an Intel Cantiga Integrated Graphics Controller (rev 07).
Comment 1 Bryan O'Sullivan 2008-09-21 17:28:06 EDT
Created attachment 317328 [details]
Xorg.0.log from running Xorg -probeonly
Comment 2 Bryan O'Sullivan 2008-09-21 17:31:23 EDT
This is a known bug in other distros too, e.g. Ubuntu: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/263114
Comment 3 Bryan O'Sullivan 2008-09-21 17:35:48 EDT
See also https://bugzilla.redhat.com/show_bug.cgi?id=457208
Comment 4 Bryan O'Sullivan 2008-09-21 17:37:35 EDT
Upstream bug: http://bugs.freedesktop.org/show_bug.cgi?id=17507
Comment 5 Bryan O'Sullivan 2008-09-21 23:06:56 EDT
Intel people wanted me to open another bug: http://bugs.freedesktop.org/show_bug.cgi?id=17703
Comment 6 Zack Cerza 2008-10-03 12:26:04 EDT
*** Bug 463294 has been marked as a duplicate of this bug. ***
Comment 7 Zack Cerza 2008-10-03 12:32:16 EDT
Created attachment 319390 [details]
Xorg.0.log

Updated several packages and I'm still seeing the problem. Log output has changed, though. Hundreds of lines of this:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

kernel-2.6.27-0.382.rc8.git4.fc10.x86_64
xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
libdrm-2.4.0-0.21.fc10.x86_64
Comment 8 Bryan O'Sullivan 2008-10-03 13:33:25 EDT
I actually have the intel Xorg driver working at the moment, but Jeremy says that it can't handle a suspend/resume cycle.
Comment 9 Jeremy Fitzhardinge 2008-10-06 19:08:34 EDT
For me, I can't only get the intel driver working if I run the vesa driver, edit xorg.conf and restart X.  On reboot with the intel driver, I just get a black screen.

When I does work, suspend/resume nearly works.  It resumes, and X pops up enough that I can see and move the pointer a bit, then it crashes shortly after.

This is with kernel-2.6.27-0.391.rc8.git7.fc10.x86_64, xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
Comment 10 Bryan O'Sullivan 2008-10-12 15:48:25 EDT
This has every sign of a kernel bug.  The intel driver works for me if I disable acceleration in xorg.conf, but freezes otherwise.

Are there bad GEM bits in the current patched rawhide kernel?
Comment 11 Zack Cerza 2008-10-15 10:30:44 EDT
Agreed; reassigning.
Comment 12 Zack Cerza 2008-10-16 14:32:49 EDT
Looks like one or both of these fixed it:

kernel-2.6.27-13.fc10
xorg-x11-drv-i810-2.4.2-12.fc10

Thanks, Dave!

Note You need to log in before you can comment on or make changes to this bug.