Bug 463120 - b43 driver unstable on PowerPC
b43 driver unstable on PowerPC
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On: 469502
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 18:38 EDT by W. Michael Petullo
Modified: 2009-05-24 20:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 11:13:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmesg following a network hang (24.89 KB, text/plain)
2008-11-18 20:16 EST, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2008-09-21 18:38:49 EDT
Description of problem:
I have found that the b43 driver is unstable when it processes a lot of network data. Eventually network access will hang.

Version-Release number of selected component (if applicable):
kernel-2.6.27-0.329.rc6.git2.fc10.ppc

How reproducible:
Everytime

Steps to Reproduce:
1. Configure b43 to use WPA. Works fine for a while.
2. Store a very large mailspool (240+ MB) on an NFS share.
3. Open the mail spool using mutt. 
  
Actual results:
Mutt will display the progress as it reads the mail spool over the network. Eventually, this will hang. Once this happens, the wireless network connection is no longer usable. Trying to "ifdown / ifup" the connection fails (no reply to DHCPDISCOVER). I am unable to ifup my wireless network until I reboot.

Expected results:
The network connectivity should be stable.

Additional info:
I am using a PowerPC G4 iBook with a Broadcom 4306 chipset (Airport Extreme).
Comment 1 John W. Linville 2008-10-23 13:37:19 EDT
Are you using NetworkManager?  Please post the output of "service NetworkManager status".
Comment 2 W. Michael Petullo 2008-10-24 20:10:33 EDT
(In reply to comment #1)
> Are you using NetworkManager?  Please post the output of "service
> NetworkManager status".

Not really. I have tried to configure NetworkManager but need my network to work before I log in (I use Kerberos, etc.). This is broken; see bug #448760.

I use "ifup wlan0" to bring my network interface up manually.
Comment 3 John W. Linville 2008-10-25 10:11:55 EDT
Then you need to make sure you have disable NetworkManager:

   chkconfig NetworkManager off # disable it starting at boot
   service NetworkManager stop # turn it off now

A reboot after that wouldn't hurt either.
Comment 4 W. Michael Petullo 2008-10-25 13:25:29 EDT
> Then you need to make sure you have disable NetworkManager:
> 
>    chkconfig NetworkManager off # disable it starting at boot
>    service NetworkManager stop # turn it off now
> 
> A reboot after that wouldn't hurt either.

Okay, I did that. However, I don't see why this would help. As I said, I'm bringing up the interface manually. I open mutt, and try to open a big mail spool over NFS. It starts loading, then hangs. Once the mail spool hangs, the interface in no longer responsive. It can't even be brought down and back up again.

I'm unable to test this at the moment because the most recent ppc kernel package crashes on boot.
Comment 5 John W. Linville 2008-10-27 10:48:14 EDT
NetworkManager thinks it "owns" the interface.  When it is running and you try to configure the interface manually, then you have two entities trying to control the interface at the same time.  So if you want to configure it manually, you need to make sure to disable NetworkManager.

Where did you get the firmware you are using for b43?
Comment 6 W. Michael Petullo 2008-11-01 12:33:19 EDT
I am using firmware broadcom-wl-4.150.10.5, from (as I remember) http://downloads.openwrt.org.

I understand your comments regarding NetworkManager. I'm pretty certain my troubleshooting took into account the dynamics of NetworkManager vs. manual interface configuration.

The b43 driver as been flakey for me since it has existed. But, being that I am on PowerPC, I have to accept that my hardware is not quite the most common. In fact, I am having other problems with the PowerPC kernel right now, too.

I will keep updating this with additional information as I can.
Comment 7 W. Michael Petullo 2008-11-06 20:39:28 EST
This may be due to some kind of interaction with my wireless router, a Belkin Wireless G Router with the latest firmware installed.

I now have two computers on my wireless network: my iBook (Fedora) and an iMac (Mac OS X).

When my iBook's wireless interface freezes as described above, the iMac's interface does too. I have to restart the router to fix this.

I have installed mutt on my Mac OS X iMac. I can open the big NFS mailspool just fine from this machine. When I try to do the same using my iBook / Fedora, the process fails as documented in the original report.

So, either:

1) This is simply a problem in my wireless router

or:

2) There is a problem in the b43 driver that is causing, e.g., a bad frame to exasperate a problem in my router.

Either way, this is difficult to debug.
Comment 8 John W. Linville 2008-11-07 11:06:37 EST
It is possible that whatever is happening causes your b43 device to generate interference on the network.  It might be interesting to know what happens if you hit your rfkill button/switch after the hang to see if it restores communications between your router and the iMac.

Please attach the output of dmesg and/or the contents of /var/log/messages directly after the network hang.  Also, please include the output of the 'lspci -n' command.
Comment 9 W. Michael Petullo 2008-11-18 20:16:34 EST
Created attachment 323986 [details]
Output from dmesg following a network hang

/var/log/messages has nothing interesting logged at the time of the hang.

lspci -n:

0000:00:0b.0 0600: 106b:0034
0000:00:10.0 0300: 1002:5c63 (rev 01)
0001:10:0b.0 0600: 106b:0035
0001:10:12.0 0280: 14e4:4320 (rev 03)
0001:10:17.0 ff00: 106b:003e
0001:10:18.0 0c03: 106b:003f
0001:10:19.0 0c03: 106b:003f
0001:10:1a.0 0c03: 106b:003f
0001:10:1b.0 0c03: 1033:0035 (rev 43)
0001:10:1b.1 0c03: 1033:0035 (rev 43)
0001:10:1b.2 0c03: 1033:00e0 (rev 04)
0002:20:0b.0 0600: 106b:0036
0002:20:0d.0 ff00: 106b:003b
0002:20:0e.0 0c00: 106b:0031 (rev 81)
0002:20:0f.0 0200: 106b:0032 (rev ff)
Comment 10 Bug Zapper 2008-11-25 22:10:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 John W. Linville 2009-02-13 14:54:27 EST
Are you still experiencing this issue?  What is the latest kernel you have tried?  I've been using b43 quite a lot lately with kernels basically equivalent to rawhide, and I'm not really seeing any problems like this.
Comment 12 W. Michael Petullo 2009-02-13 22:32:30 EST
I still have the problem (Fedora 10 up to date as of 13 Feb 09). I'd like to test against a different wireless router, but have not yet been able to do this.
Comment 13 John W. Linville 2009-03-04 14:43:43 EST
OK, can you give some more objective definition to the problem?  What messages do you see in /var/log/messages?  What exactly do you do to experience the problem?
Comment 14 John W. Linville 2009-04-27 11:13:22 EDT
Closing due to lack of response...
Comment 15 W. Michael Petullo 2009-05-24 20:45:38 EDT
This seems to have been a bug in my wireless router (Belkin Wireless G Router), not the kernel.

Note You need to log in before you can comment on or make changes to this bug.